summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorThomas Matthijs <axxo@gentoo.org>2005-07-15 13:34:11 +0000
committerThomas Matthijs <axxo@gentoo.org>2005-07-15 13:34:11 +0000
commit18ee4b450c6a90c4243a17bd397ec5d8edc8509b (patch)
tree9688fd123e2268ca27aaeef5be98fb34344a33b9 /dev-java/java-getopt
parentRemove old ebuild. (diff)
downloadgentoo-2-18ee4b450c6a90c4243a17bd397ec5d8edc8509b.tar.gz
gentoo-2-18ee4b450c6a90c4243a17bd397ec5d8edc8509b.tar.bz2
gentoo-2-18ee4b450c6a90c4243a17bd397ec5d8edc8509b.zip
Dep fixes
(Portage version: 2.0.51.22-r1)
Diffstat (limited to 'dev-java/java-getopt')
-rw-r--r--dev-java/java-getopt/java-getopt-1.0.10.ebuild7
-rw-r--r--dev-java/java-getopt/java-getopt-1.0.9.ebuild7
2 files changed, 8 insertions, 6 deletions
diff --git a/dev-java/java-getopt/java-getopt-1.0.10.ebuild b/dev-java/java-getopt/java-getopt-1.0.10.ebuild
index 723faa7c6e82..5908cebc4414 100644
--- a/dev-java/java-getopt/java-getopt-1.0.10.ebuild
+++ b/dev-java/java-getopt/java-getopt-1.0.10.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2005 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-java/java-getopt/java-getopt-1.0.10.ebuild,v 1.2 2005/02/04 23:33:05 luckyduck Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-java/java-getopt/java-getopt-1.0.10.ebuild,v 1.3 2005/07/15 13:34:11 axxo Exp $
inherit java-pkg
@@ -10,7 +10,8 @@ SRC_URI="ftp://ftp.urbanophile.com/pub/arenn/software/sources/java-getopt-${PV}.
LICENSE="LGPL-2.1"
SLOT="1"
DEPEND=">=virtual/jdk-1.2
- >=dev-java/ant-1.4.1"
+ dev-java/ant-core"
+RDEPEND=">=virtual/jre-1.2"
KEYWORDS="x86 ~ppc amd64"
IUSE=""
@@ -21,7 +22,7 @@ src_compile() {
ant all || die "failed to build"
}
-src_install () {
+src_install() {
java-pkg_dojar build/lib/gnu.getopt.jar
java-pkg_dohtml -r build/api/*
dodoc gnu/getopt/COPYING.LIB gnu/getopt/ChangeLog gnu/getopt/README
diff --git a/dev-java/java-getopt/java-getopt-1.0.9.ebuild b/dev-java/java-getopt/java-getopt-1.0.9.ebuild
index 5667dba97522..e9a47a4b0cc5 100644
--- a/dev-java/java-getopt/java-getopt-1.0.9.ebuild
+++ b/dev-java/java-getopt/java-getopt-1.0.9.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2005 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-java/java-getopt/java-getopt-1.0.9.ebuild,v 1.9 2005/02/04 23:33:05 luckyduck Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-java/java-getopt/java-getopt-1.0.9.ebuild,v 1.10 2005/07/15 13:34:11 axxo Exp $
inherit java-pkg
@@ -10,7 +10,8 @@ SRC_URI="ftp://ftp.urbanophile.com/pub/arenn/software/sources/java-getopt-${PV}.
LICENSE="LGPL-2.1"
SLOT="1"
DEPEND=">=virtual/jdk-1.2
- >=dev-java/ant-1.4.1"
+ dev-java/ant-core"
+RDEPEND=">=virtual/jre-1.2"
KEYWORDS="x86 ppc"
IUSE=""
@@ -21,7 +22,7 @@ src_compile() {
ant all || die "failed to build"
}
-src_install () {
+src_install() {
java-pkg_dojar build/lib/gnu.getopt.jar
java-pkg_dohtml -r build/api/*
dodoc gnu/getopt/COPYING.LIB gnu/getopt/ChangeLog gnu/getopt/README