summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSerkan Kaba <serkan@gentoo.org>2011-03-12 20:09:25 +0000
committerSerkan Kaba <serkan@gentoo.org>2011-03-12 20:09:25 +0000
commit0ecafde9a85746fead93a5e26b45b91be156ee38 (patch)
tree13c5fcc65f98c5ef443458c2461ec5045817fc3b /dev-java/jcifs
parentalpha/ia64/sparc stable wrt #353436 (diff)
downloadgentoo-2-0ecafde9a85746fead93a5e26b45b91be156ee38.tar.gz
gentoo-2-0ecafde9a85746fead93a5e26b45b91be156ee38.tar.bz2
gentoo-2-0ecafde9a85746fead93a5e26b45b91be156ee38.zip
Version bump.
(Portage version: 2.2.0_alpha26/cvs/Linux x86_64)
Diffstat (limited to 'dev-java/jcifs')
-rw-r--r--dev-java/jcifs/ChangeLog9
-rw-r--r--dev-java/jcifs/jcifs-1.3.15.ebuild40
2 files changed, 47 insertions, 2 deletions
diff --git a/dev-java/jcifs/ChangeLog b/dev-java/jcifs/ChangeLog
index 90a391323391..d6a50f89c57d 100644
--- a/dev-java/jcifs/ChangeLog
+++ b/dev-java/jcifs/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for dev-java/jcifs
-# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-java/jcifs/ChangeLog,v 1.24 2010/05/24 14:59:40 caster Exp $
+# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/dev-java/jcifs/ChangeLog,v 1.25 2011/03/12 20:09:25 serkan Exp $
+
+*jcifs-1.3.15 (12 Mar 2011)
+
+ 12 Mar 2011; Serkan Kaba <serkan@gentoo.org> +jcifs-1.3.15.ebuild:
+ Version bump.
24 May 2010; Vlastimil Babka <caster@gentoo.org> -jcifs-1.3.2.ebuild:
Remove old.
diff --git a/dev-java/jcifs/jcifs-1.3.15.ebuild b/dev-java/jcifs/jcifs-1.3.15.ebuild
new file mode 100644
index 000000000000..aff82b61f9e7
--- /dev/null
+++ b/dev-java/jcifs/jcifs-1.3.15.ebuild
@@ -0,0 +1,40 @@
+# Copyright 1999-2011 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-java/jcifs/jcifs-1.3.15.ebuild,v 1.1 2011/03/12 20:09:25 serkan Exp $
+
+EAPI="2"
+JAVA_PKG_IUSE="doc examples source"
+
+inherit eutils java-pkg-2 java-ant-2
+
+DESCRIPTION="Library that implements the CIFS/SMB networking protocol in Java"
+SRC_URI="http://jcifs.samba.org/src/${P}.tgz"
+HOMEPAGE="http://jcifs.samba.org/"
+LICENSE="LGPL-2.1"
+SLOT="1.1"
+KEYWORDS="~amd64 ~ppc ~ppc64 ~x86 ~x86-fbsd"
+RDEPEND=">=virtual/jre-1.4
+ dev-java/servletapi:2.4"
+DEPEND=">=virtual/jdk-1.4
+ ${RDEPEND}"
+IUSE=""
+
+S=${WORKDIR}/${P/-/_}
+
+java_prepare() {
+ rm -v *.jar || die
+}
+
+JAVA_ANT_REWRITE_CLASSPATH="true"
+EANT_EXTRA_ARGS="-DhasServlet=true"
+EANT_GENTOO_CLASSPATH="servletapi-2.4"
+
+src_install() {
+ java-pkg_newjar ${P}.jar
+
+ dodoc README.txt || die
+ # other stuff besides javadocs
+ use doc && java-pkg_dohtml -r docs/*
+ use source && java-pkg_dosrc src/*
+ use examples && java-pkg_doexamples examples
+}