summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAron Griffis <agriffis@gentoo.org>2005-10-18 20:22:25 +0000
committerAron Griffis <agriffis@gentoo.org>2005-10-18 20:22:25 +0000
commit924360744b63bc47157cd1a51863e4bba01fdb61 (patch)
treec61b3d8577718393a883c78adc6e398d76a4f357 /dev-java/sun-jdk
parentadd back browserplugin, marked as deprecated (diff)
downloadgentoo-2-924360744b63bc47157cd1a51863e4bba01fdb61.tar.gz
gentoo-2-924360744b63bc47157cd1a51863e4bba01fdb61.tar.bz2
gentoo-2-924360744b63bc47157cd1a51863e4bba01fdb61.zip
Warn about deprecated browserplugin useflag
(Portage version: 2.0.53_rc5)
Diffstat (limited to 'dev-java/sun-jdk')
-rw-r--r--dev-java/sun-jdk/ChangeLog8
-rw-r--r--dev-java/sun-jdk/sun-jdk-1.3.1.13.ebuild15
-rw-r--r--dev-java/sun-jdk/sun-jdk-1.3.1.16.ebuild15
-rw-r--r--dev-java/sun-jdk/sun-jdk-1.4.2.08-r1.ebuild17
-rw-r--r--dev-java/sun-jdk/sun-jdk-1.4.2.08.ebuild17
-rw-r--r--dev-java/sun-jdk/sun-jdk-1.4.2.09.ebuild17
-rw-r--r--dev-java/sun-jdk/sun-jdk-1.5.0.04.ebuild17
-rw-r--r--dev-java/sun-jdk/sun-jdk-1.5.0.05.ebuild17
8 files changed, 81 insertions, 42 deletions
diff --git a/dev-java/sun-jdk/ChangeLog b/dev-java/sun-jdk/ChangeLog
index 5f57cba86442..94aa60045781 100644
--- a/dev-java/sun-jdk/ChangeLog
+++ b/dev-java/sun-jdk/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for dev-java/sun-jdk
# Copyright 2002-2005 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-java/sun-jdk/ChangeLog,v 1.124 2005/10/18 19:25:14 agriffis Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-java/sun-jdk/ChangeLog,v 1.125 2005/10/18 20:22:01 agriffis Exp $
+
+ 18 Oct 2005; Aron Griffis <agriffis@gentoo.org> sun-jdk-1.3.1.13.ebuild,
+ sun-jdk-1.3.1.16.ebuild, sun-jdk-1.4.2.08.ebuild,
+ sun-jdk-1.4.2.08-r1.ebuild, sun-jdk-1.4.2.09.ebuild,
+ sun-jdk-1.5.0.04.ebuild, sun-jdk-1.5.0.05.ebuild:
+ Warn about deprecated browserplugin useflag
18 Oct 2005; Aron Griffis <agriffis@gentoo.org> sun-jdk-1.3.1.13.ebuild,
sun-jdk-1.3.1.16.ebuild, sun-jdk-1.4.2.08.ebuild,
diff --git a/dev-java/sun-jdk/sun-jdk-1.3.1.13.ebuild b/dev-java/sun-jdk/sun-jdk-1.3.1.13.ebuild
index ec7220d951f0..8db380c995eb 100644
--- a/dev-java/sun-jdk/sun-jdk-1.3.1.13.ebuild
+++ b/dev-java/sun-jdk/sun-jdk-1.3.1.13.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2005 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-java/sun-jdk/sun-jdk-1.3.1.13.ebuild,v 1.12 2005/10/18 19:25:14 agriffis Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-java/sun-jdk/sun-jdk-1.3.1.13.ebuild,v 1.13 2005/10/18 20:22:01 agriffis Exp $
inherit java eutils
@@ -24,7 +24,7 @@ SLOT="1.3"
KEYWORDS="x86 -*"
RESTRICT="fetch"
-IUSE="doc nsplugin mozilla"
+IUSE="doc browserplugin nsplugin mozilla"
# this is needed for proper operating under a PaX kernel without activated grsecurity acl
CHPAX_CONSERVATIVE_FLAGS="pemsv"
@@ -87,7 +87,9 @@ src_install() {
dodir /opt/${P}/share/
cp -a demo src.jar ${D}/opt/${P}/share/
- if use nsplugin || use mozilla; then
+ if use nsplugin || # global useflag for netscape-compat plugins
+ use browserplugin || # deprecated but honor for now
+ use mozilla; then # wrong but used to honor it
install_mozilla_plugin /opt/${P}/jre/plugin/i386/ns600/libjavaplugin_oji.so
fi
@@ -98,6 +100,13 @@ pkg_postinst () {
# Set as default VM if none exists
java_pkg_postinst
+ if ! use nsplugin && ( use browserplugin || use mozilla ); then
+ echo
+ ewarn "The 'browserplugin' and 'mozilla' useflags will not be honored in"
+ ewarn "future jdk/jre ebuilds for plugin installation. Please"
+ ewarn "update your USE to include 'nsplugin'."
+ fi
+
# if chpax is on the target system, set the appropriate PaX flags
# this will not hurt the binary, it modifies only unused ELF bits
# but may confuse things like AV scanners and automatic tripwire
diff --git a/dev-java/sun-jdk/sun-jdk-1.3.1.16.ebuild b/dev-java/sun-jdk/sun-jdk-1.3.1.16.ebuild
index c46daaac07b7..d0d1688a7078 100644
--- a/dev-java/sun-jdk/sun-jdk-1.3.1.16.ebuild
+++ b/dev-java/sun-jdk/sun-jdk-1.3.1.16.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2005 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-java/sun-jdk/sun-jdk-1.3.1.16.ebuild,v 1.2 2005/10/18 19:25:14 agriffis Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-java/sun-jdk/sun-jdk-1.3.1.16.ebuild,v 1.3 2005/10/18 20:22:01 agriffis Exp $
inherit java eutils
@@ -24,7 +24,7 @@ SLOT="1.3"
KEYWORDS="x86 -*"
RESTRICT="fetch"
-IUSE="doc nsplugin mozilla"
+IUSE="doc browserplugin nsplugin mozilla"
# this is needed for proper operating under a PaX kernel without activated grsecurity acl
CHPAX_CONSERVATIVE_FLAGS="pemsv"
@@ -87,7 +87,9 @@ src_install() {
dodir /opt/${P}/share/
cp -a demo src.jar ${D}/opt/${P}/share/
- if use nsplugin || use mozilla; then
+ if use nsplugin || # global useflag for netscape-compat plugins
+ use browserplugin || # deprecated but honor for now
+ use mozilla; then # wrong but used to honor it
install_mozilla_plugin /opt/${P}/jre/plugin/i386/ns600/libjavaplugin_oji.so
fi
@@ -98,6 +100,13 @@ pkg_postinst () {
# Set as default VM if none exists
java_pkg_postinst
+ if ! use nsplugin && ( use browserplugin || use mozilla ); then
+ echo
+ ewarn "The 'browserplugin' and 'mozilla' useflags will not be honored in"
+ ewarn "future jdk/jre ebuilds for plugin installation. Please"
+ ewarn "update your USE to include 'nsplugin'."
+ fi
+
# if chpax is on the target system, set the appropriate PaX flags
# this will not hurt the binary, it modifies only unused ELF bits
# but may confuse things like AV scanners and automatic tripwire
diff --git a/dev-java/sun-jdk/sun-jdk-1.4.2.08-r1.ebuild b/dev-java/sun-jdk/sun-jdk-1.4.2.08-r1.ebuild
index 0b2950fab80c..866d4cc1d1fa 100644
--- a/dev-java/sun-jdk/sun-jdk-1.4.2.08-r1.ebuild
+++ b/dev-java/sun-jdk/sun-jdk-1.4.2.08-r1.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2005 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-java/sun-jdk/sun-jdk-1.4.2.08-r1.ebuild,v 1.7 2005/10/18 19:25:14 agriffis Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-java/sun-jdk/sun-jdk-1.4.2.08-r1.ebuild,v 1.8 2005/10/18 20:22:01 agriffis Exp $
inherit java eutils
@@ -20,7 +20,7 @@ SLOT="1.4"
LICENSE="sun-bcla-java-vm"
KEYWORDS="-* x86"
RESTRICT="fetch"
-IUSE="doc nsplugin jce mozilla"
+IUSE="doc browserplugin nsplugin jce mozilla"
#glibc dep: #102423
DEPEND=">=dev-java/java-config-1.1.5
@@ -123,7 +123,9 @@ src_install() {
dosym /opt/${P}/jre/lib/security/unlimited-jce/local_policy.jar /opt/${P}/jre/lib/security/
fi
- if use nsplugin || use mozilla; then
+ if use nsplugin || # global useflag for netscape-compat plugins
+ use browserplugin || # deprecated but honor for now
+ use mozilla; then # wrong but used to honor it
local plugin_dir="ns610"
if has_version '>=sys-devel/gcc-3.2' ; then
plugin_dir="ns610-gcc32"
@@ -196,9 +198,10 @@ pkg_postinst() {
eerror "Some parts of Sun's JDK require virtual/x11 to be installed."
eerror "Be careful which Java libraries you attempt to use."
- if ! use nsplugin && use mozilla; then
- ewarn
- ewarn "The 'mozilla' useflag to enable the java browser plugin for applets"
- ewarn "has been renamed to 'nsplugin' please update your USE"
+ if ! use nsplugin && ( use browserplugin || use mozilla ); then
+ echo
+ ewarn "The 'browserplugin' and 'mozilla' useflags will not be honored in"
+ ewarn "future jdk/jre ebuilds for plugin installation. Please"
+ ewarn "update your USE to include 'nsplugin'."
fi
}
diff --git a/dev-java/sun-jdk/sun-jdk-1.4.2.08.ebuild b/dev-java/sun-jdk/sun-jdk-1.4.2.08.ebuild
index ee19fa620e56..f2d83f5507c3 100644
--- a/dev-java/sun-jdk/sun-jdk-1.4.2.08.ebuild
+++ b/dev-java/sun-jdk/sun-jdk-1.4.2.08.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2005 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-java/sun-jdk/sun-jdk-1.4.2.08.ebuild,v 1.10 2005/10/18 19:25:14 agriffis Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-java/sun-jdk/sun-jdk-1.4.2.08.ebuild,v 1.11 2005/10/18 20:22:01 agriffis Exp $
inherit java eutils
@@ -20,7 +20,7 @@ SLOT="1.4"
LICENSE="sun-bcla-java-vm"
KEYWORDS="x86 -*"
RESTRICT="fetch"
-IUSE="doc nsplugin jce mozilla"
+IUSE="doc browserplugin nsplugin jce mozilla"
#glibc dep: #102423
DEPEND=">=dev-java/java-config-1.1.5
@@ -116,7 +116,9 @@ src_install() {
dosym /opt/${P}/jre/lib/security/unlimited-jce/local_policy.jar /opt/${P}/jre/lib/security/
fi
- if use nsplugin || use mozilla; then
+ if use nsplugin || # global useflag for netscape-compat plugins
+ use browserplugin || # deprecated but honor for now
+ use mozilla; then # wrong but used to honor it
local plugin_dir="ns610"
if has_version '>=sys-devel/gcc-3.2' ; then
plugin_dir="ns610-gcc32"
@@ -189,9 +191,10 @@ pkg_postinst() {
eerror "Some parts of Sun's JDK require virtual/x11 to be installed."
eerror "Be careful which Java libraries you attempt to use."
- if ! use nsplugin && use mozilla; then
- ewarn
- ewarn "The 'mozilla' useflag to enable the java browser plugin for applets"
- ewarn "has been renamed to 'nsplugin' please update your USE"
+ if ! use nsplugin && ( use browserplugin || use mozilla ); then
+ echo
+ ewarn "The 'browserplugin' and 'mozilla' useflags will not be honored in"
+ ewarn "future jdk/jre ebuilds for plugin installation. Please"
+ ewarn "update your USE to include 'nsplugin'."
fi
}
diff --git a/dev-java/sun-jdk/sun-jdk-1.4.2.09.ebuild b/dev-java/sun-jdk/sun-jdk-1.4.2.09.ebuild
index c74a8b838a35..99309085cebb 100644
--- a/dev-java/sun-jdk/sun-jdk-1.4.2.09.ebuild
+++ b/dev-java/sun-jdk/sun-jdk-1.4.2.09.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2005 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-java/sun-jdk/sun-jdk-1.4.2.09.ebuild,v 1.7 2005/10/18 19:25:14 agriffis Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-java/sun-jdk/sun-jdk-1.4.2.09.ebuild,v 1.8 2005/10/18 20:22:01 agriffis Exp $
inherit java eutils
@@ -20,7 +20,7 @@ SLOT="1.4"
LICENSE="sun-bcla-java-vm"
KEYWORDS="-* x86"
RESTRICT="fetch"
-IUSE="doc nsplugin jce mozilla"
+IUSE="doc browserplugin nsplugin jce mozilla"
#glibc dep: #102423
DEPEND=">=dev-java/java-config-1.1.5
@@ -123,7 +123,9 @@ src_install() {
dosym /opt/${P}/jre/lib/security/unlimited-jce/local_policy.jar /opt/${P}/jre/lib/security/
fi
- if use nsplugin || use mozilla; then
+ if use nsplugin || # global useflag for netscape-compat plugins
+ use browserplugin || # deprecated but honor for now
+ use mozilla; then # wrong but used to honor it
local plugin_dir="ns610"
if has_version '>=sys-devel/gcc-3.2' ; then
plugin_dir="ns610-gcc32"
@@ -196,9 +198,10 @@ pkg_postinst() {
eerror "Some parts of Sun's JDK require virtual/x11 to be installed."
eerror "Be careful which Java libraries you attempt to use."
- if ! use nsplugin && use mozilla; then
- ewarn
- ewarn "The 'mozilla' useflag to enable the java browser plugin for applets"
- ewarn "has been renamed to 'nsplugin' please update your USE"
+ if ! use nsplugin && ( use browserplugin || use mozilla ); then
+ echo
+ ewarn "The 'browserplugin' and 'mozilla' useflags will not be honored in"
+ ewarn "future jdk/jre ebuilds for plugin installation. Please"
+ ewarn "update your USE to include 'nsplugin'."
fi
}
diff --git a/dev-java/sun-jdk/sun-jdk-1.5.0.04.ebuild b/dev-java/sun-jdk/sun-jdk-1.5.0.04.ebuild
index 905fa7eab71f..50e8cde0767c 100644
--- a/dev-java/sun-jdk/sun-jdk-1.5.0.04.ebuild
+++ b/dev-java/sun-jdk/sun-jdk-1.5.0.04.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2005 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-java/sun-jdk/sun-jdk-1.5.0.04.ebuild,v 1.6 2005/10/18 19:25:14 agriffis Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-java/sun-jdk/sun-jdk-1.5.0.04.ebuild,v 1.7 2005/10/18 20:22:01 agriffis Exp $
inherit java eutils
@@ -27,7 +27,7 @@ SLOT="1.5"
LICENSE="sun-bcla-java-vm"
KEYWORDS="~x86 ~amd64 -*"
RESTRICT="fetch nostrip"
-IUSE="doc nsplugin jce mozilla"
+IUSE="doc browserplugin nsplugin jce mozilla"
#
DEPEND=">=dev-java/java-config-1.2
@@ -129,7 +129,9 @@ src_install() {
dosym /opt/${P}/jre/lib/security/unlimited-jce/local_policy.jar /opt/${P}/jre/lib/security/
fi
- if use nsplugin || use mozilla; then
+ if use nsplugin || # global useflag for netscape-compat plugins
+ use browserplugin || # deprecated but honor for now
+ use mozilla; then # wrong but used to honor it
local plugin_dir="ns7-gcc29"
if has_version '>=sys-devel/gcc-3' ; then
plugin_dir="ns7"
@@ -218,9 +220,10 @@ pkg_postinst() {
einfo " are not valid identifiers any more in that mode,"
einfo " which can cause incompatibility with certain sources."
- if ! use nsplugin && use mozilla; then
- ewarn
- ewarn "The 'mozilla' useflag to enable the java browser plugin for applets"
- ewarn "has been renamed to 'nsplugin' please update your USE"
+ if ! use nsplugin && ( use browserplugin || use mozilla ); then
+ echo
+ ewarn "The 'browserplugin' and 'mozilla' useflags will not be honored in"
+ ewarn "future jdk/jre ebuilds for plugin installation. Please"
+ ewarn "update your USE to include 'nsplugin'."
fi
}
diff --git a/dev-java/sun-jdk/sun-jdk-1.5.0.05.ebuild b/dev-java/sun-jdk/sun-jdk-1.5.0.05.ebuild
index 99f3f15edd9d..0eaf7148a010 100644
--- a/dev-java/sun-jdk/sun-jdk-1.5.0.05.ebuild
+++ b/dev-java/sun-jdk/sun-jdk-1.5.0.05.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2005 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-java/sun-jdk/sun-jdk-1.5.0.05.ebuild,v 1.3 2005/10/18 19:25:14 agriffis Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-java/sun-jdk/sun-jdk-1.5.0.05.ebuild,v 1.4 2005/10/18 20:22:01 agriffis Exp $
inherit java eutils
@@ -27,7 +27,7 @@ SLOT="1.5"
LICENSE="sun-bcla-java-vm"
KEYWORDS="~x86 ~amd64 -*"
RESTRICT="fetch nostrip"
-IUSE="doc nsplugin jce mozilla"
+IUSE="doc browserplugin nsplugin jce mozilla"
#
DEPEND=">=dev-java/java-config-1.2
@@ -137,7 +137,9 @@ src_install() {
dosym /opt/${P}/jre/lib/security/unlimited-jce/local_policy.jar /opt/${P}/jre/lib/security/
fi
- if use nsplugin || use mozilla; then
+ if use nsplugin || # global useflag for netscape-compat plugins
+ use browserplugin || # deprecated but honor for now
+ use mozilla; then # wrong but used to honor it
local plugin_dir="ns7-gcc29"
if has_version '>=sys-devel/gcc-3' ; then
plugin_dir="ns7"
@@ -226,9 +228,10 @@ pkg_postinst() {
einfo " are not valid identifiers any more in that mode,"
einfo " which can cause incompatibility with certain sources."
- if ! use nsplugin && use mozilla; then
- ewarn
- ewarn "The 'mozilla' useflag to enable the java browser plugin for applets"
- ewarn "has been renamed to 'nsplugin' please update your USE."
+ if ! use nsplugin && ( use browserplugin || use mozilla ); then
+ echo
+ ewarn "The 'browserplugin' and 'mozilla' useflags will not be honored in"
+ ewarn "future jdk/jre ebuilds for plugin installation. Please"
+ ewarn "update your USE to include 'nsplugin'."
fi
}