summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSebastien Fabbro <bicatali@gentoo.org>2007-11-22 00:20:38 +0000
committerSebastien Fabbro <bicatali@gentoo.org>2007-11-22 00:20:38 +0000
commit4d3f5bc54a2672c0b19e2add34c27a1bd3c0949f (patch)
tree37945f5564b9f457afebe0a958344f20c5f056bb /dev-lang/R
parentstable x86, bug 199571 (diff)
downloadgentoo-2-4d3f5bc54a2672c0b19e2add34c27a1bd3c0949f.tar.gz
gentoo-2-4d3f5bc54a2672c0b19e2add34c27a1bd3c0949f.tar.bz2
gentoo-2-4d3f5bc54a2672c0b19e2add34c27a1bd3c0949f.zip
Major cleaning of dependencies and ebuild in general, add/remove USE flags making more sense, export pdf and html viewers with xdg-open
(Portage version: 2.1.3.19)
Diffstat (limited to 'dev-lang/R')
-rw-r--r--dev-lang/R/ChangeLog9
-rw-r--r--dev-lang/R/R-2.2.1.ebuild109
-rw-r--r--dev-lang/R/R-2.6.0-r2.ebuild116
-rw-r--r--dev-lang/R/R-2.6.0.ebuild124
-rw-r--r--dev-lang/R/files/digest-R-2.2.13
-rw-r--r--dev-lang/R/files/digest-R-2.6.0-r2 (renamed from dev-lang/R/files/digest-R-2.6.0)0
6 files changed, 124 insertions, 237 deletions
diff --git a/dev-lang/R/ChangeLog b/dev-lang/R/ChangeLog
index 771704ebbe25..6152470db6aa 100644
--- a/dev-lang/R/ChangeLog
+++ b/dev-lang/R/ChangeLog
@@ -1,6 +1,13 @@
# ChangeLog for dev-lang/R
# Copyright 1999-2007 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-lang/R/ChangeLog,v 1.102 2007/11/21 18:50:05 lavajoe Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-lang/R/ChangeLog,v 1.103 2007/11/22 00:20:37 bicatali Exp $
+
+*R-2.6.0-r2 (21 Nov 2007)
+
+ 21 Nov 2007; Sébastien Fabbro <bicatali@gentoo.org> -R-2.2.1.ebuild,
+ -R-2.6.0.ebuild, +R-2.6.0-r2.ebuild:
+ Major cleaning of dependencies and ebuild in general, add/remove USE flags
+ making more sense, export pdf and html viewers with xdg-open
21 Nov 2007; Joe Peterson <lavajoe@gentoo.org> R-2.6.0-r1.ebuild:
Add elibtoolize
diff --git a/dev-lang/R/R-2.2.1.ebuild b/dev-lang/R/R-2.2.1.ebuild
deleted file mode 100644
index 65b602e2a083..000000000000
--- a/dev-lang/R/R-2.2.1.ebuild
+++ /dev/null
@@ -1,109 +0,0 @@
-# Copyright 1999-2007 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-lang/R/R-2.2.1.ebuild,v 1.15 2007/07/22 08:47:37 graaff Exp $
-
-inherit fortran toolchain-funcs flag-o-matic
-
-DESCRIPTION="R is GNU S - A language and environment for statistical computing and graphics."
-HOMEPAGE="http://www.r-project.org/"
-SRC_URI="mirror://cran/src/base/R-2/${P}.tar.gz"
-
-LICENSE="GPL-2 LGPL-2.1"
-SLOT="0"
-KEYWORDS="amd64 ia64 ppc ppc64 sparc x86"
-IUSE="blas jpeg nls png readline tk X lapack"
-
-RDEPEND=">=dev-lang/perl-5.6.1-r3
- readline? ( >=sys-libs/readline-4.1-r3 )
- jpeg? ( >=media-libs/jpeg-6b-r2 )
- png? ( >=media-libs/libpng-1.2.1 )
- blas? ( virtual/blas )
- lapack? ( virtual/lapack )
- tk? ( dev-lang/tk
- dev-lang/tcl )
- X? ( x11-libs/libX11 )"
-DEPEND="${RDEPEND}
- X? ( x11-proto/xproto
- x11-libs/libXt
- x11-libs/libX11 )"
-
-AT_M4DIR="${S}/m4"
-
-pkg_setup() {
- # Test for a 64 bit architecture - f2c won't work on 64 bit archs with R.
- # Thanks to vapier for providing the test.
- cd "${T}"
- echo 'int main(){}' > test.c
- $(tc-getCC) -c test.c -o test.o
- if file test.o | grep -qs 64-bit ; then
- einfo "64 bit architecture detected, using g77 or gfortran."
- FORTRAN="gfortran g77 ifc"
- else
- FORTRAN="gfortran g77 f2c"
- fi
- rm -f test.{c,o}
- fortran_pkg_setup
-
- filter-ldflags -Wl,-Bdirect -Bdirect
-}
-
-src_compile() {
- local myconf="--enable-R-profiling --enable-R-shlib --enable-linux-lfs"
-
- if use tk; then
- #configure needs to find the files tclConfig.sh and tkConfig.sh
- myconf="${myconf} --with-tcltk --with-tcl-config=/usr/lib/tclConfig.sh
- --with-tk-config=/usr/lib/tkConfig.sh"
- else
- myconf="${myconf} --without-tcltk"
- fi
-
- econf \
- $(use_enable nls) \
- $(use_with blas) \
- $(use_with lapack) \
- $(use_with jpeg jpeglib) \
- $(use_with png libpng) \
- $(use_with readline) \
- $(use_with X x) \
- ${myconf} || die "econf failed"
- emake || die "emake failed"
-}
-
-src_install() {
- make \
- prefix=${D}/usr \
- mandir=${D}/usr/share/man \
- infodir=${D}/usr/share/info \
- rhome=${D}/usr/$(get_libdir)/R \
- install || die "Installation Failed"
-
- # fix the R wrapper script to have the correct R_HOME_DIR
- # sed regexp borrowed from included debian rules
- sed \
- -e "/^R_HOME_DIR=.*/s::R_HOME_DIR=/usr/$(get_libdir)/R:" \
- -i ${D}/usr/$(get_libdir)/R/bin/R \
- || die "sed failed."
-
- # The same kinds of seds are needed for these variables too, see bug 115140
- sed \
- -e "/^R_SHARE_DIR=.*/s::R_SHARE_DIR=/usr/$(get_libdir)/R/share:" \
- -e "/^R_INCLUDE_DIR=.*/s::R_INCLUDE_DIR=/usr/$(get_libdir)/R/include:" \
- -e "/^R_DOC_DIR=.*/s::R_DOC_DIR=/usr/$(get_libdir)/R/doc:" \
- -i ${D}/usr/$(get_libdir)/R/bin/R \
- || die "sed failed."
-
- # R installs two identical wrappers under /usr/bin and /usr/lib/R/bin/
- # the 2nd one is corrected by above sed, the first is replaced by a symlink
- cd ${D}/usr/bin/
- rm R
- dosym ../$(get_libdir)/R/bin/R /usr/bin/R
- dodir /etc/env.d
- echo -n \
- "LDPATH=\"/usr/$(get_libdir)/R/lib\"" \
- > ${D}/etc/env.d/99R
- cd ${S}
-
- dodoc AUTHORS BUGS COPYING* ChangeLog FAQ *NEWS README \
- RESOURCES THANKS VERSION Y2K
-}
diff --git a/dev-lang/R/R-2.6.0-r2.ebuild b/dev-lang/R/R-2.6.0-r2.ebuild
new file mode 100644
index 000000000000..947d25c2ea74
--- /dev/null
+++ b/dev-lang/R/R-2.6.0-r2.ebuild
@@ -0,0 +1,116 @@
+# Copyright 1999-2007 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-lang/R/R-2.6.0-r2.ebuild,v 1.1 2007/11/22 00:20:37 bicatali Exp $
+
+inherit fortran flag-o-matic
+
+DESCRIPTION="R is GNU S - A language and environment for statistical computing and graphics."
+HOMEPAGE="http://www.r-project.org/"
+SRC_URI="mirror://cran/src/base/R-2/${P}.tar.gz"
+
+LICENSE="GPL-2 LGPL-2.1"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~hppa ~ia64 ~ppc ~ppc64 ~sparc ~x86 ~x86-fbsd"
+
+IUSE="blas doc java jpeg lapack minimal nls png readline tk X"
+
+# common depends
+CDEPEND="dev-lang/perl
+ >=dev-libs/libpcre-7.3
+ app-arch/bzip2
+ virtual/ghostscript
+ readline? ( sys-libs/readline )
+ jpeg? ( media-libs/jpeg )
+ png? ( media-libs/libpng )
+ blas? ( virtual/blas )
+ lapack? ( virtual/lapack )
+ tk? ( dev-lang/tk )
+ X? ( x11-libs/libXmu x11-misc/xdg-utils )"
+
+DEPEND="${CDEPEND}
+ dev-util/pkgconfig
+ doc? ( virtual/latex-base
+ || ( dev-texlive/texlive-fontsrecommended virtual/tetex ) )"
+
+RDEPEND="${CDEPEND}
+ java? ( >=virtual/jre-1.5 )"
+
+pkg_setup() {
+ FORTRAN="gfortran ifc g77"
+ fortran_pkg_setup
+ export FFLAGS="${FFLAGS:--O2}"
+ [[ ${FORTRANC} = gfortran || ${FORTRANC} = if* ]] && \
+ export FCFLAGS="${FCFLAGS:-${FFLAGS}}"
+
+ filter-ldflags -Wl,-Bdirect -Bdirect
+
+ # this is needed to properly compile additional R packages
+ # (see bug #152379)
+ append-flags -std=gnu99
+}
+
+src_compile() {
+
+ use blas && \
+ export BLAS_LIBS="$(pkg-config --libs blas)"
+
+ use lapack && \
+ export LAPACK_LIBS="$(pkg-config --libs lapack)"
+
+ if use X; then
+ export R_BROWSER="$(type -p xdg-open)"
+ export R_PDFVIEWER="$(type -p xdg-open)"
+ fi
+
+ econf \
+ --enable-R-profiling \
+ --enable-memory-profiling \
+ --enable-R-shlib \
+ --enable-linux-lfs \
+ --with-system-zlib \
+ --with-system-bzlib \
+ --with-system-pcre \
+ rdocdir=/usr/share/doc/${PF} \
+ $(use_enable nls) \
+ $(use_with blas) \
+ $(use_with lapack) \
+ $(use_with tk tcltk) \
+ $(use_with jpeg jpeglib) \
+ $(use_with !minimal recommended-packages) \
+ $(use_with png libpng) \
+ $(use_with readline) \
+ $(use_with X x) \
+ || die "econf failed"
+ emake || die "emake failed"
+
+ if use doc; then
+ export VARTEXFONTS="${T}/fonts"
+ emake info pdf || die "emake docs failed"
+ fi
+}
+
+src_install() {
+ # -j1 because creates various dirs sequentially (hit should be small)
+ emake -j1 DESTDIR="${D}" install || die "emake install failed"
+
+ if use doc; then
+ emake DESTDIR="${D}" \
+ install-info install-pdf || die "emake install docs failed"
+ fi
+
+ # env files
+ echo "LDPATH=\"/usr/$(get_libdir)/R/lib\"" > 99R
+ doenvd 99R || die "doenvd failed"
+
+ # dealing with licenses
+ rm -f "${D}"usr/share/doc/${PF}/{COPYING,COPYING.LIB}
+ dosym "${PORTDIR}"/licenses/GPL-2 /usr/share/doc/${PF}/COPYING
+ dosym "${PORTDIR}"/licenses/LGPL-2.1 /usr/share/doc/${PF}/COPYING.LIB
+}
+
+pkg_config() {
+ if use java; then
+ einfo "Re-initializing java paths for ${P}"
+ R CMD javareconf
+ fi
+}
diff --git a/dev-lang/R/R-2.6.0.ebuild b/dev-lang/R/R-2.6.0.ebuild
deleted file mode 100644
index ccc8274ff3ef..000000000000
--- a/dev-lang/R/R-2.6.0.ebuild
+++ /dev/null
@@ -1,124 +0,0 @@
-# Copyright 1999-2007 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-lang/R/R-2.6.0.ebuild,v 1.1 2007/10/06 14:21:27 markusle Exp $
-
-inherit fortran toolchain-funcs flag-o-matic
-
-DESCRIPTION="R is GNU S - A language and environment for statistical computing and graphics."
-HOMEPAGE="http://www.r-project.org/"
-SRC_URI="mirror://cran/src/base/R-2/${P}.tar.gz"
-
-LICENSE="GPL-2 LGPL-2.1"
-SLOT="0"
-KEYWORDS="~amd64 ~ia64 ~ppc ~ppc64 ~sparc ~x86"
-IUSE="blas jpeg nls png readline tk X lapack gd"
-
-RDEPEND=">=dev-lang/perl-5.6.1-r3
- readline? ( >=sys-libs/readline-4.1-r3 )
- jpeg? ( >=media-libs/jpeg-6b-r2 )
- png? ( >=media-libs/libpng-1.2.1 )
- blas? ( virtual/blas )
- lapack? ( virtual/lapack )
- gd? ( >=media-libs/gd-2 )
- tk? ( dev-lang/tk
- dev-lang/tcl )
- X? ( x11-libs/libX11 )"
-DEPEND="${RDEPEND}
- X? ( x11-proto/xproto
- x11-libs/libXt
- x11-libs/libX11 )"
-
-pkg_setup() {
- # Test for a 64 bit architecture - f2c won't work on 64 bit archs with R.
- # Thanks to vapier for providing the test.
- cd "${T}"
- echo 'int main(){}' > test.c
- $(tc-getCC) -c test.c -o test.o
- if file test.o | grep -qs 64-bit ; then
- einfo "64 bit architecture detected, using g77 or gfortran."
- FORTRAN="gfortran g77 ifc"
- else
- FORTRAN="gfortran g77 f2c"
- fi
- rm -f test.{c,o}
- fortran_pkg_setup
-
- filter-ldflags -Wl,-Bdirect -Bdirect
-
- # this is needed to properly compile additional R packages
- # (see bug #152379)
- append-flags -std=gnu99
-}
-
-src_unpack() {
- unpack ${A}
- sed -e "s:\$(rhome):/usr/$(get_libdir)/R:g" \
- -i "${S}"/src/unix/Makefile.in ||
- die "Failed to fix Rscript makefile"
-}
-
-src_compile() {
- local myconf="--enable-R-profiling --enable-R-shlib --enable-linux-lfs"
-
- if use tk; then
- #configure needs to find the files tclConfig.sh and tkConfig.sh
- myconf="${myconf} --with-tcltk --with-tcl-config=/usr/lib/tclConfig.sh
- --with-tk-config=/usr/lib/tkConfig.sh"
- else
- myconf="${myconf} --without-tcltk"
- fi
-
- econf \
- $(use_enable nls) \
- $(use_with blas) \
- $(use_with lapack) \
- $(use_with jpeg jpeglib) \
- $(use_with png libpng) \
- $(use_with readline) \
- $(use_with X x) \
- ${myconf} || die "econf failed"
- # R-2.5.0 started to have issues with parallel make
- emake -j1 || die "emake failed"
-}
-
-src_install() {
- make \
- prefix=${D}/usr \
- mandir=${D}/usr/share/man \
- infodir=${D}/usr/share/info \
- libdir=${D}/usr/$(get_libdir) \
- rhome=${D}/usr/$(get_libdir)/R \
- install || die "Installation Failed"
-
- # fix the R wrapper script to have the correct R_HOME_DIR
- # sed regexp borrowed from included debian rules
- sed \
- -e "/^R_HOME_DIR=.*/s::R_HOME_DIR=/usr/$(get_libdir)/R:" \
- -i ${D}/usr/$(get_libdir)/R/bin/R \
- || die "sed failed."
-
- # The same kinds of seds are needed for these variables too, see bug 115140
- sed \
- -e "/^R_SHARE_DIR=.*/s::R_SHARE_DIR=/usr/$(get_libdir)/R/share:" \
- -e "/^R_INCLUDE_DIR=.*/s::R_INCLUDE_DIR=/usr/$(get_libdir)/R/include:" \
- -e "/^R_DOC_DIR=.*/s::R_DOC_DIR=/usr/$(get_libdir)/R/doc:" \
- -i ${D}/usr/$(get_libdir)/R/bin/R \
- || die "sed failed."
-
- # fix paths in libR.pc pkgconfig file
- sed -e "s:${D}::" -i ${D}/usr/$(get_libdir)/pkgconfig/libR.pc \
- || die "Failed to fix libR.pc file"
-
- # R installs two identical wrappers under /usr/bin and /usr/lib/R/bin/
- # the 2nd one is corrected by above sed, the first is replaced by a symlink
- cd ${D}/usr/bin/
- rm R
- dosym ../$(get_libdir)/R/bin/R /usr/bin/R
- dodir /etc/env.d
- echo -n \
- "LDPATH=\"/usr/$(get_libdir)/R/lib\"" \
- > ${D}/etc/env.d/99R
- cd ${S}
-
- dodoc ChangeLog *NEWS README VERSION
-}
diff --git a/dev-lang/R/files/digest-R-2.2.1 b/dev-lang/R/files/digest-R-2.2.1
deleted file mode 100644
index 3a6a2f9464ce..000000000000
--- a/dev-lang/R/files/digest-R-2.2.1
+++ /dev/null
@@ -1,3 +0,0 @@
-MD5 42542290c6d1585af7ded330f811385c R-2.2.1.tar.gz 13665367
-RMD160 b63b6c5ef1db27a879783460b0ecb6de0d4bba18 R-2.2.1.tar.gz 13665367
-SHA256 db442c769e5e8ecbdb33c771e41bdac4330b565652c5ca730f26f975df30c624 R-2.2.1.tar.gz 13665367
diff --git a/dev-lang/R/files/digest-R-2.6.0 b/dev-lang/R/files/digest-R-2.6.0-r2
index e5de22d6bc74..e5de22d6bc74 100644
--- a/dev-lang/R/files/digest-R-2.6.0
+++ b/dev-lang/R/files/digest-R-2.6.0-r2