summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJustin Lecher <jlec@gentoo.org>2014-02-21 15:56:03 +0000
committerJustin Lecher <jlec@gentoo.org>2014-02-21 15:56:03 +0000
commit5c01b7a1925b6e18b2fa07c1cd1aa9e3863549ef (patch)
tree845a3cced921be475622d5de4f0eb613fbc17159 /dev-lang/icc
parentIntroduce networkd use flag. (diff)
downloadgentoo-2-5c01b7a1925b6e18b2fa07c1cd1aa9e3863549ef.tar.gz
gentoo-2-5c01b7a1925b6e18b2fa07c1cd1aa9e3863549ef.tar.bz2
gentoo-2-5c01b7a1925b6e18b2fa07c1cd1aa9e3863549ef.zip
dev-lang/icc: Version Bump, #500386
(Portage version: 2.2.8-r1/cvs/Linux x86_64, signed Manifest commit with key B9D4F231BD1558AB!)
Diffstat (limited to 'dev-lang/icc')
-rw-r--r--dev-lang/icc/ChangeLog7
-rw-r--r--dev-lang/icc/icc-14.0.1.106.ebuild37
2 files changed, 43 insertions, 1 deletions
diff --git a/dev-lang/icc/ChangeLog b/dev-lang/icc/ChangeLog
index aaa651d31cf5..09d3d514b06b 100644
--- a/dev-lang/icc/ChangeLog
+++ b/dev-lang/icc/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for dev-lang/icc
# Copyright 1999-2014 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-lang/icc/ChangeLog,v 1.98 2014/02/05 17:12:30 jlec Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-lang/icc/ChangeLog,v 1.99 2014/02/21 15:56:03 jlec Exp $
+
+*icc-14.0.1.106 (21 Feb 2014)
+
+ 21 Feb 2014; Justin Lecher <jlec@gentoo.org> +icc-14.0.1.106.ebuild:
+ Version Bump, #500386
05 Feb 2014; Justin Lecher <jlec@gentoo.org> metadata.xml:
Drop maintainer
diff --git a/dev-lang/icc/icc-14.0.1.106.ebuild b/dev-lang/icc/icc-14.0.1.106.ebuild
new file mode 100644
index 000000000000..a20f4d95ba94
--- /dev/null
+++ b/dev-lang/icc/icc-14.0.1.106.ebuild
@@ -0,0 +1,37 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-lang/icc/icc-14.0.1.106.ebuild,v 1.1 2014/02/21 15:56:03 jlec Exp $
+
+EAPI=5
+
+INTEL_DPN=parallel_studio_xe
+INTEL_DID=3644
+INTEL_DPV=2013_sp1_update1
+INTEL_SUBDIR=composerxe
+INTEL_SINGLE_ARCH=false
+
+inherit intel-sdp
+
+DESCRIPTION="Intel C/C++ Compiler"
+HOMEPAGE="http://software.intel.com/en-us/articles/intel-composer-xe/"
+
+IUSE="eclipse linguas_ja"
+KEYWORDS="-* ~amd64 ~x86 ~amd64-linux ~x86-linux"
+
+DEPEND="
+ !dev-lang/ifc[linguas_ja]
+ eclipse? ( dev-util/eclipse-sdk )"
+RDEPEND="${DEPEND}
+ ~dev-libs/intel-common-${PV}[compiler]"
+
+INTEL_BIN_RPMS="compilerproc compilerproc-devel"
+INTEL_DAT_RPMS="compilerproc-common"
+
+CHECKREQS_DISK_BUILD=325M
+
+src_install() {
+ if ! use linguas_ja; then
+ find "${S}" -type d -name ja_JP -exec rm -rf '{}' + || die
+ fi
+ intel-sdp_src_install
+}