summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlexis Ballier <aballier@gentoo.org>2009-09-27 15:15:56 +0000
committerAlexis Ballier <aballier@gentoo.org>2009-09-27 15:15:56 +0000
commit45a555d30f13ea60c3fe8ec82c5ec49d0b293d56 (patch)
tree2583a01918d36dc77a6d65962f8def63ad045ca0 /dev-lang/ocaml
parentppc stable #285586 (diff)
downloadgentoo-2-45a555d30f13ea60c3fe8ec82c5ec49d0b293d56.tar.gz
gentoo-2-45a555d30f13ea60c3fe8ec82c5ec49d0b293d56.tar.bz2
gentoo-2-45a555d30f13ea60c3fe8ec82c5ec49d0b293d56.zip
Filter mfpmath=sse, it causes ocamlc.opt to segfault. Bug #285993
(Portage version: 2.2_rc42/cvs/Linux x86_64)
Diffstat (limited to 'dev-lang/ocaml')
-rw-r--r--dev-lang/ocaml/ChangeLog5
-rw-r--r--dev-lang/ocaml/ocaml-3.11.1.ebuild4
2 files changed, 7 insertions, 2 deletions
diff --git a/dev-lang/ocaml/ChangeLog b/dev-lang/ocaml/ChangeLog
index 29562c3edde4..5f5612333afa 100644
--- a/dev-lang/ocaml/ChangeLog
+++ b/dev-lang/ocaml/ChangeLog
@@ -1,6 +1,9 @@
# ChangeLog for dev-lang/ocaml
# Copyright 1999-2009 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-lang/ocaml/ChangeLog,v 1.171 2009/09/19 09:36:28 aballier Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-lang/ocaml/ChangeLog,v 1.172 2009/09/27 15:15:56 aballier Exp $
+
+ 27 Sep 2009; Alexis Ballier <aballier@gentoo.org> ocaml-3.11.1.ebuild:
+ Filter mfpmath=sse, it causes ocamlc.opt to segfault. Bug #285993
19 Sep 2009; Alexis Ballier <aballier@gentoo.org> ocaml-3.11.1.ebuild:
Filter fomit-frame-pointer, ocaml builds some programs with -pg which
diff --git a/dev-lang/ocaml/ocaml-3.11.1.ebuild b/dev-lang/ocaml/ocaml-3.11.1.ebuild
index 9e3599b28723..9e2bc27b29cf 100644
--- a/dev-lang/ocaml/ocaml-3.11.1.ebuild
+++ b/dev-lang/ocaml/ocaml-3.11.1.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2009 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-lang/ocaml/ocaml-3.11.1.ebuild,v 1.5 2009/09/19 20:53:18 mr_bones_ Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-lang/ocaml/ocaml-3.11.1.ebuild,v 1.6 2009/09/27 15:15:56 aballier Exp $
EAPI="1"
@@ -52,6 +52,8 @@ src_compile() {
# Causes build failures because it builds some programs with -pg,
# bug #270920
filter-flags -fomit-frame-pointer
+ # Bug #285993
+ filter-mfpmath sse
# It doesn't compile on alpha without this LDFLAGS
use alpha && append-ldflags "-Wl,--no-relax"