summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2012-11-30 23:57:44 +0000
committerMichał Górny <mgorny@gentoo.org>2012-11-30 23:57:44 +0000
commit30e4617547cf06cbe27ef8194e48e525e2d0d4c9 (patch)
tree7185a1beaeeaaf4ea2f2464aa3a80141651f97f1 /dev-lang/python/python-3.1.5-r1.ebuild
parentVersion bump for enlightenment:0.17 (diff)
downloadgentoo-2-30e4617547cf06cbe27ef8194e48e525e2d0d4c9.tar.gz
gentoo-2-30e4617547cf06cbe27ef8194e48e525e2d0d4c9.tar.bz2
gentoo-2-30e4617547cf06cbe27ef8194e48e525e2d0d4c9.zip
Fix byte-compiling the installed epython module when installing a new Python version.
(Portage version: 2.2.0_alpha143/cvs/Linux x86_64, signed Manifest commit with key 42B9401D)
Diffstat (limited to 'dev-lang/python/python-3.1.5-r1.ebuild')
-rw-r--r--dev-lang/python/python-3.1.5-r1.ebuild10
1 files changed, 9 insertions, 1 deletions
diff --git a/dev-lang/python/python-3.1.5-r1.ebuild b/dev-lang/python/python-3.1.5-r1.ebuild
index 4d7ed5bc6029..dd99c5e5eb94 100644
--- a/dev-lang/python/python-3.1.5-r1.ebuild
+++ b/dev-lang/python/python-3.1.5-r1.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2012 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-lang/python/python-3.1.5-r1.ebuild,v 1.1 2012/11/30 13:25:17 mgorny Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-lang/python/python-3.1.5-r1.ebuild,v 1.2 2012/11/30 23:57:44 mgorny Exp $
EAPI="3"
WANT_AUTOMAKE="none"
@@ -249,6 +249,14 @@ src_install() {
# for python-exec
python_export python${SLOT} EPYTHON PYTHON PYTHON_SITEDIR
+
+ # if not using a cross-compiler, use the fresh binary
+ if ! tc-is-cross-compiler; then
+ local PYTHON=./python \
+ LD_LIBRARY_PATH=${LD_LIBRARY_PATH+${LD_LIBRARY_PATH}:}.
+ export LD_LIBRARY_PATH
+ fi
+
echo "EPYTHON='${EPYTHON}'" > epython.py
python_domodule epython.py
}