summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorIan Stakenvicius <axs@gentoo.org>2013-08-10 02:43:06 +0000
committerIan Stakenvicius <axs@gentoo.org>2013-08-10 02:43:06 +0000
commit901335d9dd6c8de53127ddaef8972df5df8b6569 (patch)
treef0540aea0bfad9eb1ee0c70e6c89e8e4baa98637 /dev-lang/spidermonkey
parentMask upcoming poppler-0.24 until stuff builds with it (diff)
downloadgentoo-2-901335d9dd6c8de53127ddaef8972df5df8b6569.tar.gz
gentoo-2-901335d9dd6c8de53127ddaef8972df5df8b6569.tar.bz2
gentoo-2-901335d9dd6c8de53127ddaef8972df5df8b6569.zip
fixed improper pax-marking, and patched build system to keep it from stripping shebang from js-config
(Portage version: 2.1.12.2/cvs/Linux x86_64, signed Manifest commit with key 2B6559ED)
Diffstat (limited to 'dev-lang/spidermonkey')
-rw-r--r--dev-lang/spidermonkey/ChangeLog10
-rw-r--r--dev-lang/spidermonkey/files/spidermonkey-17-js-config-shebang.patch22
-rw-r--r--dev-lang/spidermonkey/spidermonkey-17.0.0-r1.ebuild (renamed from dev-lang/spidermonkey/spidermonkey-17.0.0.ebuild)5
3 files changed, 34 insertions, 3 deletions
diff --git a/dev-lang/spidermonkey/ChangeLog b/dev-lang/spidermonkey/ChangeLog
index 7445a407aa2a..0fc304af1ace 100644
--- a/dev-lang/spidermonkey/ChangeLog
+++ b/dev-lang/spidermonkey/ChangeLog
@@ -1,6 +1,14 @@
# ChangeLog for dev-lang/spidermonkey
# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-lang/spidermonkey/ChangeLog,v 1.119 2013/08/08 20:49:55 axs Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-lang/spidermonkey/ChangeLog,v 1.120 2013/08/10 02:43:06 axs Exp $
+
+*spidermonkey-17.0.0-r1 (10 Aug 2013)
+
+ 10 Aug 2013; Ian Stakenvicius <axs@gentoo.org>
+ +files/spidermonkey-17-js-config-shebang.patch,
+ +spidermonkey-17.0.0-r1.ebuild, -spidermonkey-17.0.0.ebuild:
+ fixed improper pax-marking, and patched build system to keep it from stripping
+ shebang from js-config
08 Aug 2013; Ian Stakenvicius <axs@gentoo.org> -spidermonkey-1.8.5-r1.ebuild,
-spidermonkey-1.8.5-r2.ebuild, -spidermonkey-1.8.5-r3.ebuild,
diff --git a/dev-lang/spidermonkey/files/spidermonkey-17-js-config-shebang.patch b/dev-lang/spidermonkey/files/spidermonkey-17-js-config-shebang.patch
new file mode 100644
index 000000000000..ec77b2368289
--- /dev/null
+++ b/dev-lang/spidermonkey/files/spidermonkey-17-js-config-shebang.patch
@@ -0,0 +1,22 @@
+--- a/js/src/js-config.in 2013-03-25 16:34:20.000000000 -0400
++++ b/js/src/js-config.in 2013-08-09 22:15:29.000901763 -0400
+@@ -2,7 +2,7 @@
+ # This Source Code Form is subject to the terms of the Mozilla Public
+ # License, v. 2.0. If a copy of the MPL was not distributed with this
+ # file, You can obtain one at http://mozilla.org/MPL/2.0/.
+-#filter substitution
++%filter substitution
+
+ prefix='@prefix@'
+ mozilla_version='@MOZILLA_VERSION@'
+--- a/js/src/Makefile.in 2013-03-25 16:34:20.000000000 -0400
++++ b/js/src/Makefile.in 2013-08-09 22:17:20.211903793 -0400
+@@ -778,7 +778,7 @@
+
+ $(JS_CONFIG_NAME): js-config.in Makefile $(DEPTH)/config/autoconf.mk $(topsrcdir)/config/config.mk $(topsrcdir)/config/rules.mk
+ $(RM) $@.tmp
+- $(PYTHON) $(topsrcdir)/config/Preprocessor.py $(JS_CONFIG_SUBSTITUTIONS) $< > $@.tmp \
++ $(PYTHON) $(topsrcdir)/config/Preprocessor.py --marker="%" $(JS_CONFIG_SUBSTITUTIONS) $< > $@.tmp \
+ && mv $@.tmp $@ && chmod +x $@
+
+ SCRIPTS = $(JS_CONFIG_NAME)
diff --git a/dev-lang/spidermonkey/spidermonkey-17.0.0.ebuild b/dev-lang/spidermonkey/spidermonkey-17.0.0-r1.ebuild
index add7ac493d1c..e225d5c9e4f9 100644
--- a/dev-lang/spidermonkey/spidermonkey-17.0.0.ebuild
+++ b/dev-lang/spidermonkey/spidermonkey-17.0.0-r1.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2013 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-lang/spidermonkey/spidermonkey-17.0.0.ebuild,v 1.2 2013/08/08 20:49:55 axs Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-lang/spidermonkey/spidermonkey-17.0.0-r1.ebuild,v 1.1 2013/08/10 02:43:06 axs Exp $
EAPI="5"
WANT_AUTOCONF="2.1"
@@ -39,6 +39,7 @@ pkg_setup(){
}
src_prepare() {
+ epatch "${FILESDIR}"/${PN}-${SLOT}-js-config-shebang.patch
epatch_user
if [[ ${CHOST} == *-freebsd* ]]; then
@@ -107,7 +108,7 @@ src_install() {
if ! use minimal; then
if use jit; then
- pax-mark m "${ED}/usr/bin/js${SLOT}*"
+ pax-mark m "${ED}/usr/bin/js${SLOT}"
fi
else
rm -f "${ED}/usr/bin/js${SLOT}"