summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDanny van Dyk <kugelfang@gentoo.org>2004-09-12 20:51:09 +0000
committerDanny van Dyk <kugelfang@gentoo.org>2004-09-12 20:51:09 +0000
commita3ac8912aa215f8881c734eb90cc44acdbfc9801 (patch)
tree253a477e1d25a4923f99bcf31aa73441aefb6cdc /dev-lang
parentAdded \$FILE_EXE to configuration (fixes bug #63806) (Manifest recommit) (diff)
downloadgentoo-2-a3ac8912aa215f8881c734eb90cc44acdbfc9801.tar.gz
gentoo-2-a3ac8912aa215f8881c734eb90cc44acdbfc9801.tar.bz2
gentoo-2-a3ac8912aa215f8881c734eb90cc44acdbfc9801.zip
R-1.9.1 stable on amd64, f2c masked on all 64bit arches...
Diffstat (limited to 'dev-lang')
-rw-r--r--dev-lang/R/ChangeLog9
-rw-r--r--dev-lang/R/R-1.9.0-r1.ebuild9
-rw-r--r--dev-lang/R/R-1.9.1.ebuild13
3 files changed, 26 insertions, 5 deletions
diff --git a/dev-lang/R/ChangeLog b/dev-lang/R/ChangeLog
index 73c72395e96f..7c527e5cf0c1 100644
--- a/dev-lang/R/ChangeLog
+++ b/dev-lang/R/ChangeLog
@@ -1,6 +1,13 @@
# ChangeLog for dev-lang/R
# Copyright 2002-2004 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-lang/R/ChangeLog,v 1.31 2004/09/09 12:35:17 tchiwam Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-lang/R/ChangeLog,v 1.32 2004/09/12 20:51:09 kugelfang Exp $
+
+ 12 Sep 2004; Danny van Dyk <kugelfang@gentoo.org> R-1.9.0-r1.ebuild,
+ R-1.9.1.ebuild:
+ Removed f2c support for dev-lang/R on 64-bit arches. This is entirely R's
+ fault. f2c works perfectly right. Future versions of dev-lang/R will check for
+ this in ./configure. For R-1.9.{0,1} the ebuild checks for it. Fixes BUG
+ #61042.
*R-1.9.1 (22 Aug 2004)
diff --git a/dev-lang/R/R-1.9.0-r1.ebuild b/dev-lang/R/R-1.9.0-r1.ebuild
index 5244fe1a7b56..64e1381de2c7 100644
--- a/dev-lang/R/R-1.9.0-r1.ebuild
+++ b/dev-lang/R/R-1.9.0-r1.ebuild
@@ -1,6 +1,8 @@
# Copyright 1999-2004 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-lang/R/R-1.9.0-r1.ebuild,v 1.10 2004/08/21 15:54:33 foser Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-lang/R/R-1.9.0-r1.ebuild,v 1.11 2004/09/12 20:51:09 kugelfang Exp $
+
+inherit 64-bit
IUSE="blas X tcltk gnome zlib bzlib pcre f2c"
@@ -42,6 +44,11 @@ KEYWORDS="~x86 ~sparc ~ppc amd64"
pkg_setup() {
if [ -z "$(which g77 2>/dev/null)" ]; then
einfo "Couldn't find g77 Fortran Compiler."
+ if 64-bit && use f2c; then
+ eerror "You can't use f2c for dev-lang/R on 64-bit arches."
+ eerror "Please remerge gcc with USE=\"g77\""
+ die "dev-lang/R is incompatible with f2c on 64-bit arches."
+ fi
if ! use f2c; then
eerror "Trying to emerge this packet w/o fortran compiler."
eerror "Try again with USE=\"f2c\" emerge dev-lang/R."
diff --git a/dev-lang/R/R-1.9.1.ebuild b/dev-lang/R/R-1.9.1.ebuild
index 7f6d4e93751f..1416544d6a85 100644
--- a/dev-lang/R/R-1.9.1.ebuild
+++ b/dev-lang/R/R-1.9.1.ebuild
@@ -1,8 +1,10 @@
# Copyright 1999-2004 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-lang/R/R-1.9.1.ebuild,v 1.2 2004/09/09 12:35:17 tchiwam Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-lang/R/R-1.9.1.ebuild,v 1.3 2004/09/12 20:51:09 kugelfang Exp $
-IUSE="blas X tcltk gnome zlib bzlib pcre f2c"
+inherit 64-bit
+
+IUSE="blas lapack X tcltk gnome zlib bzlib pcre f2c"
DESCRIPTION="R is GNU S - A language and environment for statistical computing and graphics."
@@ -38,11 +40,16 @@ DEPEND="virtual/libc
SLOT="0"
LICENSE="GPL-2 LGPL-2.1"
-KEYWORDS="~x86 ~sparc ~ppc ~ppc64 ~amd64"
+KEYWORDS="~x86 ~sparc ~ppc ~ppc64 amd64"
pkg_setup() {
if [ -z "$(which g77 2>/dev/null)" ]; then
einfo "Couldn't find g77 Fortran Compiler."
+ if 64-bit && use f2c; then
+ eerror "You can't use f2c for dev-lang/R on 64-bit arches."
+ eerror "Please remerge gcc with USE=\"g77\""
+ die "dev-lang/R is incompatible with f2c on 64-bit arches."
+ fi
if ! use f2c; then
eerror "Trying to emerge this packet w/o fortran compiler."
eerror "Try again with USE=\"f2c\" emerge dev-lang/R."