summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMarcus D. Hanwell <cryos@gentoo.org>2005-05-25 22:02:23 +0000
committerMarcus D. Hanwell <cryos@gentoo.org>2005-05-25 22:02:23 +0000
commitc0d77adbf6eac8d7d2975c008c69f1b3c277b96c (patch)
tree02b92139aaeefc41059e4612fcc6594079a99a31 /dev-lang
parentadd uclibctoolize for psm (diff)
downloadgentoo-2-c0d77adbf6eac8d7d2975c008c69f1b3c277b96c.tar.gz
gentoo-2-c0d77adbf6eac8d7d2975c008c69f1b3c277b96c.tar.bz2
gentoo-2-c0d77adbf6eac8d7d2975c008c69f1b3c277b96c.zip
Bring back R-1.9.0-r1 until <=dev-python/rpy-0.3.5-r1 are removed from portage.
(Portage version: 2.0.51.22-r1)
Diffstat (limited to 'dev-lang')
-rw-r--r--dev-lang/R/ChangeLog8
-rw-r--r--dev-lang/R/R-1.9.0-r1.ebuild137
-rw-r--r--dev-lang/R/files/digest-R-1.9.0-r11
3 files changed, 145 insertions, 1 deletions
diff --git a/dev-lang/R/ChangeLog b/dev-lang/R/ChangeLog
index b190d1715e1a..a66be69c4b39 100644
--- a/dev-lang/R/ChangeLog
+++ b/dev-lang/R/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for dev-lang/R
# Copyright 2002-2005 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-lang/R/ChangeLog,v 1.47 2005/05/25 13:35:59 cryos Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-lang/R/ChangeLog,v 1.48 2005/05/25 22:02:23 cryos Exp $
+
+*R-1.9.0-r1 (25 May 2005)
+
+ 25 May 2005; Marcus D. Hanwell <cryos@gentoo.org> +R-1.9.0-r1.ebuild:
+ Bring back R-1.9.0-r1 until <=dev-python/rpy-0.3.5-r1 are removed from
+ portage.
25 May 2005; Marcus D. Hanwell <cryos@gentoo.org> -R-1.9.0-r1.ebuild:
Removed old version.
diff --git a/dev-lang/R/R-1.9.0-r1.ebuild b/dev-lang/R/R-1.9.0-r1.ebuild
new file mode 100644
index 000000000000..a2e9b4daec27
--- /dev/null
+++ b/dev-lang/R/R-1.9.0-r1.ebuild
@@ -0,0 +1,137 @@
+# Copyright 1999-2005 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-lang/R/R-1.9.0-r1.ebuild,v 1.16 2005/05/25 22:02:23 cryos Exp $
+
+inherit 64-bit
+
+IUSE="blas X tcltk gnome zlib bzlib pcre f2c"
+
+DESCRIPTION="R is GNU S - A language and environment for statistical computing and graphics."
+
+SRC_URI="http://cran.r-project.org/src/base/${P}.tgz"
+
+ #There are daily release patches, don't know how to utilize these
+ #"ftp://ftp.stat.math.ethz.ch/Software/${PN}/${PN}-release.diff.gz"
+
+HOMEPAGE="http://www.r-project.org/"
+
+DEPEND="virtual/libc
+ >=dev-lang/perl-5.6.1-r3
+ >=sys-libs/readline-4.1-r3
+ zlib? ( >=sys-libs/zlib-1.1.3-r2 )
+ >=media-libs/jpeg-6b-r2
+ >=media-libs/libpng-1.2.1
+ blas? ( virtual/blas )
+ f2c? ( dev-lang/f2c >=dev-libs/libf2c-20021004-r1 )
+ X? ( virtual/x11 )
+ tcltk? ( dev-lang/tk )
+ pcre? ( dev-libs/libpcre )
+ bzlib? ( app-arch/bzip2 )
+ gnome? ( >=gnome-base/gnome-libs-1.4.1.4
+ >=gnome-base/libglade-0.17
+ >=dev-libs/libxml-1.8.16
+ =gnome-base/orbit-0*
+ >=media-libs/imlib-1.9.10
+ >=x11-libs/gtk+-1.2.10
+ >=dev-libs/glib-1.2.10
+ >=media-sound/esound-0.2.23
+ >=media-libs/audiofile-0.2.1 )"
+
+SLOT="0"
+LICENSE="GPL-2 LGPL-2.1"
+KEYWORDS="x86 sparc ppc amd64"
+
+pkg_setup() {
+ if [ -z "$(which g77 2>/dev/null)" ]; then
+ einfo "Couldn't find g77 Fortran Compiler."
+ if 64-bit && use f2c; then
+ eerror "You can't use f2c for dev-lang/R on 64-bit arches."
+ eerror "Please remerge gcc with USE=\"g77\""
+ die "dev-lang/R is incompatible with f2c on 64-bit arches."
+ fi
+ if ! use f2c; then
+ eerror "Trying to emerge this packet w/o fortran compiler."
+ eerror "Try again with USE=\"f2c\" emerge dev-lang/R."
+ die "No fortran compiler, no f2c."
+ else
+ einfo "Using f2c to translate fortran sources."
+ fi
+ fi
+}
+
+src_unpack() {
+ unpack ${A}
+ cd ${S}
+ sed -e 's/^#define NeedFunctionPrototypes 0/#define NeedFunctionPrototypes 1/' \
+ -i src/modules/X11/dataentry.c || die "sed failed"
+}
+
+src_compile() {
+ addwrite "/var/cache/fonts"
+ local myconf="--enable-static --enable-R-profiling --enable-R-shlib --with-readline"
+
+ use zlib || myconf="${myconf} --with-zlib" #default disabled
+ use bzlib || myconf="${myconf} --with-bzlib" #default disabled
+ use pcre || myconf="${myconf} --with-pcre" #default disabled
+
+ # Using the blas USE flag now instead atlas, as atlas now
+ # has been broken into blas-atlas and lapack-atlas.
+ # Danny van Dyk <kugelfang@gentoo.org> 2004/07/11
+ use blas || myconf="${myconf} --without-blas" #default enabled
+
+ use X || myconf="${myconf} --without-x" #default enabled
+
+ if use tcltk; then
+ #configure needs to find the files tclConfig.sh and tkConfig.sh
+ myconf="${myconf} --with-tcltk --with-tcl-config=/usr/lib/tclConfig.sh --with-tk-config=/usr/lib/tkConfig.sh"
+ else
+ myconf="${myconf} --without-tcltk"
+ fi
+
+ use gnome && myconf="${myconf} --with-gnome" #default disabled
+
+ ./configure \
+ --host=${CHOST} \
+ --prefix=/usr \
+ --infodir=/usr/share/info \
+ --mandir=/usr/share/man \
+ ${myconf} || die "./configure failed"
+
+ emake || die
+
+}
+
+src_install () {
+
+ make \
+ prefix=${D}/usr \
+ mandir=${D}/usr/share/man \
+ infodir=${D}/usr/share/info \
+ install || die "Installation Failed"
+
+ #fix the R wrapper script to have the correct R_HOME_DIR
+ #sed regexp borrowed from included debian rules
+ cp ${D}/usr/lib/R/bin/R ${S}/bin/R.orig
+ sed -e '/^R_HOME_DIR=.*/s::R_HOME_DIR=/usr/lib/R:' \
+ ${S}/bin/R.orig > ${D}/usr/lib/R/bin/R
+
+ #R installs two identical wrappers under /usr/bin and /usr/lib/R/bin/
+ #the 2nd one is corrected by above sed, for the 1st
+ #I'll just symlink it into /usr/bin
+ cd ${D}/usr/bin/
+ rm R
+ dosym ../lib/R/bin/R /usr/bin/R
+ cd ${S}
+
+ dodoc AUTHORS BUGS COPYING* ChangeLog FAQ INSTALL *NEWS README \
+ RESOURCES THANKS VERSION Y2K
+
+ #Add rudimentary menu entry if gnome
+ if use gnome; then
+ insinto /usr/share/gnome/apps/Applications
+ doins ${FILESDIR}/R.desktop
+ insinto /usr/share/pixmaps
+ doins ${FILESDIR}/R-logo.png
+ fi
+
+}
diff --git a/dev-lang/R/files/digest-R-1.9.0-r1 b/dev-lang/R/files/digest-R-1.9.0-r1
new file mode 100644
index 000000000000..cb20649d63df
--- /dev/null
+++ b/dev-lang/R/files/digest-R-1.9.0-r1
@@ -0,0 +1 @@
+MD5 79ae9d20a7bed94d7c92504c8c130310 R-1.9.0.tgz 9505598