summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSergei Trofimovich <slyfox@gentoo.org>2013-03-26 20:19:18 +0000
committerSergei Trofimovich <slyfox@gentoo.org>2013-03-26 20:19:18 +0000
commitc2dd2d7a3dc09fc178e06c457b1343feedaed0ff (patch)
tree262078a93e6a4e7a167ba1c3a78ad2cc54044cdc /dev-lang
parentmasked dev-lang/ghc[llvm] (diff)
downloadgentoo-2-c2dd2d7a3dc09fc178e06c457b1343feedaed0ff.tar.gz
gentoo-2-c2dd2d7a3dc09fc178e06c457b1343feedaed0ff.tar.bz2
gentoo-2-c2dd2d7a3dc09fc178e06c457b1343feedaed0ff.zip
Add ia64 binary.
(Portage version: 2.2.0_alpha166_p29/cvs/Linux x86_64, signed Manifest commit with key 611FF3AA)
Diffstat (limited to 'dev-lang')
-rw-r--r--dev-lang/ghc/ChangeLog5
-rw-r--r--dev-lang/ghc/ghc-7.4.2.ebuild18
2 files changed, 18 insertions, 5 deletions
diff --git a/dev-lang/ghc/ChangeLog b/dev-lang/ghc/ChangeLog
index 8d6803ee21bd..0548c3af560f 100644
--- a/dev-lang/ghc/ChangeLog
+++ b/dev-lang/ghc/ChangeLog
@@ -1,6 +1,9 @@
# ChangeLog for dev-lang/ghc
# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-lang/ghc/ChangeLog,v 1.231 2013/02/13 21:46:44 slyfox Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-lang/ghc/ChangeLog,v 1.232 2013/03/26 20:19:18 slyfox Exp $
+
+ 26 Mar 2013; Sergei Trofimovich <slyfox@gentoo.org> ghc-7.4.2.ebuild:
+ Add ia64 binary.
13 Feb 2013; Sergei Trofimovich <slyfox@gentoo.org>
+files/terminfo-0.3.2.5-tinfo.patch, ghc-7.4.2.ebuild:
diff --git a/dev-lang/ghc/ghc-7.4.2.ebuild b/dev-lang/ghc/ghc-7.4.2.ebuild
index 8641c9d6961d..c918af5d5bd2 100644
--- a/dev-lang/ghc/ghc-7.4.2.ebuild
+++ b/dev-lang/ghc/ghc-7.4.2.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2013 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-lang/ghc/ghc-7.4.2.ebuild,v 1.2 2013/02/13 21:46:44 slyfox Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-lang/ghc/ghc-7.4.2.ebuild,v 1.3 2013/03/26 20:19:18 slyfox Exp $
# Brief explanation of the bootstrap logic:
#
@@ -42,7 +42,7 @@ arch_binaries=""
arch_binaries="$arch_binaries alpha? ( http://code.haskell.org/~slyfox/ghc-alpha/ghc-bin-${PV}-alpha.tbz2 )"
#arch_binaries="$arch_binaries arm? ( http://code.haskell.org/~slyfox/ghc-arm/ghc-bin-${PV}-arm.tbz2 )"
arch_binaries="$arch_binaries amd64? ( http://code.haskell.org/~slyfox/ghc-amd64/ghc-bin-${PV}-amd64-stable-glibc.tbz2 )"
-#arch_binaries="$arch_binaries ia64? ( http://code.haskell.org/~slyfox/ghc-ia64/ghc-bin-${PV}-ia64-fixed-fiw.tbz2 )"
+arch_binaries="$arch_binaries ia64? ( http://code.haskell.org/~slyfox/ghc-ia64/ghc-bin-${PV}-ia64.tbz2 )"
arch_binaries="$arch_binaries ppc? ( http://code.haskell.org/~slyfox/ghc-ppc/ghc-bin-${PV}-ppc.tbz2 )"
arch_binaries="$arch_binaries ppc64? ( http://code.haskell.org/~slyfox/ghc-ppc64/ghc-bin-${PV}-ppc64.tbz2 )"
arch_binaries="$arch_binaries sparc? ( http://code.haskell.org/~slyfox/ghc-sparc/ghc-bin-${PV}-sparc.tbz2 )"
@@ -60,6 +60,7 @@ yet_binary() {
# return 0
#;;
amd64) return 0 ;;
+ ia64) return 0 ;;
ppc) return 0 ;;
ppc64) return 0 ;;
sparc) return 0 ;;
@@ -73,8 +74,8 @@ SRC_URI="!binary? ( http://www.haskell.org/ghc/dist/${PV}/${P}-src.tar.bz2 )"
LICENSE="BSD"
SLOT="0/${PV}"
# ghc on ia64 needs gcc to support -mcmodel=medium (or some dark hackery) to avoid TOC overflow
-KEYWORDS="~alpha ~amd64 -ia64 ~ppc ~ppc64 ~sparc ~x86 ~x86-fbsd ~amd64-linux ~x86-linux ~ppc-macos ~x86-macos ~sparc-solaris ~x86-solaris"
-IUSE="doc ghcbootstrap ghcmakebinary llvm"
+KEYWORDS="~alpha ~amd64 ~ia64 ~ppc ~ppc64 ~sparc ~x86 ~x86-fbsd ~amd64-linux ~x86-linux ~ppc-macos ~x86-macos ~sparc-solaris ~x86-solaris"
+IUSE="doc ghcbootstrap ghcmakebinary +gmp llvm"
IUSE+=" binary" # don't forget about me later!
IUSE+=" elibc_glibc" # system stuff
@@ -108,6 +109,9 @@ PDEPEND="
${PDEPEND}
llvm? ( sys-devel/llvm )"
+# ia64 fails to return from STG GMP primitives (stage2 always SIGSEGVs)
+REQUIRED_USE="ia64? ( !gmp )"
+
append-ghc-cflags() {
local flag compile assemble link
for flag in $*; do
@@ -468,6 +472,12 @@ src_configure() {
export PATH="${WORKDIR}/usr/bin:${PATH}"
fi
+ if use gmp; then
+ echo "INTEGER_LIBRARY=integer-gmp" >> mk/build.mk
+ else
+ echo "INTEGER_LIBRARY=integer-simple" >> mk/build.mk
+ fi
+
# Since GHC 6.12.2 the GHC wrappers store which GCC version GHC was
# compiled with, by saving the path to it. The purpose is to make sure
# that GHC will use the very same gcc version when it compiles haskell