summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorGeorge Shapovalov <george@gentoo.org>2011-05-23 14:24:56 +0000
committerGeorge Shapovalov <george@gentoo.org>2011-05-23 14:24:56 +0000
commitc998951622707dd701ce9f3c4a136579c15095fe (patch)
treebf73e4eef42804798aeb01c9a0a2f21e59e9b68d /dev-lang
parentDEL (diff)
downloadgentoo-2-c998951622707dd701ce9f3c4a136579c15095fe.tar.gz
gentoo-2-c998951622707dd701ce9f3c4a136579c15095fe.tar.bz2
gentoo-2-c998951622707dd701ce9f3c4a136579c15095fe.zip
new version uding new bootstrap. Should fix #327043
(Portage version: 2.1.9.49/cvs/Linux x86_64)
Diffstat (limited to 'dev-lang')
-rw-r--r--dev-lang/gnat-gcc/ChangeLog9
-rw-r--r--dev-lang/gnat-gcc/gnat-gcc-4.4.5.ebuild62
2 files changed, 69 insertions, 2 deletions
diff --git a/dev-lang/gnat-gcc/ChangeLog b/dev-lang/gnat-gcc/ChangeLog
index a74017bb3ae8..bc0f2599404d 100644
--- a/dev-lang/gnat-gcc/ChangeLog
+++ b/dev-lang/gnat-gcc/ChangeLog
@@ -1,10 +1,15 @@
# ChangeLog for dev-lang/gnat-gcc
# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-lang/gnat-gcc/ChangeLog,v 1.39 2011/03/10 19:59:39 george Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-lang/gnat-gcc/ChangeLog,v 1.40 2011/05/23 14:24:56 george Exp $
+
+*gnat-gcc-4.4.5 (23 May 2011)
+
+ 23 May 2011; George Shapovalov <george-cvs@gentoo.org> +gnat-gcc-4.4.5.ebuild:
+ new version; using new bootstrap, should fix buig #327043
*gnat-gcc-4.4.3 (10 Mar 2011)
- 10 Mar 2011; <portage-cvs@gentoo.org> +gnat-gcc-4.3.5.ebuild,
+ 10 Mar 2011; George Shapovalov <george-cvs@gentoo.org> +gnat-gcc-4.3.5.ebuild,
+gnat-gcc-4.4.3.ebuild:
an overdue major bump. Finally got 4.4 working. Homefully more to follow
soon..
diff --git a/dev-lang/gnat-gcc/gnat-gcc-4.4.5.ebuild b/dev-lang/gnat-gcc/gnat-gcc-4.4.5.ebuild
new file mode 100644
index 000000000000..f099f845dcbc
--- /dev/null
+++ b/dev-lang/gnat-gcc/gnat-gcc-4.4.5.ebuild
@@ -0,0 +1,62 @@
+# Copyright 1999-2011 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-lang/gnat-gcc/gnat-gcc-4.4.5.ebuild,v 1.1 2011/05/23 14:24:56 george Exp $
+
+inherit gnatbuild autotools
+
+DESCRIPTION="GNAT Ada Compiler - gcc version"
+HOMEPAGE="http://gcc.gnu.org/"
+LICENSE="GMGPL"
+
+IUSE=""
+
+BOOT_SLOT="4.3"
+
+# SLOT is set in gnatbuild.eclass, depends only on PV (basically SLOT=GCCBRANCH)
+# so the URI's are static.
+SRC_URI="ftp://gcc.gnu.org/pub/gcc/releases/gcc-${PV}/gcc-core-${PV}.tar.bz2
+ ftp://gcc.gnu.org/pub/gcc/releases/gcc-${PV}/gcc-ada-${PV}.tar.bz2
+ amd64? ( http://dev.gentoo.org/~george/src/gnatboot-${SLOT}-amd64.tar.bz2 )
+ sparc? ( http://dev.gentoo.org/~george/src/gnatboot-${BOOT_SLOT}-sparc.tar.bz2 )
+ x86? ( http://dev.gentoo.org/~george/src/gnatboot-${BOOT_SLOT}-i686.tar.bz2 )"
+# ppc? ( mirror://gentoo/gnatboot-${BOOT_SLOT}-ppc.tar.bz2 )
+
+KEYWORDS="~amd64 ~x86 ~sparc"
+
+# starting with 4.3.0 gnat needs these libs
+RDEPEND=">=dev-libs/mpfr-3.0.1
+ >=dev-libs/gmp-5.0
+ >=sys-libs/zlib-1.2
+ >=sys-libs/ncurses-5.7"
+
+DEPEND="${RDEPEND}
+ >=sys-devel/bison-1.875
+ >=sys-libs/glibc-2.8
+ >=sys-devel/binutils-2.20"
+
+#QA_EXECSTACK="${BINPATH:1}/gnatls ${BINPATH:1}/gnatbind ${BINPATH:1}/gnatmake
+# ${LIBEXECPATH:1}/gnat1 ${LIBPATH:1}/adalib/libgnat-${SLOT}.so"
+
+src_unpack() {
+ gnatbuild_src_unpack
+
+ #fixup some hardwired flags
+ cd "${S}"/gcc/ada
+
+ # universal gcc -> gnatgcc substitution occasionally produces lines too long
+ # and then build halts on the style check.
+ #
+ sed -i -e 's:and Nam is "gnatgcc":and Nam is "gcc":' osint.ads ||
+ die "reversing [gnat]gcc substitution in comments failed"
+
+ # gcc pretty much ignores --with-system-zlib. At least it still descends
+ # into zlib and does configure and build there (gcc bug@7125?). For whatever
+ # reason this conflicts with multilib in gcc-4.4..
+ sed -i -e "s:libgui zlib:libgui:" "${S}"/configure
+}
+
+src_compile() {
+ # looks like gnatlib_and_tools and gnatlib_shared have become part of
+ # bootstrap
+ gnatbuild_src_compile configure make-tools bootstrap
+}