summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorHarald van Dijk <truedfx@gentoo.org>2009-07-10 21:44:58 +0000
committerHarald van Dijk <truedfx@gentoo.org>2009-07-10 21:44:58 +0000
commitfca7aae08f88f01131449bc8be76173a189acb91 (patch)
tree458b551ae7a828e603f66c7e694d32ec3d4fd2ed /dev-lang
parentPyQt4 use dep, #272142 (diff)
downloadgentoo-2-fca7aae08f88f01131449bc8be76173a189acb91.tar.gz
gentoo-2-fca7aae08f88f01131449bc8be76173a189acb91.tar.bz2
gentoo-2-fca7aae08f88f01131449bc8be76173a189acb91.zip
Version bump, with amd64 support
(Portage version: 2.2_rc33/cvs/Linux i686)
Diffstat (limited to 'dev-lang')
-rw-r--r--dev-lang/tcc/ChangeLog9
-rw-r--r--dev-lang/tcc/tcc-0.9.25.ebuild62
2 files changed, 69 insertions, 2 deletions
diff --git a/dev-lang/tcc/ChangeLog b/dev-lang/tcc/ChangeLog
index da3bada4f5fc..dc2c05057298 100644
--- a/dev-lang/tcc/ChangeLog
+++ b/dev-lang/tcc/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for dev-lang/tcc
-# Copyright 2002-2009 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-lang/tcc/ChangeLog,v 1.28 2009/01/04 21:03:25 patrick Exp $
+# Copyright 1999-2009 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/dev-lang/tcc/ChangeLog,v 1.29 2009/07/10 21:44:58 truedfx Exp $
+
+*tcc-0.9.25 (10 Jul 2009)
+
+ 10 Jul 2009; Harald van Dijk <truedfx@gentoo.org> +tcc-0.9.25.ebuild:
+ Version bump, with amd64 support (#276586 by Thomas)
*tcc-0.9.24 (04 Jan 2009)
diff --git a/dev-lang/tcc/tcc-0.9.25.ebuild b/dev-lang/tcc/tcc-0.9.25.ebuild
new file mode 100644
index 000000000000..554690eea858
--- /dev/null
+++ b/dev-lang/tcc/tcc-0.9.25.ebuild
@@ -0,0 +1,62 @@
+# Copyright 1999-2009 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-lang/tcc/tcc-0.9.25.ebuild,v 1.1 2009/07/10 21:44:58 truedfx Exp $
+
+inherit eutils
+
+IUSE=""
+DESCRIPTION="A very small C compiler for ix86/amd64"
+HOMEPAGE="http://bellard.org/tcc/"
+SRC_URI="http://download.savannah.nongnu.org/releases/tinycc/${P}.tar.bz2"
+
+LICENSE="LGPL-2.1"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+DEPEND=""
+# Both tendra and tinycc install /usr/bin/tcc
+RDEPEND="!dev-lang/tendra"
+
+# Testsuite is broken, relies on gcc to compile
+# invalid C code that it no longer accepts
+RESTRICT="test"
+
+src_unpack() {
+ unpack ${A}
+ cd "${S}"
+ #epatch "${FILESDIR}"/${PN}-0.9.23-anonunion.patch
+ #epatch "${FILESDIR}"/${PN}-0.9.23-asneeded.patch
+ #epatch "${FILESDIR}"/${PN}-0.9.23-nxbit.patch
+
+ # Don't strip
+ sed -i -e 's|$(INSTALL) -s|$(INSTALL)|' Makefile
+
+ # Fix examples
+ sed -i -e '1{
+ i#! /usr/bin/tcc -run
+ /^#!/d
+ }' examples/ex*.c
+ sed -i -e '1s/$/ -lX11/' examples/ex4.c
+}
+
+src_compile() {
+ local myopts
+ use x86 && myopts="--cpu=x86"
+ use amd64 && myopts="--cpu=x86-64"
+ econf ${myopts}
+ emake || die "make failed"
+}
+
+src_install() {
+ emake \
+ bindir="${D}"/usr/bin \
+ libdir="${D}"/usr/lib \
+ tccdir="${D}"/usr/lib/tcc \
+ includedir="${D}"/usr/include \
+ docdir="${D}"/usr/share/doc/${PF} \
+ mandir="${D}"/usr/share/man install || die "make install failed"
+ dodoc Changelog README TODO VERSION
+ dohtml tcc-doc.html
+ exeinto /usr/share/doc/${PF}/examples
+ doexe examples/ex*.c
+}