summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMarkos Chandras <hwoarang@gentoo.org>2011-07-07 10:21:09 +0000
committerMarkos Chandras <hwoarang@gentoo.org>2011-07-07 10:21:09 +0000
commit1ba4d2730ca18825f7b3ed81aff44aca410387e6 (patch)
tree79e67c8c5038ab04e0c3d854fb69e8e16246f4b7 /dev-libs/apr
parentapp-admin/swatch: Drop old. (diff)
downloadgentoo-2-1ba4d2730ca18825f7b3ed81aff44aca410387e6.tar.gz
gentoo-2-1ba4d2730ca18825f7b3ed81aff44aca410387e6.tar.bz2
gentoo-2-1ba4d2730ca18825f7b3ed81aff44aca410387e6.zip
Version bump. Requested by Arfrever
(Portage version: 2.2.0_alpha43/cvs/Linux x86_64)
Diffstat (limited to 'dev-libs/apr')
-rw-r--r--dev-libs/apr/ChangeLog7
-rw-r--r--dev-libs/apr/apr-1.4.5.ebuild87
2 files changed, 93 insertions, 1 deletions
diff --git a/dev-libs/apr/ChangeLog b/dev-libs/apr/ChangeLog
index 22a61c19de78..22d70015841b 100644
--- a/dev-libs/apr/ChangeLog
+++ b/dev-libs/apr/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for dev-libs/apr
# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-libs/apr/ChangeLog,v 1.173 2011/05/14 19:30:43 armin76 Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-libs/apr/ChangeLog,v 1.174 2011/07/07 10:21:09 hwoarang Exp $
+
+*apr-1.4.5 (07 Jul 2011)
+
+ 07 Jul 2011; Markos Chandras <hwoarang@gentoo.org> +apr-1.4.5.ebuild:
+ Version bump. Requested by Arfrever
14 May 2011; Raúl Porcel <armin76@gentoo.org> apr-1.4.4.ebuild:
alpha/arm/ia64/s390/sh/sparc stable wrt #366903
diff --git a/dev-libs/apr/apr-1.4.5.ebuild b/dev-libs/apr/apr-1.4.5.ebuild
new file mode 100644
index 000000000000..f779ee34a799
--- /dev/null
+++ b/dev-libs/apr/apr-1.4.5.ebuild
@@ -0,0 +1,87 @@
+# Copyright 1999-2011 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-libs/apr/apr-1.4.5.ebuild,v 1.1 2011/07/07 10:21:09 hwoarang Exp $
+
+EAPI="3"
+
+inherit autotools eutils libtool multilib
+
+DESCRIPTION="Apache Portable Runtime Library"
+HOMEPAGE="http://apr.apache.org/"
+SRC_URI="mirror://apache/apr/${P}.tar.bz2"
+
+LICENSE="Apache-2.0"
+SLOT="1"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~sparc-fbsd ~x86-fbsd"
+IUSE="doc elibc_FreeBSD older-kernels-compatibility +urandom +uuid"
+RESTRICT="test"
+
+RDEPEND="uuid? ( !elibc_FreeBSD? ( >=sys-apps/util-linux-2.16 ) )"
+DEPEND="${RDEPEND}
+ doc? ( app-doc/doxygen )"
+
+src_prepare() {
+ # Ensure that system libtool is used.
+ sed -e 's:${installbuilddir}/libtool:/usr/bin/libtool:' -i apr-config.in || die "sed failed"
+ sed -e 's:@LIBTOOL@:$(SHELL) /usr/bin/libtool:' -i build/apr_rules.mk.in || die "sed failed"
+
+ AT_M4DIR="build" eautoreconf
+ elibtoolize
+
+ epatch "${FILESDIR}/config.layout.patch"
+}
+
+src_configure() {
+ local myconf
+
+ if use older-kernels-compatibility; then
+ local apr_cv_accept4 apr_cv_dup3 apr_cv_epoll_create1 apr_cv_sock_cloexec
+ export apr_cv_accept4="no"
+ export apr_cv_dup3="no"
+ export apr_cv_epoll_create1="no"
+ export apr_cv_sock_cloexec="no"
+ fi
+
+ if use urandom; then
+ myconf+=" --with-devrandom=/dev/urandom"
+ else
+ myconf+=" --with-devrandom=/dev/random"
+ fi
+
+ if ! use uuid; then
+ local apr_cv_osuuid
+ export apr_cv_osuuid="no"
+ fi
+
+ CONFIG_SHELL="/bin/bash" econf \
+ --enable-layout=gentoo \
+ --enable-nonportable-atomics \
+ --enable-threads \
+ ${myconf}
+
+ rm -f libtool
+}
+
+src_compile() {
+ emake || die "emake failed"
+
+ if use doc; then
+ emake dox || die "emake dox failed"
+ fi
+}
+
+src_install() {
+ emake DESTDIR="${D}" install || die "emake install failed"
+
+ find "${ED}" -name "*.la" -print0 | xargs -0 rm -f
+
+ dodoc CHANGES NOTICE README
+
+ if use doc; then
+ dohtml -r docs/dox/html/* || die "dohtml failed"
+ fi
+
+ # This file is only used on AIX systems, which Gentoo is not,
+ # and causes collisions between the SLOTs, so remove it.
+ rm -f "${D}usr/$(get_libdir)/apr.exp"
+}