summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorNirbheek Chauhan <nirbheek@gentoo.org>2011-08-14 13:04:58 +0000
committerNirbheek Chauhan <nirbheek@gentoo.org>2011-08-14 13:04:58 +0000
commit768d16b47c45a9cdce4f42943b5d0cdbf20371a2 (patch)
tree88916010cebbbf0ccc17d4e56613fdecc93b50a2 /dev-libs/atk
parentRestrict gentoopm due to bug in slr. (diff)
downloadgentoo-2-768d16b47c45a9cdce4f42943b5d0cdbf20371a2.tar.gz
gentoo-2-768d16b47c45a9cdce4f42943b5d0cdbf20371a2.tar.bz2
gentoo-2-768d16b47c45a9cdce4f42943b5d0cdbf20371a2.zip
Bump to 2.0.1, for GNOME 3
(Portage version: 2.2.0_alpha39_p14/cvs/Linux x86_64)
Diffstat (limited to 'dev-libs/atk')
-rw-r--r--dev-libs/atk/ChangeLog7
-rw-r--r--dev-libs/atk/atk-2.0.1.ebuild43
2 files changed, 49 insertions, 1 deletions
diff --git a/dev-libs/atk/ChangeLog b/dev-libs/atk/ChangeLog
index b778a82d30bf..d6c1f0353ca4 100644
--- a/dev-libs/atk/ChangeLog
+++ b/dev-libs/atk/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for dev-libs/atk
# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-libs/atk/ChangeLog,v 1.226 2011/07/11 00:03:33 mattst88 Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-libs/atk/ChangeLog,v 1.227 2011/08/14 13:04:58 nirbheek Exp $
+
+*atk-2.0.1 (14 Aug 2011)
+
+ 14 Aug 2011; Nirbheek Chauhan <nirbheek@gentoo.org> +atk-2.0.1.ebuild:
+ Bump to 2.0.1, for GNOME 3
11 Jul 2011; Matt Turner <mattst88@gentoo.org> atk-1.32.0-r1.ebuild:
Added ~mips, bug 364693
diff --git a/dev-libs/atk/atk-2.0.1.ebuild b/dev-libs/atk/atk-2.0.1.ebuild
new file mode 100644
index 000000000000..2b4595da4aa8
--- /dev/null
+++ b/dev-libs/atk/atk-2.0.1.ebuild
@@ -0,0 +1,43 @@
+# Copyright 1999-2011 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-libs/atk/atk-2.0.1.ebuild,v 1.1 2011/08/14 13:04:58 nirbheek Exp $
+
+EAPI="3"
+GCONF_DEBUG="no"
+
+inherit gnome2
+
+DESCRIPTION="GTK+ & GNOME Accessibility Toolkit"
+HOMEPAGE="http://projects.gnome.org/accessibility/"
+
+LICENSE="LGPL-2"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~x86-fbsd ~x86-freebsd ~x86-interix ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~sparc-solaris ~sparc64-solaris ~x64-solaris ~x86-solaris ~x86-winnt"
+IUSE="doc +introspection nls"
+
+RDEPEND="dev-libs/glib:2
+ introspection? ( >=dev-libs/gobject-introspection-0.6.7 )"
+DEPEND="${RDEPEND}
+ >=dev-lang/perl-5
+ dev-util/pkgconfig
+ doc? ( >=dev-util/gtk-doc-1.13 )
+ nls? ( sys-devel/gettext )"
+
+pkg_setup() {
+ G2CONF="${G2CONF} $(use_enable introspection)"
+ DOCS="AUTHORS ChangeLog NEWS README"
+}
+
+src_prepare() {
+ gnome2_src_prepare
+
+ if ! use test; then
+ # don't waste time building tests (bug #226353)
+ sed 's/^\(SUBDIRS =.*\)tests\(.*\)$/\1\2/' -i Makefile.am Makefile.in \
+ || die "sed failed"
+ fi
+
+ # Remove DEPRECATED flags
+ sed -e '/-D[A-Z_]*DISABLE_DEPRECATED/d' -i atk/Makefile.am atk/Makefile.in \
+ tests/Makefile.am tests/Makefile.in || die "sed 2 failed"
+}