summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorNaohiro Aota <naota@gentoo.org>2012-10-13 13:42:13 +0000
committerNaohiro Aota <naota@gentoo.org>2012-10-13 13:42:13 +0000
commit2c68bb6f8246ecfefdbee15e785a2cc6542082bd (patch)
treeddb7ce4e13bde3a8e9ea4b0af25499da29e776b7 /dev-libs/boehm-gc
parentRemove pogooglue USE flag by upstream's request (diff)
downloadgentoo-2-2c68bb6f8246ecfefdbee15e785a2cc6542082bd.tar.gz
gentoo-2-2c68bb6f8246ecfefdbee15e785a2cc6542082bd.tar.bz2
gentoo-2-2c68bb6f8246ecfefdbee15e785a2cc6542082bd.zip
Add patch to fix bash-ism configure; Add ~x86-fbsd.
(Portage version: 2.2.0_alpha134/cvs/Linux x86_64)
Diffstat (limited to 'dev-libs/boehm-gc')
-rw-r--r--dev-libs/boehm-gc/ChangeLog6
-rw-r--r--dev-libs/boehm-gc/boehm-gc-7.2d.ebuild8
-rw-r--r--dev-libs/boehm-gc/files/boehm-gc-7.2d-configure.patch33
3 files changed, 44 insertions, 3 deletions
diff --git a/dev-libs/boehm-gc/ChangeLog b/dev-libs/boehm-gc/ChangeLog
index 83bf27a05674..42bb4d336f9c 100644
--- a/dev-libs/boehm-gc/ChangeLog
+++ b/dev-libs/boehm-gc/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for dev-libs/boehm-gc
# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-libs/boehm-gc/ChangeLog,v 1.82 2012/10/01 09:25:14 radhermit Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-libs/boehm-gc/ChangeLog,v 1.83 2012/10/13 13:42:13 naota Exp $
+
+ 13 Oct 2012; <naota@gentoo.org> +files/boehm-gc-7.2d-configure.patch,
+ boehm-gc-7.2d.ebuild:
+ Add patch to fix bash-ism configure; Add ~x86-fbsd.
*boehm-gc-7.2d (01 Oct 2012)
diff --git a/dev-libs/boehm-gc/boehm-gc-7.2d.ebuild b/dev-libs/boehm-gc/boehm-gc-7.2d.ebuild
index 6cc1ba0ed648..51a8ccf9eb47 100644
--- a/dev-libs/boehm-gc/boehm-gc-7.2d.ebuild
+++ b/dev-libs/boehm-gc/boehm-gc-7.2d.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2012 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-libs/boehm-gc/boehm-gc-7.2d.ebuild,v 1.1 2012/10/01 09:25:14 radhermit Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-libs/boehm-gc/boehm-gc-7.2d.ebuild,v 1.2 2012/10/13 13:42:13 naota Exp $
EAPI=4
@@ -16,7 +16,7 @@ SRC_URI="http://www.hpl.hp.com/personal/Hans_Boehm/gc/gc_source/${MY_P}.tar.gz"
LICENSE="as-is"
SLOT="0"
-KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~ppc ~ppc64 ~sparc ~x86 ~x86-freebsd ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~sparc-solaris ~x64-solaris ~x86-solaris"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~ppc ~ppc64 ~sparc ~x86 ~x86-fbsd ~x86-freebsd ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~sparc-solaris ~x64-solaris ~x86-solaris"
IUSE="cxx static-libs threads"
RDEPEND=">=dev-libs/libatomic_ops-7.2"
@@ -27,6 +27,10 @@ S="${WORKDIR}/${MY_P/d}"
DOCS=( README.QUICK doc/README{,.environment,.linux,.macros} doc/barrett_diagram )
+PATCHES=( "${FILESDIR}"/${P}-configure.patch )
+
+AUTOTOOLS_AUTORECONF=1
+
src_prepare() {
sed '/Cflags/s:$:/gc:g' -i bdw-gc.pc.in || die
sed \
diff --git a/dev-libs/boehm-gc/files/boehm-gc-7.2d-configure.patch b/dev-libs/boehm-gc/files/boehm-gc-7.2d-configure.patch
new file mode 100644
index 000000000000..fdada4394cc4
--- /dev/null
+++ b/dev-libs/boehm-gc/files/boehm-gc-7.2d-configure.patch
@@ -0,0 +1,33 @@
+diff --git a/configure.ac b/configure.ac
+index ee6693d..45300c0 100644
+--- a/configure.ac
++++ b/configure.ac
+@@ -337,7 +337,7 @@ if test $compiler_xlc = yes -a "$powerpc_darwin" = true; then
+ AC_DEFINE([DARWIN_DONT_PARSE_STACK], 1, [See doc/README.macros.])
+ fi
+
+-if test "$GCC" == yes; then
++if test "$GCC" = yes; then
+ # Disable aliasing optimization unless forced to.
+ AC_MSG_CHECKING([whether gcc supports -fno-strict-aliasing])
+ ac_cv_fno_strict_aliasing=no
+@@ -442,8 +442,8 @@ esac
+ AC_MSG_RESULT($enable_shared)
+
+ # Compile with GC_DLL defined unless building static libraries.
+-if test "${enable_shared}" == yes; then
+- if test "${enable_static}" == no; then
++if test "${enable_shared}" = yes; then
++ if test "${enable_static}" = no; then
+ AC_DEFINE(GC_DLL)
+ # FIXME: Also pass -fvisibility=hidden option if GCC v4+ and not Win32.
+ fi
+@@ -707,7 +707,7 @@ if test -n "${with_cross_host}"; then
+ [Define to tune the collector for small heap sizes.])
+ fi
+
+-if test "$enable_gc_debug" == "no"; then
++if test "$enable_gc_debug" = "no"; then
+ AC_DEFINE([NO_DEBUGGING], 1,
+ [Disable debugging, like GC_dump and its callees.])
+ fi