summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMarcelo Góes <vanquirius@gentoo.org>2007-01-31 01:57:30 +0000
committerMarcelo Góes <vanquirius@gentoo.org>2007-01-31 01:57:30 +0000
commitf72efc817818d676b0702d0253a13cbdc597dbf6 (patch)
treeae0cd8979b5ef14f0eb1477a94a66812ed254865 /dev-libs/crypto++/crypto++-5.4.ebuild
parentStable on amd64 per bug #164336 (diff)
downloadgentoo-2-f72efc817818d676b0702d0253a13cbdc597dbf6.tar.gz
gentoo-2-f72efc817818d676b0702d0253a13cbdc597dbf6.tar.bz2
gentoo-2-f72efc817818d676b0702d0253a13cbdc597dbf6.zip
Remove old version, 5.4 version bump.
(Portage version: 2.1.1-r2)
Diffstat (limited to 'dev-libs/crypto++/crypto++-5.4.ebuild')
-rw-r--r--dev-libs/crypto++/crypto++-5.4.ebuild60
1 files changed, 60 insertions, 0 deletions
diff --git a/dev-libs/crypto++/crypto++-5.4.ebuild b/dev-libs/crypto++/crypto++-5.4.ebuild
new file mode 100644
index 000000000000..333b2fb7ce6b
--- /dev/null
+++ b/dev-libs/crypto++/crypto++-5.4.ebuild
@@ -0,0 +1,60 @@
+# Copyright 1999-2007 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-libs/crypto++/crypto++-5.4.ebuild,v 1.1 2007/01/31 01:57:30 vanquirius Exp $
+
+inherit flag-o-matic eutils
+
+DESCRIPTION="Crypto++ is a C++ class library of cryptographic schemes"
+HOMEPAGE="http://cryptopp.com"
+SRC_URI="mirror://sourceforge/cryptopp/cryptopp${PV//.}.zip"
+
+LICENSE="cryptopp"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~ppc64 ~sparc ~x86"
+DEPEND="app-arch/unzip"
+RDEPEND=""
+IUSE=""
+
+S="${WORKDIR}"
+
+src_compile() {
+ # -O3 causes segfaults
+ replace-flags -O3 -O2
+ filter-flags -fomit-frame-pointer
+ filter-flags -msse2
+ if use x86 || use amd64
+ then
+ append-flags -mno-sse2
+ fi
+ emake -f GNUmakefile || die
+}
+
+
+src_test() {
+ # make sure all test vectors have unix line endings
+ for f in TestVectors/* ; do
+ edos2unix $f
+ done
+
+ if ! ./cryptest.exe v
+ then
+ eerror "crypto++ self-tests failed"
+ eerror "Try to remove some optimization flags and re-emerge"
+ die
+ fi;
+}
+
+src_install() {
+ # For consistency across GNU/Linux distributions,
+ # "crypto++" has been preferred over "crytopp"...
+ newlib.a libcryptopp.a libcrypto++.a
+ # ...unbreak programs which don't expect this
+ dosym libcrypto++.a /usr/lib/libcryptopp.a
+ insinto /usr/include/crypto++
+ doins *.h
+ # should the .exe extension be removed??
+ dobin cryptest.exe
+ # unbreak programs which expect cryptopp
+ into /usr/include
+ dosym crypto++ /usr/include/cryptopp
+}