summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorKarl Trygve Kalleberg <karltk@gentoo.org>2002-02-10 21:27:52 +0000
committerKarl Trygve Kalleberg <karltk@gentoo.org>2002-02-10 21:27:52 +0000
commitb5bb357269ae9d78639d56b31fdeff9c2c1baa7c (patch)
tree092c2cfa07905d3c2325fdd1cedec5762d0a4dae /dev-libs/libffi
parentNetscape Portable Runtime 4.1.2 (diff)
downloadgentoo-2-b5bb357269ae9d78639d56b31fdeff9c2c1baa7c.tar.gz
gentoo-2-b5bb357269ae9d78639d56b31fdeff9c2c1baa7c.tar.bz2
gentoo-2-b5bb357269ae9d78639d56b31fdeff9c2c1baa7c.zip
libffi - foreign functions interface helper
Diffstat (limited to 'dev-libs/libffi')
-rw-r--r--dev-libs/libffi/ChangeLog19
-rw-r--r--dev-libs/libffi/files/digest-libffi-1.201
-rw-r--r--dev-libs/libffi/libffi-1.20.ebuild27
3 files changed, 47 insertions, 0 deletions
diff --git a/dev-libs/libffi/ChangeLog b/dev-libs/libffi/ChangeLog
new file mode 100644
index 000000000000..5b608cfab86b
--- /dev/null
+++ b/dev-libs/libffi/ChangeLog
@@ -0,0 +1,19 @@
+# ChangeLog for dev-libs/libffi
+# Copyright 2002 Gentoo Technologies, Inc.; Distributed under the GPL
+# $Header: /var/cvsroot/gentoo-x86/dev-libs/libffi/ChangeLog,v 1.1 2002/02/10 21:27:52 karltk Exp $
+
+*libffi-0.20 ( 10 Feb 2002 )
+
+ 10 Feb 2002; Karl Trygve Kalleberg <karltk@gentoo.org> ChangeLog files/digest-libffi-0.20 libffi-0.20:
+
+ The libffi library provides a portable, high level programming interface to
+ various calling conventions. This allows a programmer to call any function
+ specified by a call interface description at run-time.
+
+ Ffi stands for Foreign Function Interface. A foreign function interface is
+ the popular name for the interface that allows code written in one language
+ to call code written in another language. The libffi library really only
+ provides the lowest, machine dependent layer of a fully featured foreign
+ function interface. A layer must exist above libffi that handles type
+ conversions for values passed between the two languages.
+
diff --git a/dev-libs/libffi/files/digest-libffi-1.20 b/dev-libs/libffi/files/digest-libffi-1.20
new file mode 100644
index 000000000000..c90c0711310a
--- /dev/null
+++ b/dev-libs/libffi/files/digest-libffi-1.20
@@ -0,0 +1 @@
+MD5 e4c9c435ebdfcba6fa493fb1abce2ddc libffi-1.20.tar.gz 110592
diff --git a/dev-libs/libffi/libffi-1.20.ebuild b/dev-libs/libffi/libffi-1.20.ebuild
new file mode 100644
index 000000000000..ab98032fc7b2
--- /dev/null
+++ b/dev-libs/libffi/libffi-1.20.ebuild
@@ -0,0 +1,27 @@
+# Copyright 1999-2001 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License, v2 or later
+# Maintainer: Tools Team <tools@gentoo.org>
+# Author: Karl Trygve Kalleberg <karltk@gentoo.org>
+# $Header: /var/cvsroot/gentoo-x86/dev-libs/libffi/libffi-1.20.ebuild,v 1.1 2002/02/10 21:27:52 karltk Exp $
+
+S=${WORKDIR}/${P}
+DESCRIPTION="Support library for Foreign Functions Interfaces"
+SRC_URI="ftp://sourceware.cygnus.com/pub/libffi/libffi-1.20.tar.gz"
+HOMEPAGE="http://sources.redhat.com/libffi/"
+
+DEPEND=""
+#RDEPEND=""
+
+src_compile() {
+ ./configure \
+ --host=${CHOST} \
+ --prefix=/usr \
+ --infodir=/usr/share/info \
+ --mandir=/usr/share/man || die "./configure failed"
+ emake || die
+}
+
+src_install () {
+ make DESTDIR=${D} install || die
+ dodoc README ChangeLog LICENSE
+}