summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJeroen Roovers <jer@gentoo.org>2015-03-12 19:40:55 +0000
committerJeroen Roovers <jer@gentoo.org>2015-03-12 19:40:55 +0000
commit369b3f14e5e5de2f99d9c1098c4816806dd151d5 (patch)
tree461f69b428b5cc4de6601a4e8dd18725a86bd1e8 /dev-libs/libnl
parentold (diff)
downloadgentoo-2-369b3f14e5e5de2f99d9c1098c4816806dd151d5.tar.gz
gentoo-2-369b3f14e5e5de2f99d9c1098c4816806dd151d5.tar.bz2
gentoo-2-369b3f14e5e5de2f99d9c1098c4816806dd151d5.zip
Version bump.
(Portage version: 2.2.18/cvs/Linux x86_64, signed Manifest commit with key A792A613)
Diffstat (limited to 'dev-libs/libnl')
-rw-r--r--dev-libs/libnl/ChangeLog7
-rw-r--r--dev-libs/libnl/libnl-3.2.26_rc1.ebuild103
2 files changed, 109 insertions, 1 deletions
diff --git a/dev-libs/libnl/ChangeLog b/dev-libs/libnl/ChangeLog
index ef94c0b0fb88..69c3b506fb2f 100644
--- a/dev-libs/libnl/ChangeLog
+++ b/dev-libs/libnl/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for dev-libs/libnl
# Copyright 1999-2015 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-libs/libnl/ChangeLog,v 1.219 2015/03/02 09:23:05 ago Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-libs/libnl/ChangeLog,v 1.220 2015/03/12 19:40:55 jer Exp $
+
+*libnl-3.2.26_rc1 (12 Mar 2015)
+
+ 12 Mar 2015; Jeroen Roovers <jer@gentoo.org> +libnl-3.2.26_rc1.ebuild:
+ Version bump.
02 Mar 2015; Agostino Sarubbo <ago@gentoo.org> libnl-3.2.25.ebuild:
Stable for ppc, wrt bug #509544
diff --git a/dev-libs/libnl/libnl-3.2.26_rc1.ebuild b/dev-libs/libnl/libnl-3.2.26_rc1.ebuild
new file mode 100644
index 000000000000..b3ed1ad9a66d
--- /dev/null
+++ b/dev-libs/libnl/libnl-3.2.26_rc1.ebuild
@@ -0,0 +1,103 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-libs/libnl/libnl-3.2.26_rc1.ebuild,v 1.1 2015/03/12 19:40:55 jer Exp $
+
+EAPI=5
+PYTHON_COMPAT=( python2_{6,7} python3_{2,3,4} )
+DISTUTILS_OPTIONAL=1
+inherit autotools distutils-r1 eutils libtool multilib multilib-minimal
+
+NL_PV=${PV/_/}
+NL_PV=${NL_PV//./_}
+
+DESCRIPTION="A collection of libraries providing APIs to netlink protocol based Linux kernel interfaces"
+HOMEPAGE="http://www.infradead.org/~tgr/libnl/"
+SRC_URI="
+ https://github.com/thom311/${PN}/archive/${PN}3_2_26rc1.tar.gz
+"
+LICENSE="LGPL-2.1 utils? ( GPL-2 )"
+SLOT="3"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~amd64-linux ~ia64-linux ~x86-linux"
+IUSE="static-libs python utils"
+
+RDEPEND="python? ( ${PYTHON_DEPS} )
+ abi_x86_32? (
+ !<=app-emulation/emul-linux-x86-baselibs-20140508-r5
+ !app-emulation/emul-linux-x86-baselibs[-abi_x86_32(-)]
+ )"
+DEPEND="${RDEPEND}
+ python? ( dev-lang/swig )
+ sys-devel/flex
+ sys-devel/bison
+"
+
+REQUIRED_USE="python? ( ${PYTHON_REQUIRED_USE} )"
+
+DOCS=( ChangeLog )
+
+S=${WORKDIR}/${PN}-${PN}${NL_PV}
+
+MULTILIB_WRAPPED_HEADERS=(
+ # we do not install CLI stuff for non-native
+ /usr/include/libnl3/netlink/cli/addr.h
+ /usr/include/libnl3/netlink/cli/class.h
+ /usr/include/libnl3/netlink/cli/cls.h
+ /usr/include/libnl3/netlink/cli/ct.h
+ /usr/include/libnl3/netlink/cli/exp.h
+ /usr/include/libnl3/netlink/cli/link.h
+ /usr/include/libnl3/netlink/cli/neigh.h
+ /usr/include/libnl3/netlink/cli/qdisc.h
+ /usr/include/libnl3/netlink/cli/route.h
+ /usr/include/libnl3/netlink/cli/rule.h
+ /usr/include/libnl3/netlink/cli/tc.h
+ /usr/include/libnl3/netlink/cli/utils.h
+)
+
+src_prepare() {
+ epatch "${FILESDIR}"/${PN}-1.1-vlan-header.patch
+ epatch "${FILESDIR}"/${PN}-3.2.20-rtnl_tc_get_ops.patch
+ epatch "${FILESDIR}"/${PN}-3.2.20-cache-api.patch
+
+ eautoreconf
+
+ if use python; then
+ cd "${S}"/python || die
+ distutils-r1_src_prepare
+ fi
+
+ # out-of-source build broken
+ # https://github.com/thom311/libnl/pull/58
+ multilib_copy_sources
+}
+
+multilib_src_configure() {
+ econf \
+ --disable-silent-rules \
+ $(use_enable static-libs static) \
+ $(multilib_native_use_enable utils cli)
+}
+
+multilib_src_compile() {
+ default
+
+ if multilib_is_native_abi && use python; then
+ cd python || die
+ distutils-r1_src_compile
+ fi
+}
+
+multilib_src_install() {
+ emake DESTDIR="${D}" install
+
+ if multilib_is_native_abi && use python; then
+ # Unset DOCS= since distutils-r1.eclass interferes
+ local DOCS=()
+ cd python || die
+ distutils-r1_src_install
+ fi
+}
+
+multilib_src_install_all() {
+ einstalldocs
+ prune_libtool_files --modules
+}