summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlexys Jacob <ultrabug@gentoo.org>2014-05-04 14:17:14 +0000
committerAlexys Jacob <ultrabug@gentoo.org>2014-05-04 14:17:14 +0000
commitbdd10b8d79c855ca6a727a3fee38c102f50bef7e (patch)
tree22f8a8f80f97b0db24704ad58a290ac6667222ea /dev-libs/librelp
parentVersion bump. (diff)
downloadgentoo-2-bdd10b8d79c855ca6a727a3fee38c102f50bef7e.tar.gz
gentoo-2-bdd10b8d79c855ca6a727a3fee38c102f50bef7e.tar.bz2
gentoo-2-bdd10b8d79c855ca6a727a3fee38c102f50bef7e.zip
version bump fix #509506 thx to Thomas D.
(Portage version: 2.2.10/cvs/Linux x86_64, signed Manifest commit with key B658FA13)
Diffstat (limited to 'dev-libs/librelp')
-rw-r--r--dev-libs/librelp/ChangeLog9
-rw-r--r--dev-libs/librelp/librelp-1.2.7.ebuild49
2 files changed, 56 insertions, 2 deletions
diff --git a/dev-libs/librelp/ChangeLog b/dev-libs/librelp/ChangeLog
index aae5c9a5242a..fbc6895d1548 100644
--- a/dev-libs/librelp/ChangeLog
+++ b/dev-libs/librelp/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for dev-libs/librelp
-# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-libs/librelp/ChangeLog,v 1.25 2013/12/13 10:24:16 ultrabug Exp $
+# Copyright 1999-2014 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/dev-libs/librelp/ChangeLog,v 1.26 2014/05/04 14:17:14 ultrabug Exp $
+
+*librelp-1.2.7 (04 May 2014)
+
+ 04 May 2014; Ultrabug <ultrabug@gentoo.org> +librelp-1.2.7.ebuild:
+ version bump fix #509506 thx to Thomas D.
13 Dec 2013; Ultrabug <ultrabug@gentoo.org> librelp-1.1.5.ebuild,
librelp-1.2.0.ebuild:
diff --git a/dev-libs/librelp/librelp-1.2.7.ebuild b/dev-libs/librelp/librelp-1.2.7.ebuild
new file mode 100644
index 000000000000..e3faa1b125d9
--- /dev/null
+++ b/dev-libs/librelp/librelp-1.2.7.ebuild
@@ -0,0 +1,49 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-libs/librelp/librelp-1.2.7.ebuild,v 1.1 2014/05/04 14:17:14 ultrabug Exp $
+
+EAPI=5
+
+inherit autotools-utils
+
+DESCRIPTION="An easy to use library for the RELP protocol."
+HOMEPAGE="http://www.librelp.com/"
+SRC_URI="http://download.rsyslog.com/${PN}/${P}.tar.gz"
+
+LICENSE="GPL-3 doc? ( FDL-1.3 )"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~hppa ~sparc ~x86"
+IUSE="debug doc +ssl static-libs"
+
+RDEPEND="
+ ssl? ( >=net-libs/gnutls-2.12.23-r1 )
+"
+
+DEPEND="
+ ${RDEPEND}
+ virtual/pkgconfig
+"
+
+DOCS=( AUTHORS ChangeLog )
+
+AUTOTOOLS_IN_SOURCE_BUILD=1
+
+src_configure() {
+ local myeconfargs=(
+ $(use_enable debug)
+ $(use_enable ssl tls)
+ )
+
+ autotools-utils_src_configure
+}
+
+src_install() {
+ emake DESTDIR="${D}" install || die "emake install failed"
+
+ # We don't need the *.la files - do we?
+ find "${ED}"/usr/ -name '*.la' -delete
+
+ if use doc; then
+ dohtml doc/relp.html
+ fi
+}