summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2010-05-14 03:59:59 +0000
committerRobin H. Johnson <robbat2@gentoo.org>2010-05-14 03:59:59 +0000
commitc952f9fd4dbb0444755a9a1298fbc2489dab95c0 (patch)
tree4d73d8638c3a301e60732716280b1939f9b52543 /dev-libs/libxml2
parentRemove broken 5.0.21. (diff)
downloadgentoo-2-c952f9fd4dbb0444755a9a1298fbc2489dab95c0.tar.gz
gentoo-2-c952f9fd4dbb0444755a9a1298fbc2489dab95c0.tar.bz2
gentoo-2-c952f9fd4dbb0444755a9a1298fbc2489dab95c0.zip
Fix so that the catalyst autobuilds can continue safely. If the Python binary is not present in $ROOT, python_execute_function returns successfully but silently, WITHOUT running the command (with disasterous side-effects).
(Portage version: 2.2_rc67/cvs/Linux x86_64)
Diffstat (limited to 'dev-libs/libxml2')
-rw-r--r--dev-libs/libxml2/ChangeLog8
-rw-r--r--dev-libs/libxml2/libxml2-2.7.7.ebuild12
2 files changed, 17 insertions, 3 deletions
diff --git a/dev-libs/libxml2/ChangeLog b/dev-libs/libxml2/ChangeLog
index 326457aade65..42da07f2dd06 100644
--- a/dev-libs/libxml2/ChangeLog
+++ b/dev-libs/libxml2/ChangeLog
@@ -1,6 +1,6 @@
# ChangeLog for dev-libs/libxml2
# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-libs/libxml2/ChangeLog,v 1.288 2010/05/11 21:26:13 ranger Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-libs/libxml2/ChangeLog,v 1.289 2010/05/14 03:59:59 robbat2 Exp $
11 May 2010; Brent Baude <ranger@gentoo.org> libxml2-2.7.7.ebuild:
stable ppc64, bug 317819
@@ -8,6 +8,12 @@
11 May 2010; Pawel Hajdan jr <phajdan.jr@gentoo.org> libxml2-2.7.7.ebuild:
x86 stable wrt bug #317819
+ 14 May 2010; Robin H. Johnson <robbat2@gentoo.org> libxml2-2.7.7.ebuild:
+ Fix so that the catalyst autobuilds can continue safely. If the Python
+ binary is not present in $ROOT, python_execute_function returns
+ successfully but silently, WITHOUT running the command (with disasterous
+ side-effects).
+
10 May 2010; nixnut <nixnut@gentoo.org> libxml2-2.7.7.ebuild:
ppc stable #317819
diff --git a/dev-libs/libxml2/libxml2-2.7.7.ebuild b/dev-libs/libxml2/libxml2-2.7.7.ebuild
index fdd80d33f305..44a6f6de4355 100644
--- a/dev-libs/libxml2/libxml2-2.7.7.ebuild
+++ b/dev-libs/libxml2/libxml2-2.7.7.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2010 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-libs/libxml2/libxml2-2.7.7.ebuild,v 1.7 2010/05/11 21:26:13 ranger Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-libs/libxml2/libxml2-2.7.7.ebuild,v 1.8 2010/05/14 03:59:59 robbat2 Exp $
EAPI="2"
SUPPORT_PYTHON_ABIS="1"
@@ -81,7 +81,15 @@ src_configure() {
# filter seemingly problematic CFLAGS (#26320)
filter-flags -fprefetch-loop-arrays -funroll-loops
- python_execute_function -f -q econf ${myconf}
+ # This ebuild is critical during preparation of a stage1 build.
+ # If the Python binary is not present in $ROOT, python_execute_function
+ # returns successfully but silently, WITHOUT running the command (with
+ # disasterous side-effects).
+ if use python; then
+ python_execute_function -f -q econf ${myconf}
+ else
+ econf ${myconf}
+ fi
}
src_compile() {