summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlon Bar-Lev <alonbl@gentoo.org>2006-12-21 22:14:47 +0000
committerAlon Bar-Lev <alonbl@gentoo.org>2006-12-21 22:14:47 +0000
commitf56d03f49dbeedca11269510cb06d96c188b57b9 (patch)
tree3629516aeeba42b803eea099a03e92dc784640ac /dev-libs/nss
parentVersion bump, closes bug#158707, thanks to Walter Meinl (diff)
downloadgentoo-2-f56d03f49dbeedca11269510cb06d96c188b57b9.tar.gz
gentoo-2-f56d03f49dbeedca11269510cb06d96c188b57b9.tar.bz2
gentoo-2-f56d03f49dbeedca11269510cb06d96c188b57b9.zip
Version bump, closes bug#158707, thanks to Walter Meinl
(Portage version: 2.1.1-r2)
Diffstat (limited to 'dev-libs/nss')
-rw-r--r--dev-libs/nss/ChangeLog7
-rw-r--r--dev-libs/nss/files/digest-nss-3.11.43
-rw-r--r--dev-libs/nss/nss-3.11.4.ebuild109
3 files changed, 118 insertions, 1 deletions
diff --git a/dev-libs/nss/ChangeLog b/dev-libs/nss/ChangeLog
index 21504fc58486..fb1933a3622f 100644
--- a/dev-libs/nss/ChangeLog
+++ b/dev-libs/nss/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for dev-libs/nss
# Copyright 2000-2006 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-libs/nss/ChangeLog,v 1.74 2006/10/06 23:08:35 alonbl Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-libs/nss/ChangeLog,v 1.75 2006/12/21 22:14:47 alonbl Exp $
+
+*nss-3.11.4 (21 Dec 2006)
+
+ 21 Dec 2006; Alon Bar-Lev <alonbl@gentoo.org> +nss-3.11.4.ebuild:
+ Version bump, closes bug#158707, thanks to Walter Meinl
*nss-3.11.3-r1 (06 Oct 2006)
diff --git a/dev-libs/nss/files/digest-nss-3.11.4 b/dev-libs/nss/files/digest-nss-3.11.4
new file mode 100644
index 000000000000..1b12837e6ad3
--- /dev/null
+++ b/dev-libs/nss/files/digest-nss-3.11.4
@@ -0,0 +1,3 @@
+MD5 74af8ebdf94307f47ff8931adbef9c39 nss-3.11.4.tar.gz 3713920
+RMD160 5047c7f56444b22bc5f64dbaa02576e48ab5ef2a nss-3.11.4.tar.gz 3713920
+SHA256 c50062df123d733f25d4903f42e8855adf51b7324c786c714f7dd1ab9e328f06 nss-3.11.4.tar.gz 3713920
diff --git a/dev-libs/nss/nss-3.11.4.ebuild b/dev-libs/nss/nss-3.11.4.ebuild
new file mode 100644
index 000000000000..aeb9b996e299
--- /dev/null
+++ b/dev-libs/nss/nss-3.11.4.ebuild
@@ -0,0 +1,109 @@
+# Copyright 1999-2006 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-libs/nss/nss-3.11.4.ebuild,v 1.1 2006/12/21 22:14:47 alonbl Exp $
+
+inherit eutils flag-o-matic
+
+NSPR_VER="4.6.4"
+RTM_NAME="NSS_${PV//./_}_RTM"
+DESCRIPTION="Mozilla's Netscape Security Services Library that implements PKI support"
+HOMEPAGE="http://www.mozilla.org/projects/security/pki/nss/"
+SRC_URI="ftp://ftp.mozilla.org/pub/mozilla.org/security/nss/releases/${RTM_NAME}/src/${P}.tar.gz"
+
+LICENSE="MPL-1.1"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~mips ~ppc ~ppc64 ~sparc ~x86 ~x86-fbsd"
+IUSE=""
+
+DEPEND="virtual/libc
+ app-arch/zip
+ >=dev-libs/nspr-${NSPR_VER}"
+
+src_unpack() {
+ unpack ${A}
+
+ # hack nspr paths
+ echo 'INCLUDES += -I${ROOT}/usr/include/nspr -I$(DIST)/include/dbm' \
+ >> ${S}/mozilla/security/coreconf/headers.mk || die "failed to append include"
+
+ # cope with nspr being in /usr/$(get_libdir)/nspr
+ sed -e 's:$(DIST)/lib:${ROOT}/usr/'"$(get_libdir)"/nspr':' \
+ -i ${S}/mozilla/security/coreconf/location.mk
+
+ # modify install path
+ sed -e 's:SOURCE_PREFIX = $(CORE_DEPTH)/\.\./dist:SOURCE_PREFIX = $(CORE_DEPTH)/dist:' \
+ -i ${S}/mozilla/security/coreconf/source.mk
+
+ cd ${S}
+ epatch ${FILESDIR}/${PN}-3.11-config.patch
+ epatch ${FILESDIR}/${PN}-3.11-config-1.patch
+ epatch ${FILESDIR}/${PN}-mips64.patch
+}
+
+src_compile() {
+ strip-flags
+ if use amd64 || use ppc64 || use ia64 || use s390; then
+ export USE_64=1
+ fi
+ export NSDISTMODE=copy
+ cd ${S}/mozilla/security/coreconf
+ emake -j1 BUILD_OPT=1 XCFLAGS="${CFLAGS}" || die "coreconf make failed"
+ cd ${S}/mozilla/security/dbm
+ emake -j1 BUILD_OPT=1 XCFLAGS="${CFLAGS}" || die "dbm make failed"
+ cd ${S}/mozilla/security/nss
+ emake -j1 BUILD_OPT=1 XCFLAGS="${CFLAGS}" || die "nss make failed"
+}
+
+src_install () {
+ MINOR_VERSION=11
+ cd ${S}/mozilla/security/dist
+
+ # put all *.a files in /usr/lib/nss (because some have conflicting names
+ # with existing libraries)
+ dodir /usr/$(get_libdir)/nss
+ cp -L */lib/*.so ${D}/usr/$(get_libdir)/nss || die "copying shared libs failed"
+ cp -L */lib/*.chk ${D}/usr/$(get_libdir)/nss || die "copying chk files failed"
+ cp -L */lib/*.a ${D}/usr/$(get_libdir)/nss || die "copying libs failed"
+
+ # all the include files
+ insinto /usr/include/nss
+ doins private/nss/*.h
+ doins public/nss/*.h
+ cd ${D}/usr/$(get_libdir)/nss
+ for file in *.so; do
+ mv ${file} ${file}.${MINOR_VERSION}
+ ln -s ${file}.${MINOR_VERSION} ${file}
+ done
+
+ # coping with nss being in a different path. We move up priority to
+ # ensure that nss/nspr are used specifically before searching elsewhere.
+ dodir /etc/env.d
+ echo "LDPATH=/usr/$(get_libdir)/nss" > ${D}/etc/env.d/08nss
+
+ dodir /usr/bin
+ dodir /usr/$(get_libdir)/pkgconfig
+ cp ${FILESDIR}/nss-config.in ${D}/usr/bin/nss-config
+ cp ${FILESDIR}/nss.pc.in ${D}/usr/$(get_libdir)/pkgconfig/nss.pc
+ NSS_VMAJOR=`cat ${S}/mozilla/security/nss/lib/nss/nss.h | grep "#define.*NSS_VMAJOR" | awk '{print $3}'`
+ NSS_VMINOR=`cat ${S}/mozilla/security/nss/lib/nss/nss.h | grep "#define.*NSS_VMINOR" | awk '{print $3}'`
+ NSS_VPATCH=`cat ${S}/mozilla/security/nss/lib/nss/nss.h | grep "#define.*NSS_VPATCH" | awk '{print $3}'`
+
+ sed -e "s,@libdir@,/usr/"$(get_libdir)"/nss,g" \
+ -e "s,@prefix@,/usr,g" \
+ -e "s,@exec_prefix@,\$\{prefix},g" \
+ -e "s,@includedir@,\$\{prefix}/include/nss,g" \
+ -e "s,@MOD_MAJOR_VERSION@,$NSS_VMAJOR,g" \
+ -e "s,@MOD_MINOR_VERSION@,$NSS_VMINOR,g" \
+ -e "s,@MOD_PATCH_VERSION@,$NSS_VPATCH,g" \
+ -i ${D}/usr/bin/nss-config
+ chmod 755 ${D}/usr/bin/nss-config
+
+ sed -e "s,@libdir@,/usr/"$(get_libdir)"/nss,g" \
+ -e "s,@prefix@,/usr,g" \
+ -e "s,@exec_prefix@,\$\{prefix},g" \
+ -e "s,@includedir@,\$\{prefix}/include/nss," \
+ -e "s,@NSPR_VERSION@,`nspr-config --version`,g" \
+ -e "s,@NSS_VERSION@,$NSS_VMAJOR.$NSS_VMINOR.$NSS_VPATCH,g" \
+ -i ${D}/usr/$(get_libdir)/pkgconfig/nss.pc
+ chmod 644 ${D}/usr/$(get_libdir)/pkgconfig/nss.pc
+}