summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRyan Hill <dirtyepic@gentoo.org>2008-01-07 06:00:50 +0000
committerRyan Hill <dirtyepic@gentoo.org>2008-01-07 06:00:50 +0000
commit238e5cfab694a8f79ac8504f472b6e3f8c1b5e03 (patch)
treea4c6fa9fade25a251bcdb86dc8d4793fd5149e67 /dev-libs/popt
parentStable on amd64 (diff)
downloadgentoo-2-238e5cfab694a8f79ac8504f472b6e3f8c1b5e03.tar.gz
gentoo-2-238e5cfab694a8f79ac8504f472b6e3f8c1b5e03.tar.bz2
gentoo-2-238e5cfab694a8f79ac8504f472b6e3f8c1b5e03.zip
Version bump. Fixes redefinition errors in headers when building packages
like xulrunner with GCC 4.3. (Portage version: 2.1.4_rc14)
Diffstat (limited to 'dev-libs/popt')
-rw-r--r--dev-libs/popt/ChangeLog10
-rw-r--r--dev-libs/popt/files/digest-popt-1.133
-rw-r--r--dev-libs/popt/popt-1.13.ebuild36
3 files changed, 47 insertions, 2 deletions
diff --git a/dev-libs/popt/ChangeLog b/dev-libs/popt/ChangeLog
index e757ef7b7777..7d0631b89035 100644
--- a/dev-libs/popt/ChangeLog
+++ b/dev-libs/popt/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for dev-libs/popt
-# Copyright 1999-2007 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-libs/popt/ChangeLog,v 1.60 2007/12/09 04:15:41 vapier Exp $
+# Copyright 1999-2008 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/dev-libs/popt/ChangeLog,v 1.61 2008/01/07 06:00:49 dirtyepic Exp $
+
+*popt-1.13 (07 Jan 2008)
+
+ 07 Jan 2008; Ryan Hill <dirtyepic@gentoo.org> +popt-1.13.ebuild:
+ Version bump. Fixes redefinition errors in headers when building packages
+ like xulrunner with GCC 4.3.
*popt-1.12 (09 Dec 2007)
diff --git a/dev-libs/popt/files/digest-popt-1.13 b/dev-libs/popt/files/digest-popt-1.13
new file mode 100644
index 000000000000..29ed73138138
--- /dev/null
+++ b/dev-libs/popt/files/digest-popt-1.13
@@ -0,0 +1,3 @@
+MD5 b5c47ce0185c83f947953c77000533bf popt-1.13.tar.gz 682438
+RMD160 bcf9d493be05c909609d98f504b77268aadadff1 popt-1.13.tar.gz 682438
+SHA256 722b939b14e8b510bbb24e3109a075c7d86b33bec05cb583e76769df9ef2661f popt-1.13.tar.gz 682438
diff --git a/dev-libs/popt/popt-1.13.ebuild b/dev-libs/popt/popt-1.13.ebuild
new file mode 100644
index 000000000000..ffc07a0be7ad
--- /dev/null
+++ b/dev-libs/popt/popt-1.13.ebuild
@@ -0,0 +1,36 @@
+# Copyright 1999-2008 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-libs/popt/popt-1.13.ebuild,v 1.1 2008/01/07 06:00:49 dirtyepic Exp $
+
+inherit eutils
+
+DESCRIPTION="Parse Options - Command line parser"
+HOMEPAGE="http://rpm5.org/"
+SRC_URI="http://rpm5.org/files/popt/${P}.tar.gz"
+
+LICENSE="as-is"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~sparc-fbsd ~x86 ~x86-fbsd"
+IUSE="nls"
+
+RDEPEND="nls? ( virtual/libintl )"
+DEPEND="nls? ( sys-devel/gettext )"
+
+src_unpack() {
+ unpack ${A}
+ cd "${S}"
+ epatch "${FILESDIR}"/${PN}-1.12-scrub-lame-gettext.patch
+}
+
+src_compile() {
+ econf \
+ --without-included-gettext \
+ $(use_enable nls) \
+ || die
+ emake || die "emake failed"
+}
+
+src_install() {
+ emake install DESTDIR="${D}" || die
+ dodoc CHANGES README
+}