summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorBenedikt Boehm <hollow@gentoo.org>2006-07-06 00:13:23 +0000
committerBenedikt Boehm <hollow@gentoo.org>2006-07-06 00:13:23 +0000
commit0dd990cf1f90e42b92ec51643029d859c5cc82f7 (patch)
tree80328314cd456469ca290eb1406abf1dfcf1b09d /dev-libs/xmlrpc-c
parentStable on ppc. (diff)
downloadgentoo-2-0dd990cf1f90e42b92ec51643029d859c5cc82f7.tar.gz
gentoo-2-0dd990cf1f90e42b92ec51643029d859c5cc82f7.tar.bz2
gentoo-2-0dd990cf1f90e42b92ec51643029d859c5cc82f7.zip
install missing client_global.h; fix PIC handling on amd64
(Portage version: 2.1.1_pre2-r2)
Diffstat (limited to 'dev-libs/xmlrpc-c')
-rw-r--r--dev-libs/xmlrpc-c/ChangeLog9
-rw-r--r--dev-libs/xmlrpc-c/files/digest-xmlrpc-c-1.05-r23
-rw-r--r--dev-libs/xmlrpc-c/files/xmlrpc-c-1.05-client-global.patch12
-rw-r--r--dev-libs/xmlrpc-c/files/xmlrpc-c-1.05-pic.patch13
-rw-r--r--dev-libs/xmlrpc-c/xmlrpc-c-1.05-r2.ebuild50
5 files changed, 86 insertions, 1 deletions
diff --git a/dev-libs/xmlrpc-c/ChangeLog b/dev-libs/xmlrpc-c/ChangeLog
index 7e92fbc2c2d2..ba13a8eb6f6e 100644
--- a/dev-libs/xmlrpc-c/ChangeLog
+++ b/dev-libs/xmlrpc-c/ChangeLog
@@ -1,6 +1,13 @@
# ChangeLog for dev-libs/xmlrpc-c
# Copyright 2002-2006 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-libs/xmlrpc-c/ChangeLog,v 1.14 2006/07/01 09:33:46 hollow Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-libs/xmlrpc-c/ChangeLog,v 1.15 2006/07/06 00:13:22 hollow Exp $
+
+*xmlrpc-c-1.05-r2 (06 Jul 2006)
+
+ 06 Jul 2006; Benedikt Böhm <hollow@gentoo.org>
+ +files/xmlrpc-c-1.05-client-global.patch, +files/xmlrpc-c-1.05-pic.patch,
+ +xmlrpc-c-1.05-r2.ebuild:
+ install missing client_global.h; fix PIC handling on amd64
*xmlrpc-c-1.05-r1 (01 Jul 2006)
diff --git a/dev-libs/xmlrpc-c/files/digest-xmlrpc-c-1.05-r2 b/dev-libs/xmlrpc-c/files/digest-xmlrpc-c-1.05-r2
new file mode 100644
index 000000000000..dc70677a26a3
--- /dev/null
+++ b/dev-libs/xmlrpc-c/files/digest-xmlrpc-c-1.05-r2
@@ -0,0 +1,3 @@
+MD5 60d59b39f13d21c3db9285274ea23bab xmlrpc-c-1.05.tgz 669620
+RMD160 0440f06fe1d7ba3cc41cfc7f0341bffd5452de77 xmlrpc-c-1.05.tgz 669620
+SHA256 09a66073c6680916134ea17b961b9b52cc9cdecee95b90fcaf9e18f06a7a449a xmlrpc-c-1.05.tgz 669620
diff --git a/dev-libs/xmlrpc-c/files/xmlrpc-c-1.05-client-global.patch b/dev-libs/xmlrpc-c/files/xmlrpc-c-1.05-client-global.patch
new file mode 100644
index 000000000000..83e7da174e88
--- /dev/null
+++ b/dev-libs/xmlrpc-c/files/xmlrpc-c-1.05-client-global.patch
@@ -0,0 +1,12 @@
+Index: xmlrpc-c-1.05/include/Makefile
+===================================================================
+--- xmlrpc-c-1.05.orig/include/Makefile
++++ xmlrpc-c-1.05/include/Makefile
+@@ -45,6 +45,7 @@ HEADERINST_PREFIX = /xmlrpc-c
+ ifeq ($(MUST_BUILD_CLIENT),yes)
+ HEADERS_TO_INSTALL += \
+ xmlrpc-c/client.h \
++ xmlrpc-c/client_global.h \
+ xmlrpc-c/transport.h \
+
+ ifeq ($(ENABLE_CPLUSPLUS),yes)
diff --git a/dev-libs/xmlrpc-c/files/xmlrpc-c-1.05-pic.patch b/dev-libs/xmlrpc-c/files/xmlrpc-c-1.05-pic.patch
new file mode 100644
index 000000000000..4f8496e524df
--- /dev/null
+++ b/dev-libs/xmlrpc-c/files/xmlrpc-c-1.05-pic.patch
@@ -0,0 +1,13 @@
+Index: xmlrpc-c-1.05/src/cpp/Makefile
+===================================================================
+--- xmlrpc-c-1.05.orig/src/cpp/Makefile
++++ xmlrpc-c-1.05/src/cpp/Makefile
+@@ -135,7 +135,7 @@ libxmlrpc_client++.a: $(LIBXMLRPC_CLIENT
+ # RULES TO COMPILE OBJECT MODULES FOR LIBRARIES
+ #-----------------------------------------------------------------------------
+
+-CXXFLAGS = $(CXXFLAGS_COMMON) $(CFLAGS_PERSONAL) $(CADD)
++CXXFLAGS = $(CXXFLAGS_COMMON) $(CFLAGS_PERSONAL) $(CADD) -fPIC
+
+ XmlRpcCpp.o:%.o:%.cpp
+ $(CXX) -c $(BASIC_INCLUDES) $(CXXFLAGS) $<
diff --git a/dev-libs/xmlrpc-c/xmlrpc-c-1.05-r2.ebuild b/dev-libs/xmlrpc-c/xmlrpc-c-1.05-r2.ebuild
new file mode 100644
index 000000000000..3151e727c770
--- /dev/null
+++ b/dev-libs/xmlrpc-c/xmlrpc-c-1.05-r2.ebuild
@@ -0,0 +1,50 @@
+# Copyright 1999-2006 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-libs/xmlrpc-c/xmlrpc-c-1.05-r2.ebuild,v 1.1 2006/07/06 00:13:23 hollow Exp $
+
+inherit eutils
+
+DESCRIPTION="A lightweigt RPC library based on XML and HTTP"
+SRC_URI="mirror://sourceforge/xmlrpc-c/${P}.tgz"
+HOMEPAGE="http://xmlrpc-c.sourceforge.net/"
+
+KEYWORDS="~alpha ~amd64 ~ppc ~x86"
+IUSE="curl libwww"
+LICENSE="GPL-2"
+SLOT="0"
+
+DEPEND="virtual/libc
+ dev-libs/libxml2
+ libwww? ( net-libs/libwww )
+ curl? ( net-misc/curl )"
+
+pkg_setup() {
+ # paralell make doesn't work
+ MAKEOPTS="-j1"
+
+ if ! use curl && ! use libwww; then
+ ewarn "Neither CURL nor libwww support was selected"
+ ewarn "No client library will be be built"
+ fi
+}
+
+src_unpack() {
+ unpack ${A}
+ cd "${S}"
+
+ epatch "${FILESDIR}"/${P}-iostream.patch
+ epatch "${FILESDIR}"/${P}-no-extra-qual.patch
+ epatch "${FILESDIR}"/${P}-client-global.patch
+ epatch "${FILESDIR}"/${P}-pic.patch
+}
+
+src_compile() {
+ econf --disable-wininet-client \
+ $(use_enable curl curl-client) \
+ $(use_enable libwww libwww-client) || die "econf failed"
+ emake || die "emake failed"
+}
+
+src_install() {
+ make DESTDIR=${D} install || die
+}