summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMatthew Kennedy <mkennedy@gentoo.org>2003-09-24 00:27:46 +0000
committerMatthew Kennedy <mkennedy@gentoo.org>2003-09-24 00:27:46 +0000
commit053c89baf34f0b678451cdf88763a65fecd3d63a (patch)
treeaad8a3d32ebdfb92ff64bd730d3d9a6054f831d0 /dev-lisp
parentinitial import (diff)
downloadgentoo-2-053c89baf34f0b678451cdf88763a65fecd3d63a.tar.gz
gentoo-2-053c89baf34f0b678451cdf88763a65fecd3d63a.tar.bz2
gentoo-2-053c89baf34f0b678451cdf88763a65fecd3d63a.zip
initial import
Diffstat (limited to 'dev-lisp')
-rw-r--r--dev-lisp/cmucl/ChangeLog8
-rw-r--r--dev-lisp/cmucl/Manifest6
-rw-r--r--dev-lisp/cmucl/cmucl-18e.ebuild98
-rw-r--r--dev-lisp/cmucl/files/18e/README.Gentoo31
-rw-r--r--dev-lisp/cmucl/files/18e/herald-save.lisp-gentoo.patch18
-rw-r--r--dev-lisp/cmucl/files/18e/site-init.lisp.in102
-rw-r--r--dev-lisp/cmucl/files/digest-cmucl-18e3
7 files changed, 265 insertions, 1 deletions
diff --git a/dev-lisp/cmucl/ChangeLog b/dev-lisp/cmucl/ChangeLog
new file mode 100644
index 000000000000..7152d42460ac
--- /dev/null
+++ b/dev-lisp/cmucl/ChangeLog
@@ -0,0 +1,8 @@
+# ChangeLog for dev-lisp/cmucl
+# Copyright 2000-2003 Gentoo Technologies, Inc.; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/dev-lisp/cmucl/ChangeLog,v 1.1 2003/09/24 00:27:43 mkennedy Exp $
+
+*cmucl-18e (23 Sep 2003)
+
+ 23 Sep 2003; Matthew Kennedy <mkennedy@gentoo.org> :
+ Initial import.
diff --git a/dev-lisp/cmucl/Manifest b/dev-lisp/cmucl/Manifest
index ec258a4a1325..2e1e98a1f394 100644
--- a/dev-lisp/cmucl/Manifest
+++ b/dev-lisp/cmucl/Manifest
@@ -1,2 +1,6 @@
-MD5 a0969eccb32bf76d8dcf4b600fa969e8 cmucl-18e.ebuild 2295
+MD5 99ca05f54412d3c9b9cdf9b6b65048e5 cmucl-18e.ebuild 2663
+MD5 116e68a1775cacfa701db2d7e91b83f9 ChangeLog 311
MD5 3e3791768309ef2b15c4e342b300980b files/digest-cmucl-18e 205
+MD5 fc89ac560cffc93b097f34b594373113 files/18e/herald-save.lisp-gentoo.patch 756
+MD5 997a2bfdcd98bc978f6c3b79ba8f2264 files/18e/README.Gentoo 848
+MD5 7c6e25bb371b16cea4f8cad6f64a0317 files/18e/site-init.lisp.in 2857
diff --git a/dev-lisp/cmucl/cmucl-18e.ebuild b/dev-lisp/cmucl/cmucl-18e.ebuild
new file mode 100644
index 000000000000..7fff091b43b8
--- /dev/null
+++ b/dev-lisp/cmucl/cmucl-18e.ebuild
@@ -0,0 +1,98 @@
+# Copyright 1999-2003 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-lisp/cmucl/cmucl-18e.ebuild,v 1.1 2003/09/24 00:27:43 mkennedy Exp $
+
+# This package is a port of the Debian package of the same name.
+DEB_PV=7
+
+DESCRIPTION="CMUCL Lisp. This conforms to the ANSI Common Lisp Standard"
+HOMEPAGE="http://www.cons.org/cmucl/
+ http://packages.debian.org/unstable/devel/cmucl.html"
+LICENSE="public-domain"
+DEPEND="dev-lisp/common-lisp-controller
+ x11-libs/lesstif
+ doc? ( app-text/tetex )"
+# X? ( x11-libs/lesstif )"
+IUSE="doc X"
+SLOT="0"
+KEYWORDS="~x86"
+SRC_URI="http://ftp.debian.org/debian/pool/main/c/cmucl/cmucl_${PV}.orig.tar.gz
+ http://ftp.debian.org/debian/pool/main/c/cmucl/cmucl_${PV}-${DEB_PV}.diff.gz
+ http://cmucl.cons.org/ftp-area/cmucl/release/18e/cmucl-${PV}-x86-linux.tar.bz2"
+
+PROVIDE="virtual/commonlisp"
+
+S=${WORKDIR}/${P}.orig
+
+src_unpack() {
+ unpack ${A}
+ epatch cmucl_${PV}-${DEB_PV}.diff
+ epatch ${FILESDIR}/${PV}/herald-save.lisp-gentoo.patch
+}
+
+src_compile() {
+ PATH=${WORKDIR}/bin:$PATH CMUCLCORE=${WORKDIR}/lib/cmucl/lib/lisp.core make || die
+ if use doc; then
+ make -C src/docs
+ fi
+}
+
+src_install() {
+ insinto /usr/lib/cmucl/include
+ doins src/lisp/*.h target/lisp/*.h target/lisp/*.map target/lisp/*.nm
+ insinto /usr/lib/cmucl
+ cp target/lisp/lisp.core lisp-dist.core
+ doins lisp-dist.core
+
+ dodoc target/lisp/lisp.{nm,map}
+ doman src/general-info/{cmucl,lisp}.1
+
+ dobin target/lisp/lisp
+ dobin own-work/Demos/lisp-start
+
+ insinto /usr/lib/cmucl
+ doins own-work/install-clc.lisp
+ exeinto /usr/lib/common-lisp/bin
+ cp own-work/cmucl-script.sh cmucl.sh
+ doexe cmucl.sh
+
+ insinto /etc/common-lisp/cmucl
+ sed "s,@PF@,${PF},g" <${FILESDIR}/${PV}/site-init.lisp.in >site-init.lisp
+ doins site-init.lisp
+ dosym /etc/common-lisp/cmucl/site-init.lisp /usr/lib/cmucl/site-init.lisp
+
+ dodir /etc/env.d
+ cat >${D}/etc/env.d/50cmucl <<EOF
+# CMUCLLIB=/usr/lib/cmucl
+EOF
+ [ -f /etc/lisp-config.lisp ] || touch ${D}/etc/lisp-config.lisp
+
+ insinto /usr/share/doc/${P}/html/Basic-tutorial
+ doins own-work/tutorials/Basic-tutorial/*
+ insinto /usr/share/doc/${P}/html/Clos
+ doins own-work/tutorials/Clos/*
+ docinto notes
+ dodoc own-work/tutorials/notes/*
+
+ insinto /usr/lib/cmucl
+ doins own-work/hemlock11.*
+
+ if use doc; then
+ dodoc src/docs/*/*.{ps,pdf}
+ fi
+
+ if use X; then
+ exeinto /usr/lib/cmucl
+ doexe target/motif/server/motifd
+ insinto /usr/lib/cmucl/subsystems/
+ doins target/interface/clm-library.x86f
+ fi
+}
+
+pkg_postinst() {
+ /usr/sbin/register-common-lisp-implementation cmucl
+}
+
+pkg_prerm() {
+ /usr/sbin/unregister-common-lisp-implementation cmucl
+}
diff --git a/dev-lisp/cmucl/files/18e/README.Gentoo b/dev-lisp/cmucl/files/18e/README.Gentoo
new file mode 100644
index 000000000000..885807587fb5
--- /dev/null
+++ b/dev-lisp/cmucl/files/18e/README.Gentoo
@@ -0,0 +1,31 @@
+
+* README.Gentoo -- Gentoo Specific Notes for dev-lisp/cmucl
+
+** About dev-lisp/cmucl
+
+The dev-lisp/cmucl ebuild in portage aim to provide a port of
+Debian's package of CMUCL. Thus the Gentoo CMUCL port should be
+binary compatible with the Debian port.
+
+** Linux Miscellaneous Binary Support
+
+You can have your compiled Lisp .x86f files automatically executed
+like any other binary by executing the following command:
+
+ echo ':lisp:E::x86f::/usr/bin/lisp-start:' \
+ >/proc/sys/fs/binfmt_misc/register
+
+Note: you need kernel support for this. A good place to put the
+above command is in your /etc/conf.d/localstart.
+
+** Credit
+
+This Gentoo package, like many other Gentoo packages in the dev-lisp
+category, benifit from the Debian Project's work.
+
+ -- Matthew Kennedy <mkennedy@gentoo.org>
+
+
+Local Variables: ***
+mode: outline ***
+End: ***
diff --git a/dev-lisp/cmucl/files/18e/herald-save.lisp-gentoo.patch b/dev-lisp/cmucl/files/18e/herald-save.lisp-gentoo.patch
new file mode 100644
index 000000000000..de70a1259102
--- /dev/null
+++ b/dev-lisp/cmucl/files/18e/herald-save.lisp-gentoo.patch
@@ -0,0 +1,18 @@
+--- cmucl-18e.orig.orig/src/code/save.lisp 2003-09-23 15:57:49.993364656 -0500
++++ cmucl-18e.orig/src/code/save.lisp 2003-09-23 15:56:31.261333744 -0500
+@@ -289,12 +289,9 @@
+ ))
+
+ (setf (getf *herald-items* :bugs)
+- '("For support see http://www.cons.org/cmucl/support.html Send bug reports to the debian BTS."
+- terpri
+- "or to "
+- "pvaneynd@debian.org" terpri
+- "type (help) for help, (quit) to exit, and (demo) to see the demos" terpri
+- terpri
++ '("For support see http://www.cons.org/cmucl/support.html" terpri
++ "Send bug reports to the Gentoo Bugzilla http://bugs.gentoo.org" terpri
++ "Type (help) for help, (quit) to exit, and (demo) to see the demos" terpri
+ "Loaded subsystems:"))
+
+ ;;; PRINT-HERALD -- Public
diff --git a/dev-lisp/cmucl/files/18e/site-init.lisp.in b/dev-lisp/cmucl/files/18e/site-init.lisp.in
new file mode 100644
index 000000000000..3de2acb23253
--- /dev/null
+++ b/dev-lisp/cmucl/files/18e/site-init.lisp.in
@@ -0,0 +1,102 @@
+;;; -*- Mode: Lisp; Package: System -*-
+;;;
+;;; **********************************************************************
+;;; This code was written as part of the CMU Common Lisp project at
+;;; Carnegie Mellon University, and has been placed in the public domain.
+;;;
+
+;;; Heavy modifications by Peter Van Eynde
+
+;;; More modifications for Gentoo by Matthew Kennedy
+
+(in-package "SYSTEM")
+
+(if (probe-file "/etc/lisp-config.lisp")
+ (load "/etc/lisp-config.lisp")
+ (format t "~%;;; Warning: There is no /etc/lisp-config.lisp file (which should have been created during emerge"))
+
+;;; If you have sources installed on your system, un-comment the following form
+;;; and change it to point to the source location. This will allow the Hemlock
+;;; "Edit Definition" command and the debugger to find sources for functions in
+;;; the core.
+(setf (ext:search-list "target:")
+ '(
+ "/usr/share/common-lisp/source/cmucl/" ; object dir
+ ))
+
+(setf (ext:search-list "library:") '("/usr/lib/cmucl/"))
+;;; for safety...
+
+;;; optional extentions to the lisp image: delete if you
+;;; don't like them :-).
+(in-package :common-lisp-user)
+
+;;; newbie functions, delete if you don't like them
+
+#-hemlock
+(defun ed (&rest rest)
+ (multiple-value-bind (return errorp)
+ (ignore-errors (require :cmucl-hemlock))
+ (if errorp
+ (error "Sorry, cannot find hemlock, please install and use ilisp. Reason: ~S" errorp)
+ (apply #'ed rest))))
+
+(defun help ()
+ (format t "~
+Welcome to CMUCL for Linux.
+
+If you aren't running this with ilisp in emacs,
+or aren't intending to use hemlock then you
+deserve to lose. :-)
+
+Read the documentation in /usr/share/doc/@PF@.
+
+(quit) is to quit.
+(ed) starts hemlock (if installed)
+(demo) shows a list of demos
+(describe 'progn) gives information about progn for
+ example.
+(inspect '*a*) interactively inspects *a* for example.
+"))
+
+(defun demo ()
+ (format t "Some demos are in the source package, some in the
+normal package.
+
+General demos:
+CLX demos:
+ if you have installed cmucl-source you can do:
+ (require :cmucl-clx)
+ (load \"cl-library:cmucl-clx;demo;hello\")
+ (xlib::hello-world \"\")
+ (load \"cl-library:;cmucl-clx;demo;menu\")
+ (xlib::just-say-lisp \"\")
+ (xlib::pop-up \"\"
+ '(\"Linux\" \"FreeBSD\" \"OpenBSD\"))
+ exit by pressing control+C followed by a keypress.
+
+Clue demos:
+ if you have installed the clue package you can do:
+ (require :clue)
+ (load \"cl-library:;clue;examples;menu\")
+ (clue-examples::beatlemenuia \"\")
+ (clue-examples::pick-one \"\"
+ \"One\"
+ \"Two\"
+ \"Three\")
+ (clue-examples::just-say-lisp \"\")
+
+ or you can use the Clio demos:
+ (require :clio)
+ (require :clio-examples)
+ (clio-examples::sketch :host \"\")
+
+Pictures demos:
+ (require :pictures)
+ (load \"cl-library:;pictures;examples;road-demo\")
+ (pictures::road-demo)
+ press control-a to animate
+
+"))
+
+
diff --git a/dev-lisp/cmucl/files/digest-cmucl-18e b/dev-lisp/cmucl/files/digest-cmucl-18e
new file mode 100644
index 000000000000..d0cf150eb9d4
--- /dev/null
+++ b/dev-lisp/cmucl/files/digest-cmucl-18e
@@ -0,0 +1,3 @@
+MD5 d834f9fa8539309bcc7ebc41c8b124e6 cmucl_18e.orig.tar.gz 4420172
+MD5 49d8ec3c68cb3f0f9c736644ba5d16cf cmucl_18e-7.diff.gz 1911127
+MD5 695f4a6abc5af6276f776a9739c2c7e7 cmucl-18e-x86-linux.tar.bz2 6404635