summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMarijn Schouten <hkbst@gentoo.org>2007-10-22 13:32:18 +0000
committerMarijn Schouten <hkbst@gentoo.org>2007-10-22 13:32:18 +0000
commitac7f8545cb9fa6e03a58dd11bf3fc691404e0449 (patch)
tree2985f7927203e456de2132c9b1aa5fbac30d68b2 /dev-lisp
parentclisp:svm use flag (diff)
downloadgentoo-2-ac7f8545cb9fa6e03a58dd11bf3fc691404e0449.tar.gz
gentoo-2-ac7f8545cb9fa6e03a58dd11bf3fc691404e0449.tar.bz2
gentoo-2-ac7f8545cb9fa6e03a58dd11bf3fc691404e0449.zip
fixes for clisp from bug 196543, thanks to Stelian Ionescu <stelian.ionescu-zeus@poste.it>
(Portage version: 2.1.3.15)
Diffstat (limited to 'dev-lisp')
-rw-r--r--dev-lisp/clisp/ChangeLog8
-rw-r--r--dev-lisp/clisp/clisp-2.42-r1.ebuild102
-rw-r--r--dev-lisp/clisp/files/digest-clisp-2.42-r13
3 files changed, 112 insertions, 1 deletions
diff --git a/dev-lisp/clisp/ChangeLog b/dev-lisp/clisp/ChangeLog
index 6fefd2feb605..d376603de59f 100644
--- a/dev-lisp/clisp/ChangeLog
+++ b/dev-lisp/clisp/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for dev-lisp/clisp
# Copyright 2002-2007 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-lisp/clisp/ChangeLog,v 1.65 2007/10/17 14:09:32 hkbst Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-lisp/clisp/ChangeLog,v 1.66 2007/10/22 13:32:17 hkbst Exp $
+
+*clisp-2.42-r1 (22 Oct 2007)
+
+ 22 Oct 2007; Marijn Schouten <hkBst@gentoo.org> +clisp-2.42-r1.ebuild:
+ fixes for clisp from bug 196543, thanks to Stelian Ionescu
+ <stelian.ionescu-zeus@poste.it>
17 Oct 2007; Marijn Schouten <hkBst@gentoo.org> clisp-2.42.ebuild:
remove mangling of HyperSpec URL
diff --git a/dev-lisp/clisp/clisp-2.42-r1.ebuild b/dev-lisp/clisp/clisp-2.42-r1.ebuild
new file mode 100644
index 000000000000..674c4177e25d
--- /dev/null
+++ b/dev-lisp/clisp/clisp-2.42-r1.ebuild
@@ -0,0 +1,102 @@
+# Copyright 1999-2007 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-lisp/clisp/clisp-2.42-r1.ebuild,v 1.1 2007/10/22 13:32:17 hkbst Exp $
+
+inherit flag-o-matic eutils toolchain-funcs multilib
+
+DESCRIPTION="A portable, bytecode-compiled implementation of Common Lisp"
+HOMEPAGE="http://clisp.sourceforge.net/"
+SRC_URI="mirror://sourceforge/clisp/${P}.tar.bz2"
+
+LICENSE="GPL-2"
+SLOT="2"
+KEYWORDS="~amd64 -sparc ~x86"
+IUSE="X new-clx fastcgi gdbm gtk pcre postgres readline svm zlib"
+
+RDEPEND="dev-lisp/gentoo-init
+ >=dev-libs/libsigsegv-2.4
+ virtual/tetex
+ fastcgi? ( dev-libs/fcgi )
+ gdbm? ( sys-libs/gdbm )
+ gtk? ( >=x11-libs/gtk+-2.10 >=gnome-base/libglade-2.6 )
+ postgres? ( >=dev-db/postgresql-8.0 )
+ readline? ( sys-libs/readline )
+ pcre? ( dev-libs/libpcre )
+ svm? ( sci-libs/libsvm )
+ zlib? ( sys-libs/zlib )
+ X? ( new-clx? ( x11-libs/libXpm ) )"
+# * GNU gettext
+# + Not needed on systems with glibc 2.2 or newer, but recommended on all
+# other systems: needed if you want clisp with native language support.
+# sys-devel/gettext
+
+DEPEND="${RDEPEND} X? ( new-clx? ( x11-misc/imake x11-proto/xextproto ) )"
+
+PROVIDE="virtual/commonlisp"
+
+src_unpack() {
+ unpack ${A}
+ # Fix module install path: 2.41.1 -> 2.42
+ sed -i 's:2\.41\.1:2\.42:' "${S}"/src/{configure,version.h}
+}
+
+enable_modules() {
+ [[ $# = 0 ]] && die "${FUNCNAME[0]} must receive at least one argument"
+ for m in "$@" ; do
+ einfo "enabling module $m"
+ myconf="${myconf} --with-module=${m}"
+ done
+}
+
+BUILDDIR="builddir"
+
+src_compile() {
+ CC="$(tc-getCC)"
+
+ # built-in features
+ local myconf="--with-dynamic-ffi"
+ use readline || myconf="${myconf} --with-noreadline"
+
+ # default modules
+ enable_modules wildcard rawsock i18n
+ # optional modules
+ use elibc_glibc && enable_modules bindings/glibc
+ if use X; then
+ if use new-clx; then
+ enable_modules clx/new-clx
+ else
+ enable_modules clx/mit-clx
+ fi
+ fi
+ if use postgres; then
+ enable_modules postgresql
+ CC="${CC} -I $(pg_config --includedir)"
+ fi
+ use fastcgi && enable_modules fastcgi
+ use gdbm && enable_modules gdbm
+ use gtk && enable_modules gtk2
+ use pcre && enable_modules pcre
+ use svm && enable_modules libsvm
+ use zlib && enable_modules zlib
+
+ # configure chokes on --infodir option
+ ./configure --prefix=/usr --libdir=/usr/$(get_libdir) \
+ ${myconf} ${BUILDDIR} || die "./configure failed"
+ cd ${BUILDDIR}
+ ./makemake ${myconf} > Makefile
+# emake config.lisp
+# sed -i 's,"vi","nano",g' config.lisp
+ # parallel build fails
+ emake -j1 || die "emake failed"
+}
+
+src_install() {
+ pushd ${BUILDDIR}
+ make DESTDIR="${D}" prefix=/usr install-bin || die
+ doman clisp.1
+ dodoc SUMMARY README* NEWS MAGIC.add ANNOUNCE clisp.dvi clisp.html
+ chmod a+x "${D}"/usr/$(get_libdir)/clisp/clisp-link
+ popd
+ dohtml doc/impnotes.{css,html} ${BUILDDIR}/clisp.html doc/clisp.png
+ dodoc ${BUILDDIR}/clisp.ps doc/{editors,CLOS-guide,LISP-tutorial}.txt
+}
diff --git a/dev-lisp/clisp/files/digest-clisp-2.42-r1 b/dev-lisp/clisp/files/digest-clisp-2.42-r1
new file mode 100644
index 000000000000..0634b9bb6066
--- /dev/null
+++ b/dev-lisp/clisp/files/digest-clisp-2.42-r1
@@ -0,0 +1,3 @@
+MD5 3fc28342e446a62c1eb4f65277929888 clisp-2.42.tar.bz2 8284453
+RMD160 b6d6b3c255c3f91f76e5fc46b1f05cca2ebbb388 clisp-2.42.tar.bz2 8284453
+SHA256 6e0f44fd76505557620b43d8b6cfdb3fcd6bfbe1facd7c1b951fc0e47fff30d8 clisp-2.42.tar.bz2 8284453