summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMatti Bickel <mabi@gentoo.org>2013-05-19 21:54:24 +0000
committerMatti Bickel <mabi@gentoo.org>2013-05-19 21:54:24 +0000
commit5de533417a1036eaf83ea95beaf636cc31825ee9 (patch)
tree0dba30d6b19b7d9450e63b490ff6d9c43cd28cf6 /dev-lua
parentkeyword ~amd64-fbsd, bug #468270 (diff)
downloadgentoo-2-5de533417a1036eaf83ea95beaf636cc31825ee9.tar.gz
gentoo-2-5de533417a1036eaf83ea95beaf636cc31825ee9.tar.bz2
gentoo-2-5de533417a1036eaf83ea95beaf636cc31825ee9.zip
remove --force-config (bug #436754)
(Portage version: 2.2.0_alpha168/cvs/Linux x86_64, signed Manifest commit with key 0x4849EC6C)
Diffstat (limited to 'dev-lua')
-rw-r--r--dev-lua/luarocks/ChangeLog10
-rw-r--r--dev-lua/luarocks/luarocks-2.0.8-r1.ebuild53
2 files changed, 60 insertions, 3 deletions
diff --git a/dev-lua/luarocks/ChangeLog b/dev-lua/luarocks/ChangeLog
index 7ac5095d5f69..0611d18b41f0 100644
--- a/dev-lua/luarocks/ChangeLog
+++ b/dev-lua/luarocks/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for dev-lua/luarocks
-# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-lua/luarocks/ChangeLog,v 1.4 2012/06/07 19:13:37 zmedico Exp $
+# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/dev-lua/luarocks/ChangeLog,v 1.5 2013/05/19 21:54:24 mabi Exp $
+
+*luarocks-2.0.8-r1 (19 May 2013)
+
+ 19 May 2013; Matti Bickel <mabi@gentoo.org> +luarocks-2.0.8-r1.ebuild:
+ remove --force-config (bug #436754)
07 Jun 2012; Zac Medico <zmedico@gentoo.org> luarocks-2.0.7.1.ebuild,
luarocks-2.0.8.ebuild:
@@ -27,4 +32,3 @@
+luarocks-1.0.ebuild:
initial version. Thanks to A.S. Bradbury (asb@asbradbury.org) for the
original ebuild
-
diff --git a/dev-lua/luarocks/luarocks-2.0.8-r1.ebuild b/dev-lua/luarocks/luarocks-2.0.8-r1.ebuild
new file mode 100644
index 000000000000..c24a191695cd
--- /dev/null
+++ b/dev-lua/luarocks/luarocks-2.0.8-r1.ebuild
@@ -0,0 +1,53 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-lua/luarocks/luarocks-2.0.8-r1.ebuild,v 1.1 2013/05/19 21:54:24 mabi Exp $
+
+EAPI=4
+
+inherit eutils multilib
+
+DESCRIPTION="A deployment and management system for Lua modules"
+HOMEPAGE="http://www.luarocks.org"
+SRC_URI="http://luarocks.org/releases/${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~x86 ~amd64 ~ppc"
+IUSE="curl openssl"
+
+DEPEND="dev-lang/lua
+ curl? ( net-misc/curl )
+ openssl? ( dev-libs/openssl )"
+RDEPEND="${DEPEND}
+ app-arch/unzip"
+
+src_configure() {
+ USE_MD5="md5sum"
+ USE_FETCH="wget"
+ use openssl && USE_MD5="openssl"
+ use curl && USE_FETCH="curl"
+
+ # econf doesn't work b/c it passes variables the custom configure can't
+ # handle
+ ./configure \
+ --prefix=/usr \
+ --with-lua-lib=/usr/$(get_libdir) \
+ --rocks-tree=/usr/$(get_libdir)/lua/luarocks \
+ --with-downloader=$USE_FETCH \
+ --with-md5-checker=$USE_MD5 \
+ || die "configure failed"
+}
+
+src_compile() {
+ # -j1 b/c make tries to delete files it has yet to create (bug #402005)
+ emake DESTDIR="${D}" -j1 || die "make failed"
+}
+
+src_install() {
+ # -j1 b/c otherwise it fails to find src/bin/luarocks
+ emake DESTDIR="${D}" -j1 install || die "einstall"
+}
+
+pkg_preinst() {
+ find "${D}" -type f | xargs sed -i -e "s:${D}::g" || die "sed failed"
+}