summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlexis Ballier <aballier@gentoo.org>2014-11-28 15:20:48 +0000
committerAlexis Ballier <aballier@gentoo.org>2014-11-28 15:20:48 +0000
commitc757db2fb04b98a432d2844cbabd4fc000566ced (patch)
tree0b339c9a1dd5bdceb03897dbe9b07d7cabcd64c6 /dev-ml/cmdliner
parentversion bump (diff)
downloadgentoo-2-c757db2fb04b98a432d2844cbabd4fc000566ced.tar.gz
gentoo-2-c757db2fb04b98a432d2844cbabd4fc000566ced.tar.bz2
gentoo-2-c757db2fb04b98a432d2844cbabd4fc000566ced.zip
version bump
Signed-off-by: aballier@gentoo.org (Portage version: 2.2.14/cvs/Linux x86_64, signed Manifest commit with key 160F534A)
Diffstat (limited to 'dev-ml/cmdliner')
-rw-r--r--dev-ml/cmdliner/ChangeLog7
-rw-r--r--dev-ml/cmdliner/cmdliner-0.9.6.ebuild37
2 files changed, 43 insertions, 1 deletions
diff --git a/dev-ml/cmdliner/ChangeLog b/dev-ml/cmdliner/ChangeLog
index 13bc9d3d1bf9..dcab829cd852 100644
--- a/dev-ml/cmdliner/ChangeLog
+++ b/dev-ml/cmdliner/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for dev-ml/cmdliner
# Copyright 1999-2014 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-ml/cmdliner/ChangeLog,v 1.1 2014/10/29 08:32:31 aballier Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-ml/cmdliner/ChangeLog,v 1.2 2014/11/28 15:20:48 aballier Exp $
+
+*cmdliner-0.9.6 (28 Nov 2014)
+
+ 28 Nov 2014; Alexis Ballier <aballier@gentoo.org> +cmdliner-0.9.6.ebuild:
+ version bump
*cmdliner-0.9.5 (29 Oct 2014)
diff --git a/dev-ml/cmdliner/cmdliner-0.9.6.ebuild b/dev-ml/cmdliner/cmdliner-0.9.6.ebuild
new file mode 100644
index 000000000000..c4251a304abf
--- /dev/null
+++ b/dev-ml/cmdliner/cmdliner-0.9.6.ebuild
@@ -0,0 +1,37 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-ml/cmdliner/cmdliner-0.9.6.ebuild,v 1.1 2014/11/28 15:20:48 aballier Exp $
+
+EAPI=5
+
+inherit findlib
+
+DESCRIPTION="Declarative definition of command line interfaces for OCaml"
+HOMEPAGE="http://erratique.ch/software/cmdliner"
+SRC_URI="http://erratique.ch/software/${PN}/releases/${P}.tbz"
+
+LICENSE="BSD"
+SLOT="0/${PV}"
+KEYWORDS="~amd64"
+IUSE="doc +ocamlopt"
+
+DEPEND=">=dev-lang/ocaml-3.12:=[ocamlopt?]"
+RDEPEND="${DEPEND}"
+
+src_compile() {
+ ocaml pkg/build.ml \
+ native=$(usex ocamlopt true false) \
+ native-dynlink=$(usex ocamlopt true false) \
+ || die
+}
+
+src_install() {
+ # Can't use opam-installer here as it is an opam dep...
+ findlib_src_preinst
+ local nativelibs=""
+ use ocamlopt && nativelibs="$(echo _build/src/cmdliner.cm{x,xa,xs} _build/src/cmdliner.a)"
+ ocamlfind install cmdliner _build/pkg/META \
+ _build/src/cmdliner.mli _build/src/cmdliner.cm{a,i} ${nativelibs} || die
+ dodoc README.md TODO.md CHANGES.md
+ use doc && dohtml -r doc/
+}