summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlexis Ballier <aballier@gentoo.org>2014-10-27 08:40:50 +0000
committerAlexis Ballier <aballier@gentoo.org>2014-10-27 08:40:50 +0000
commit5d61c86bdfd23dfbc347effc89bb0d73b58bf3e5 (patch)
treef2ef6f044c003cd3d774877480b4759c4a6d62bc /dev-ml/findlib
parentversion bump (diff)
downloadgentoo-2-5d61c86bdfd23dfbc347effc89bb0d73b58bf3e5.tar.gz
gentoo-2-5d61c86bdfd23dfbc347effc89bb0d73b58bf3e5.tar.bz2
gentoo-2-5d61c86bdfd23dfbc347effc89bb0d73b58bf3e5.zip
version bump
Signed-off-by: aballier@gentoo.org (Portage version: 2.2.14/cvs/Linux x86_64, signed Manifest commit with key 160F534A)
Diffstat (limited to 'dev-ml/findlib')
-rw-r--r--dev-ml/findlib/ChangeLog7
-rw-r--r--dev-ml/findlib/findlib-1.5.5.ebuild70
2 files changed, 76 insertions, 1 deletions
diff --git a/dev-ml/findlib/ChangeLog b/dev-ml/findlib/ChangeLog
index 601edb711b28..18fe047d6aae 100644
--- a/dev-ml/findlib/ChangeLog
+++ b/dev-ml/findlib/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for dev-ml/findlib
# Copyright 1999-2014 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-ml/findlib/ChangeLog,v 1.117 2014/08/10 20:42:55 slyfox Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-ml/findlib/ChangeLog,v 1.118 2014/10/27 08:40:50 aballier Exp $
+
+*findlib-1.5.5 (27 Oct 2014)
+
+ 27 Oct 2014; Alexis Ballier <aballier@gentoo.org> +findlib-1.5.5.ebuild:
+ version bump
10 Aug 2014; Sergei Trofimovich <slyfox@gentoo.org> findlib-1.4.ebuild:
QA: drop trailing '.' from DESCRIPTION
diff --git a/dev-ml/findlib/findlib-1.5.5.ebuild b/dev-ml/findlib/findlib-1.5.5.ebuild
new file mode 100644
index 000000000000..e16d6a218fe8
--- /dev/null
+++ b/dev-ml/findlib/findlib-1.5.5.ebuild
@@ -0,0 +1,70 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-ml/findlib/findlib-1.5.5.ebuild,v 1.1 2014/10/27 08:40:50 aballier Exp $
+
+EAPI=5
+
+inherit multilib
+
+DESCRIPTION="OCaml tool to find/use non-standard packages"
+HOMEPAGE="http://projects.camlcity.org/projects/findlib.html"
+SRC_URI="http://download.camlcity.org/download/${P}.tar.gz"
+IUSE="doc +ocamlopt tk"
+
+LICENSE="MIT"
+
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~ppc ~ppc64 ~sparc ~x86 ~amd64-fbsd ~x86-fbsd ~amd64-linux ~x86-linux ~ppc-macos"
+
+DEPEND=">=dev-lang/ocaml-3.10:=[ocamlopt?,tk?]"
+RDEPEND="${DEPEND}"
+
+ocamlfind_destdir="${EPREFIX}/usr/$(get_libdir)/ocaml"
+stublibs="${ocamlfind_destdir}/stublibs"
+
+src_configure() {
+ local myconf
+ use tk && myconf="-with-toolbox"
+ ./configure -bindir "${EPREFIX}"/usr/bin -mandir "${EPREFIX}"/usr/share/man \
+ -sitelib ${ocamlfind_destdir} \
+ -config ${ocamlfind_destdir}/findlib/findlib.conf \
+ -no-custom \
+ ${myconf} || die "configure failed"
+}
+
+src_compile() {
+ emake all
+ if use ocamlopt; then
+ emake opt # optimized code
+ fi
+}
+
+src_install() {
+ emake prefix="${D}" install
+
+ dodir "${stublibs#${EPREFIX}}"
+
+ cd "${S}/doc"
+ dodoc QUICKSTART README DOCINFO
+ use doc && dohtml -r ref-html guide-html
+}
+
+check_stublibs() {
+ local ocaml_stdlib=`ocamlc -where`
+ local ldconf="${ocaml_stdlib}/ld.conf"
+
+ if [ ! -e ${ldconf} ]
+ then
+ echo "${ocaml_stdlib}" > ${ldconf}
+ echo "${ocaml_stdlib}/stublibs" >> ${ldconf}
+ fi
+
+ if [ -z `grep -e ${stublibs} ${ldconf}` ]
+ then
+ echo ${stublibs} >> ${ldconf}
+ fi
+}
+
+pkg_postinst() {
+ check_stublibs
+}