summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlexis Ballier <aballier@gentoo.org>2014-12-01 10:25:33 +0000
committerAlexis Ballier <aballier@gentoo.org>2014-12-01 10:25:33 +0000
commit0018b3db0fd91a7f2f557f9fec0ec6750dfd3b64 (patch)
tree6fab55222239b265195800ab916b1347fe6f83e7 /dev-ml/js_of_ocaml
parentinitial import, ebuild by me (diff)
downloadgentoo-2-0018b3db0fd91a7f2f557f9fec0ec6750dfd3b64.tar.gz
gentoo-2-0018b3db0fd91a7f2f557f9fec0ec6750dfd3b64.tar.bz2
gentoo-2-0018b3db0fd91a7f2f557f9fec0ec6750dfd3b64.zip
add missing dep
Signed-off-by: aballier@gentoo.org (Portage version: 2.2.14/cvs/Linux x86_64, signed Manifest commit with key 160F534A)
Diffstat (limited to 'dev-ml/js_of_ocaml')
-rw-r--r--dev-ml/js_of_ocaml/ChangeLog7
-rw-r--r--dev-ml/js_of_ocaml/js_of_ocaml-2.5-r1.ebuild44
2 files changed, 50 insertions, 1 deletions
diff --git a/dev-ml/js_of_ocaml/ChangeLog b/dev-ml/js_of_ocaml/ChangeLog
index 0befd025f451..485d936391ee 100644
--- a/dev-ml/js_of_ocaml/ChangeLog
+++ b/dev-ml/js_of_ocaml/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for dev-ml/js_of_ocaml
# Copyright 1999-2014 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-ml/js_of_ocaml/ChangeLog,v 1.7 2014/12/01 09:50:16 aballier Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-ml/js_of_ocaml/ChangeLog,v 1.8 2014/12/01 10:25:33 aballier Exp $
+
+*js_of_ocaml-2.5-r1 (01 Dec 2014)
+
+ 01 Dec 2014; Alexis Ballier <aballier@gentoo.org> +js_of_ocaml-2.5-r1.ebuild:
+ add missing dep
*js_of_ocaml-2.5 (01 Dec 2014)
diff --git a/dev-ml/js_of_ocaml/js_of_ocaml-2.5-r1.ebuild b/dev-ml/js_of_ocaml/js_of_ocaml-2.5-r1.ebuild
new file mode 100644
index 000000000000..c454f5594ba6
--- /dev/null
+++ b/dev-ml/js_of_ocaml/js_of_ocaml-2.5-r1.ebuild
@@ -0,0 +1,44 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-ml/js_of_ocaml/js_of_ocaml-2.5-r1.ebuild,v 1.1 2014/12/01 10:25:33 aballier Exp $
+
+EAPI=5
+
+inherit findlib
+
+DESCRIPTION="A compiler from OCaml bytecode to javascript"
+HOMEPAGE="http://ocsigen.org/js_of_ocaml/"
+SRC_URI="https://github.com/ocsigen/js_of_ocaml/archive/${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="LGPL-2.1-with-linking-exception"
+SLOT="0/${PV}"
+KEYWORDS="~amd64"
+IUSE="+ocamlopt doc +deriving"
+
+DEPEND=">=dev-lang/ocaml-3.12:=[ocamlopt?]
+ >=dev-ml/lwt-2.4.0:=
+ dev-ml/react:=
+ dev-ml/reactiveData:=
+ >=dev-ml/tyxml-3.3:=
+ dev-ml/cmdliner:=
+ dev-ml/menhir:=
+ || ( dev-ml/camlp4:= <dev-lang/ocaml-4.02.0 )
+ deriving? ( >=dev-ml/deriving-0.6:= )"
+RDEPEND="${DEPEND}"
+
+src_configure() {
+ use ocamlopt || echo "BEST := byte" >> Makefile.conf
+ use deriving || echo "WITH_DERIVING := NO" >> Makefile.conf
+}
+
+src_compile() {
+ emake -j1
+ use doc && emake doc
+}
+
+src_install() {
+ findlib_src_preinst
+ emake BINDIR="${ED}/usr/bin/" install
+ dodoc CHANGES README.md
+ use doc && dohtml -r doc/api/html/
+}