summaryrefslogtreecommitdiff
path: root/dev-ml
diff options
context:
space:
mode:
authorAlexis Ballier <aballier@gentoo.org>2008-01-02 21:57:29 +0000
committerAlexis Ballier <aballier@gentoo.org>2008-01-02 21:57:29 +0000
commit18c15ed1a844bfe085b7d3430d44d3f316f2d068 (patch)
treed47b4f232872336efbe67cf251e1826311ccf62c /dev-ml
parentdev-ml/pcre-ocaml ocamlopt useflag (diff)
downloadgentoo-2-18c15ed1a844bfe085b7d3430d44d3f316f2d068.tar.gz
gentoo-2-18c15ed1a844bfe085b7d3430d44d3f316f2d068.tar.bz2
gentoo-2-18c15ed1a844bfe085b7d3430d44d3f316f2d068.zip
Version bump and add support to not build with ocamlopt
(Portage version: 2.1.4_rc14)
Diffstat (limited to 'dev-ml')
-rw-r--r--dev-ml/pcre-ocaml/ChangeLog10
-rw-r--r--dev-ml/pcre-ocaml/files/digest-pcre-ocaml-5.12.23
-rw-r--r--dev-ml/pcre-ocaml/pcre-ocaml-5.12.2.ebuild52
3 files changed, 63 insertions, 2 deletions
diff --git a/dev-ml/pcre-ocaml/ChangeLog b/dev-ml/pcre-ocaml/ChangeLog
index 23507124942e..6b77457f37ee 100644
--- a/dev-ml/pcre-ocaml/ChangeLog
+++ b/dev-ml/pcre-ocaml/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for dev-ml/pcre-ocaml
-# Copyright 2002-2007 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-ml/pcre-ocaml/ChangeLog,v 1.14 2007/08/30 13:34:34 phreak Exp $
+# Copyright 2002-2008 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/dev-ml/pcre-ocaml/ChangeLog,v 1.15 2008/01/02 21:57:28 aballier Exp $
+
+*pcre-ocaml-5.12.2 (02 Jan 2008)
+
+ 02 Jan 2008; Alexis Ballier <aballier@gentoo.org>
+ +pcre-ocaml-5.12.2.ebuild:
+ Version bump and add support to not build with ocamlopt
30 Aug 2007; Christian Heim <phreak@gentoo.org> metadata.xml:
Removing mattam from metadata due to his retirement (see #30021 for reference).
diff --git a/dev-ml/pcre-ocaml/files/digest-pcre-ocaml-5.12.2 b/dev-ml/pcre-ocaml/files/digest-pcre-ocaml-5.12.2
new file mode 100644
index 000000000000..cfb1fea68d5c
--- /dev/null
+++ b/dev-ml/pcre-ocaml/files/digest-pcre-ocaml-5.12.2
@@ -0,0 +1,3 @@
+MD5 dbe759392f1c1d22cb96b9136ebf4ec4 pcre-ocaml-5.12.2.tar.bz2 50303
+RMD160 f81b5cc03da0282c576c49ae66691b358f94dd9a pcre-ocaml-5.12.2.tar.bz2 50303
+SHA256 4eb6d1b2ae09cd60a1c06901e41315c735c2ed84c89897d85cc18c44d768f18d pcre-ocaml-5.12.2.tar.bz2 50303
diff --git a/dev-ml/pcre-ocaml/pcre-ocaml-5.12.2.ebuild b/dev-ml/pcre-ocaml/pcre-ocaml-5.12.2.ebuild
new file mode 100644
index 000000000000..4b407e000c00
--- /dev/null
+++ b/dev-ml/pcre-ocaml/pcre-ocaml-5.12.2.ebuild
@@ -0,0 +1,52 @@
+# Copyright 1999-2008 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-ml/pcre-ocaml/pcre-ocaml-5.12.2.ebuild,v 1.1 2008/01/02 21:57:28 aballier Exp $
+
+inherit findlib eutils
+
+EAPI="1"
+
+DESCRIPTION="Perl Compatibility Regular Expressions for O'Caml"
+HOMEPAGE="http://www.ocaml.info/home/ocaml_sources.html"
+SRC_URI="http://www.ocaml.info/ocaml_sources/${P}.tar.bz2"
+LICENSE="LGPL-2.1"
+
+DEPEND=">=dev-lang/ocaml-3.07
+ >=dev-libs/libpcre-4.5"
+SLOT="0"
+IUSE="examples +ocamlopt"
+KEYWORDS="~amd64 ~ppc ~x86"
+
+pkg_setup() {
+ if use ocamlopt && ! built_with_use --missing true dev-lang/ocaml ocamlopt; then
+ eerror "In order to build ${PN} with native code support from ocaml"
+ eerror "You first need to have a native code ocaml compiler."
+ eerror "You need to install dev-lang/ocaml with ocamlopt useflag on."
+ die "Please install ocaml with ocamlopt useflag"
+ fi
+}
+
+src_compile() {
+ cd "${S}/lib"
+ emake byte-code-library || die "Failed to build byte code library"
+ if use ocamlopt; then
+ emake native-code-library || die "Failed to build native code library"
+ fi
+}
+
+
+src_install () {
+ export OCAMLFIND_INSTFLAGS="-optional"
+ findlib_src_install
+
+ # install documentation
+ dodoc README VERSION Changes
+
+ if use examples; then
+ for dir in examples/*
+ do
+ docinto $dir
+ dodoc $dir/*
+ done
+ fi
+}