summaryrefslogtreecommitdiff
path: root/dev-ml
diff options
context:
space:
mode:
authorAlexis Ballier <aballier@gentoo.org>2014-12-01 14:15:40 +0000
committerAlexis Ballier <aballier@gentoo.org>2014-12-01 14:15:40 +0000
commitd3ffe925c6b010d120ed58df679059c0c2e3a16e (patch)
tree1f4f6649313987dafae9558eb888e5d82799126b /dev-ml
parentversion bump (diff)
downloadgentoo-2-d3ffe925c6b010d120ed58df679059c0c2e3a16e.tar.gz
gentoo-2-d3ffe925c6b010d120ed58df679059c0c2e3a16e.tar.bz2
gentoo-2-d3ffe925c6b010d120ed58df679059c0c2e3a16e.zip
version bump
Signed-off-by: aballier@gentoo.org (Portage version: 2.2.14/cvs/Linux x86_64, signed Manifest commit with key 160F534A)
Diffstat (limited to 'dev-ml')
-rw-r--r--dev-ml/async/ChangeLog7
-rw-r--r--dev-ml/async/async-112.01.00.ebuild40
2 files changed, 46 insertions, 1 deletions
diff --git a/dev-ml/async/ChangeLog b/dev-ml/async/ChangeLog
index 5e867350df7d..118788d3e184 100644
--- a/dev-ml/async/ChangeLog
+++ b/dev-ml/async/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for dev-ml/async
# Copyright 1999-2014 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-ml/async/ChangeLog,v 1.13 2014/11/28 18:05:22 aballier Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-ml/async/ChangeLog,v 1.14 2014/12/01 14:15:40 aballier Exp $
+
+*async-112.01.00 (01 Dec 2014)
+
+ 01 Dec 2014; Alexis Ballier <aballier@gentoo.org> +async-112.01.00.ebuild:
+ version bump
28 Nov 2014; Alexis Ballier <aballier@gentoo.org> async-111.25.00.ebuild:
update deps for ocaml 4.02
diff --git a/dev-ml/async/async-112.01.00.ebuild b/dev-ml/async/async-112.01.00.ebuild
new file mode 100644
index 000000000000..2cfe3ef1269a
--- /dev/null
+++ b/dev-ml/async/async-112.01.00.ebuild
@@ -0,0 +1,40 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-ml/async/async-112.01.00.ebuild,v 1.1 2014/12/01 14:15:40 aballier Exp $
+
+EAPI="5"
+
+OASIS_BUILD_DOCS=1
+OASIS_BUILD_TESTS=1
+
+inherit oasis
+
+MY_P=${PN/-/_}-${PV}
+DESCRIPTION="Jane Street Capital's asynchronous execution library"
+HOMEPAGE="http://www.janestreet.com/ocaml"
+SRC_URI="http://ocaml.janestreet.com/ocaml-core/${PV}/individual/${MY_P}.tar.gz
+ http://dev.gentoo.org/~aballier/distfiles/${MY_P}.tar.gz"
+
+LICENSE="Apache-2.0"
+SLOT="0/${PV}"
+KEYWORDS="~amd64"
+IUSE="examples"
+
+RDEPEND=">=dev-lang/ocaml-4.00.0:=
+ >=dev-ml/async_kernel-${PV}:=
+ >=dev-ml/async_unix-${PV}:=
+ >=dev-ml/async_extra-${PV}:=
+ dev-ml/camlp4:=
+ "
+DEPEND="${RDEPEND}
+ test? ( >=dev-ml/ounit-1.0.2 dev-ml/core_bench )"
+
+S="${WORKDIR}/${MY_P}"
+
+src_install() {
+ oasis_src_install
+ if use examples ; then
+ dodoc -r examples
+ docompress -x /usr/share/doc/${PF}/examples
+ fi
+}