summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTorsten Veller <tove@gentoo.org>2010-01-07 07:54:28 +0000
committerTorsten Veller <tove@gentoo.org>2010-01-07 07:54:28 +0000
commit8fd48dc940fa832ee70afa873997e47824447429 (patch)
treed637fe54f128f7ef330df08e3a470a996dea78a2 /dev-perl/Devel-Profiler
parentversion bump (diff)
downloadgentoo-2-8fd48dc940fa832ee70afa873997e47824447429.tar.gz
gentoo-2-8fd48dc940fa832ee70afa873997e47824447429.tar.bz2
gentoo-2-8fd48dc940fa832ee70afa873997e47824447429.zip
Fix test failure (#299981). Patch from Fedora
(Portage version: 2.2_rc61/cvs/Linux x86_64)
Diffstat (limited to 'dev-perl/Devel-Profiler')
-rw-r--r--dev-perl/Devel-Profiler/ChangeLog8
-rw-r--r--dev-perl/Devel-Profiler/Devel-Profiler-0.04.ebuild12
-rw-r--r--dev-perl/Devel-Profiler/files/perl510.patch39
3 files changed, 51 insertions, 8 deletions
diff --git a/dev-perl/Devel-Profiler/ChangeLog b/dev-perl/Devel-Profiler/ChangeLog
index cd9367abfc36..41613ac3c891 100644
--- a/dev-perl/Devel-Profiler/ChangeLog
+++ b/dev-perl/Devel-Profiler/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for dev-perl/Devel-Profiler
-# Copyright 2000-2007 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-perl/Devel-Profiler/ChangeLog,v 1.12 2007/01/15 17:25:28 mcummings Exp $
+# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/dev-perl/Devel-Profiler/ChangeLog,v 1.13 2010/01/07 07:54:27 tove Exp $
+
+ 07 Jan 2010; Torsten Veller <tove@gentoo.org> +files/perl510.patch,
+ Devel-Profiler-0.04.ebuild:
+ Fix test failure (#299981). Patch from Fedora
15 Jan 2007; Michael Cummings <mcummings@gentoo.org>
Devel-Profiler-0.04.ebuild:
diff --git a/dev-perl/Devel-Profiler/Devel-Profiler-0.04.ebuild b/dev-perl/Devel-Profiler/Devel-Profiler-0.04.ebuild
index 2605181baa56..ea60c068128c 100644
--- a/dev-perl/Devel-Profiler/Devel-Profiler-0.04.ebuild
+++ b/dev-perl/Devel-Profiler/Devel-Profiler-0.04.ebuild
@@ -1,18 +1,18 @@
-# Copyright 1999-2007 Gentoo Foundation
+# Copyright 1999-2010 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-perl/Devel-Profiler/Devel-Profiler-0.04.ebuild,v 1.14 2007/07/10 23:33:26 mr_bones_ Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-perl/Devel-Profiler/Devel-Profiler-0.04.ebuild,v 1.15 2010/01/07 07:54:27 tove Exp $
+MODULE_AUTHOR=SAMTREGAR
inherit perl-module
DESCRIPTION="a Perl profiler compatible with dprofpp"
-HOMEPAGE="http://search.cpan.org/~samtregar/"
-SRC_URI="mirror://cpan/authors/id/S/SA/SAMTREGAR/${P}.tar.gz"
LICENSE="GPL-2"
SLOT="0"
KEYWORDS="amd64 ia64 ~ppc sparc x86"
IUSE=""
-SRC_TEST="do"
-
DEPEND="dev-lang/perl"
+
+SRC_TEST="do"
+PATCHES=( "${FILESDIR}"/perl510.patch )
diff --git a/dev-perl/Devel-Profiler/files/perl510.patch b/dev-perl/Devel-Profiler/files/perl510.patch
new file mode 100644
index 000000000000..78ecc4d99dba
--- /dev/null
+++ b/dev-perl/Devel-Profiler/files/perl510.patch
@@ -0,0 +1,39 @@
+http://cvs.fedoraproject.org/viewvc/devel/perl-Devel-Profiler/perl-Devel-Profiler-perl510.patch
+--- Devel-Profiler-0.04/lib/Devel/Profiler.pm
++++ Devel-Profiler-0.04/lib/Devel/Profiler.pm
+@@ -151,9 +151,14 @@ sub scan {
+ }
+
+ # found a code ref? then instrument it
+- instrument($pkg, $sym, $code)
+- if defined($code = *{$glob}{CODE}) and ref $code eq 'CODE';
+-
++ if (ref \$glob ne 'GLOB') {
++ # Something stranger in the typeglob, which will expand to (at
++ # least) a prototype if we take a reference to it.
++ instrument($pkg, $sym, \&{"$pkg$sym"});
++ } else {
++ instrument($pkg, $sym, $code)
++ if defined($code = *{$glob}{CODE}) and ref $code eq 'CODE';
++ }
+ }
+ }
+ }
+--- Devel-Profiler-0.04/t/09fcntl.t
++++ Devel-Profiler-0.04/t/09fcntl.t
+@@ -8,7 +8,14 @@ foo();
+ END
+
+ # make sure the call tree looks right
+-check_tree(<<END, "checking tree");
++if ($] > 5.009) {
++ # Fcntl's constants are now directly defined, so constant() isn't called.
++ check_tree(<<END, "checking tree");
++main::foo
++END
++} else {
++ check_tree(<<END, "checking tree");
+ main::foo
+ Fcntl::constant
+ END
++}