summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichael Cummings <mcummings@gentoo.org>2003-07-03 00:48:12 +0000
committerMichael Cummings <mcummings@gentoo.org>2003-07-03 00:48:12 +0000
commitaf04f39089eae2f2b65885819e2b8a8ade910907 (patch)
tree1c83101d145abe6d81ac2f6aeeed7b71d85a797d /dev-perl/Inline
parentAddresses bug 17223, patch submitted by Kfir Ozer <ufk2k@yahoo.com> (diff)
downloadgentoo-2-af04f39089eae2f2b65885819e2b8a8ade910907.tar.gz
gentoo-2-af04f39089eae2f2b65885819e2b8a8ade910907.tar.bz2
gentoo-2-af04f39089eae2f2b65885819e2b8a8ade910907.zip
Addresses bug 17223, patch submitted by Kfir Ozer <ufk2k@yahoo.com>
Diffstat (limited to 'dev-perl/Inline')
-rw-r--r--dev-perl/Inline/ChangeLog8
-rw-r--r--dev-perl/Inline/Inline-0.44-r1.ebuild45
-rw-r--r--dev-perl/Inline/Manifest4
-rw-r--r--dev-perl/Inline/files/digest-Inline-0.44-r11
-rw-r--r--dev-perl/Inline/files/gtk2-patch.diff32
5 files changed, 87 insertions, 3 deletions
diff --git a/dev-perl/Inline/ChangeLog b/dev-perl/Inline/ChangeLog
index e5bc1ebf6790..6683b981b317 100644
--- a/dev-perl/Inline/ChangeLog
+++ b/dev-perl/Inline/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for dev-perl/Inline
# Copyright 2002-2003 Gentoo Technologies, Inc.; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-perl/Inline/ChangeLog,v 1.10 2003/06/24 14:55:15 agriffis Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-perl/Inline/ChangeLog,v 1.11 2003/07/03 00:48:09 mcummings Exp $
+
+*Inline-0.44-r1 (02 Jul 2003)
+
+ 02 Jul 2003; Michael Cummings <mcummings@gentoo.org> Inline-0.44-r1.ebuild,
+ files/gtk2-patch.diff:
+ Addresses bug 17223, patch submitted by Kfir Ozer <ufk2k@yahoo.com>
24 Jun 2003; Aron Griffis <agriffis@gentoo.org> Inline-0.44.ebuild:
Mark stable on alpha
diff --git a/dev-perl/Inline/Inline-0.44-r1.ebuild b/dev-perl/Inline/Inline-0.44-r1.ebuild
new file mode 100644
index 000000000000..9354165ede71
--- /dev/null
+++ b/dev-perl/Inline/Inline-0.44-r1.ebuild
@@ -0,0 +1,45 @@
+# Copyright 1999-2003 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-perl/Inline/Inline-0.44-r1.ebuild,v 1.1 2003/07/03 00:48:09 mcummings Exp $
+
+inherit perl-module eutils
+
+S=${WORKDIR}/${P}
+DESCRIPTION="Write Perl subroutines in other languages"
+SRC_URI="http://www.cpan.org/authors/id/I/IN/INGY/${P}.tar.gz"
+HOMEPAGE="http://search.cpan.org/doc/INGY/Inline-0.43/Inline.pod"
+
+SLOT="0"
+LICENSE="Artistic"
+KEYWORDS="~x86 ~amd64 ~ppc ~sparc alpha"
+
+DEPEND="${DEPEND}
+ dev-perl/Digest-MD5
+ dev-perl/File-Spec
+ dev-perl/Parse-RecDescent
+ dev-perl/Test-Harness"
+
+src_unpack() {
+ unpack ${P}.tar.gz
+
+ cd ${S}
+ #gtk-2 suggested patch
+ if [ "`use gtk2`" ]
+ then
+ epatch ${FILESDIR}/gtk2-patch.diff
+ fi
+
+}
+
+src_compile() {
+
+ echo "y" | perl-module_src_compile
+ perl-module_src_test
+}
+
+
+src_install () {
+
+ perl-module_src_install
+ dohtml DT.html
+}
diff --git a/dev-perl/Inline/Manifest b/dev-perl/Inline/Manifest
index b8e492622294..dc6ebf9aaa0c 100644
--- a/dev-perl/Inline/Manifest
+++ b/dev-perl/Inline/Manifest
@@ -1,7 +1,7 @@
-MD5 b946a137b2b13fe3e1f9e893050dbe99 ChangeLog 934
+MD5 bd530b49cf0fc6be88835b5a1335c1ad ChangeLog 1140
MD5 d7641c0ff9ed5b01213d01e4e1ba5751 Inline-0.43-r1.ebuild 698
MD5 2cc0bb525fdf75f5d6ba9387726007d0 Inline-0.43.ebuild 696
-MD5 1efc6496fffc33ec01e852c8401dd4b5 Inline-0.44-r1.ebuild 924
+MD5 0983b2707d656c14bb16693262edd88f Inline-0.44-r1.ebuild 928
MD5 f3ba519214d153d8004e85d8c11b03c9 Inline-0.44.ebuild 796
MD5 10cb079ed55ec2e6b331b3b4d2a108a1 files/digest-Inline-0.43 62
MD5 10cb079ed55ec2e6b331b3b4d2a108a1 files/digest-Inline-0.43-r1 62
diff --git a/dev-perl/Inline/files/digest-Inline-0.44-r1 b/dev-perl/Inline/files/digest-Inline-0.44-r1
new file mode 100644
index 000000000000..6de2ec935f2b
--- /dev/null
+++ b/dev-perl/Inline/files/digest-Inline-0.44-r1
@@ -0,0 +1 @@
+MD5 840f47d9b6cef39e68370faf9dceab2c Inline-0.44.tar.gz 91450
diff --git a/dev-perl/Inline/files/gtk2-patch.diff b/dev-perl/Inline/files/gtk2-patch.diff
new file mode 100644
index 000000000000..bf28ec596f7b
--- /dev/null
+++ b/dev-perl/Inline/files/gtk2-patch.diff
@@ -0,0 +1,32 @@
+*** Inline-0.44/lib/Inline/denter.pm-orig 2001-06-13 06:30:50.000000000 +0200
+--- Inline-0.44/lib/Inline/denter.pm 2002-11-13 15:43:41.000000000 +0100
+***************
+*** 177,182 ****
+--- 177,183 ----
+ }
+
+ sub _next_line {
++ local ($_);
+ my $o = shift;
+ $o->{done}++, $o->{level} = -1, return unless @{$o->{lines}};
+ $_ = shift @{$o->{lines}};
+***************
+*** 188,193 ****
+--- 189,195 ----
+ $o->{done}++, $o->{level} = -1, return unless @{$o->{lines}};
+ my ($width, $tabwidth) = @{$o}{qw(width tabwidth)};
+ while (1) {
++ local ($_);
+ $_ = $o->{lines}[0];
+ # expand tabs in leading whitespace;
+ $o->next_line, next if /^(\s*$|\#)/; # skip comments and blank lines
+***************
+*** 221,226 ****
+--- 223,229 ----
+
+ sub indent_data {
+ my $o = shift;
++ local ($_);
+ $_ = shift;
+ return $o->indent_undef($_)
+ if not defined;