summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMatti Bickel <mabi@gentoo.org>2010-05-29 18:35:14 +0000
committerMatti Bickel <mabi@gentoo.org>2010-05-29 18:35:14 +0000
commit2ad4ee9285630c9d30f5a0a55c7a9a4ad2a4298b (patch)
tree4532091686de8bee8e3bebd7070fc44055496e2f /dev-php5/phing
parentversion bump (diff)
downloadgentoo-2-2ad4ee9285630c9d30f5a0a55c7a9a4ad2a4298b.tar.gz
gentoo-2-2ad4ee9285630c9d30f5a0a55c7a9a4ad2a4298b.tar.bz2
gentoo-2-2ad4ee9285630c9d30f5a0a55c7a9a4ad2a4298b.zip
version bump
(Portage version: 2.1.8.3/cvs/Linux x86_64)
Diffstat (limited to 'dev-php5/phing')
-rw-r--r--dev-php5/phing/ChangeLog7
-rw-r--r--dev-php5/phing/phing-2.4.1.ebuild41
2 files changed, 47 insertions, 1 deletions
diff --git a/dev-php5/phing/ChangeLog b/dev-php5/phing/ChangeLog
index 50d4c123665d..0d753754ad76 100644
--- a/dev-php5/phing/ChangeLog
+++ b/dev-php5/phing/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for dev-php5/phing
# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-php5/phing/ChangeLog,v 1.11 2010/01/01 22:30:47 yngwin Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-php5/phing/ChangeLog,v 1.12 2010/05/29 18:35:14 mabi Exp $
+
+*phing-2.4.1 (29 May 2010)
+
+ 29 May 2010; <mabi@gentoo.org> +phing-2.4.1.ebuild:
+ version bump
*phing-2.3.3 (01 Jan 2010)
diff --git a/dev-php5/phing/phing-2.4.1.ebuild b/dev-php5/phing/phing-2.4.1.ebuild
new file mode 100644
index 000000000000..0d173642b16c
--- /dev/null
+++ b/dev-php5/phing/phing-2.4.1.ebuild
@@ -0,0 +1,41 @@
+# Copyright 1999-2010 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-php5/phing/phing-2.4.1.ebuild,v 1.1 2010/05/29 18:35:14 mabi Exp $
+
+EAPI="2"
+inherit php-pear-lib-r1 eutils
+
+DESCRIPTION="PHP project build system based on Apache Ant"
+HOMEPAGE="http://www.phing.info/"
+SRC_URI="http://pear.phing.info/get/phing-${PV/_/}.tgz"
+
+
+LICENSE="LGPL-2.1"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="+minimal"
+
+DEPEND=""
+RDEPEND="!minimal? ( >=dev-php/PEAR-PhpDocumentor-1.4.0
+ >=dev-php/PEAR-PEAR_PackageFileManager-1.5.2
+ >=dev-php/PEAR-VersionControl_SVN-0.3.0_alpha1
+ >=dev-php5/phpunit-3.2.0
+ >=dev-php5/xdebug-2.0.0
+ >=dev-php/simpletest-1.0.1_beta2
+ >=dev-php5/creole-1.1.0 )
+ >=dev-lang/php-5.0.2[xml,xsl]
+ || ( <dev-lang/php-5.3.1[pcre,reflection,spl] >=dev-lang/php-5.3.1 )
+ "
+
+need_php_by_category
+
+S=${WORKDIR}/${PN}-${PV/_/}
+
+
+pkg_postinst() {
+ if use minimal; then
+ elog "You have enabled the minimal USE flag. If you want to use features"
+ elog "from xdebug, phpunit, simpletest and more, disable the"
+ elog "USE flag or emerge the packages manually"
+ fi
+}