summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorChristian Hoffmann <hoffie@gentoo.org>2008-03-25 22:51:57 +0000
committerChristian Hoffmann <hoffie@gentoo.org>2008-03-25 22:51:57 +0000
commit7f34916d1d913f009680ad40622e979c120a43ff (patch)
tree7b69c59de270627d64752a88210a89cfee275be2 /dev-php5
parentCHANGES file doesn't exist (diff)
downloadgentoo-2-7f34916d1d913f009680ad40622e979c120a43ff.tar.gz
gentoo-2-7f34916d1d913f009680ad40622e979c120a43ff.tar.bz2
gentoo-2-7f34916d1d913f009680ad40622e979c120a43ff.zip
version bump to 3.0.17, mainly to address security bug 214576 (CVE-2008-1488); thanks to jakub
(Portage version: 2.1.4.4)
Diffstat (limited to 'dev-php5')
-rw-r--r--dev-php5/pecl-apc/ChangeLog7
-rw-r--r--dev-php5/pecl-apc/pecl-apc-3.0.17.ebuild66
2 files changed, 72 insertions, 1 deletions
diff --git a/dev-php5/pecl-apc/ChangeLog b/dev-php5/pecl-apc/ChangeLog
index e9f24df3b30f..0393f162b724 100644
--- a/dev-php5/pecl-apc/ChangeLog
+++ b/dev-php5/pecl-apc/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for dev-php5/pecl-apc
# Copyright 1999-2008 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-php5/pecl-apc/ChangeLog,v 1.37 2008/03/02 14:46:38 philantrop Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-php5/pecl-apc/ChangeLog,v 1.38 2008/03/25 22:51:57 hoffie Exp $
+
+ 25 Mar 2008; Jakub Moc <jakub@gentoo.org>
+ +pecl-apc-3.0.17.ebuild:
+ Version bump, fixes CVE-2008-1488 - see Bug 214576. Also fixing some
+ memory leaks and apc_add() cache expunge bug.
02 Mar 2008; Wulf C. Krueger <philantrop@gentoo.org>
pecl-apc-3.0.16.ebuild:
diff --git a/dev-php5/pecl-apc/pecl-apc-3.0.17.ebuild b/dev-php5/pecl-apc/pecl-apc-3.0.17.ebuild
new file mode 100644
index 000000000000..54a84dde7b71
--- /dev/null
+++ b/dev-php5/pecl-apc/pecl-apc-3.0.17.ebuild
@@ -0,0 +1,66 @@
+# Copyright 1999-2008 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-php5/pecl-apc/pecl-apc-3.0.17.ebuild,v 1.1 2008/03/25 22:51:57 hoffie Exp $
+
+PHP_EXT_NAME="apc"
+PHP_EXT_PECL_PKG="APC"
+PHP_EXT_INI="yes"
+PHP_EXT_ZENDEXT="no"
+DOCS="CHANGELOG INSTALL NOTICE TECHNOTES.txt TODO"
+
+inherit php-ext-pecl-r1 confutils eutils
+
+KEYWORDS="~amd64 ~ppc ~ppc64 ~sparc ~x86"
+
+DESCRIPTION="A free, open, and robust framework for caching and optimizing PHP code."
+LICENSE="PHP-3.01"
+SLOT="0"
+IUSE="mmap"
+
+DEPEND="!dev-php5/eaccelerator !dev-php5/xcache"
+RDEPEND="${DEPEND}"
+
+need_php_by_category
+
+pkg_setup() {
+ require_php_sapi_from cgi apache2
+}
+
+src_compile() {
+ has_php
+
+ my_conf="--enable-apc"
+ enable_extension_enable "apc-mmap" "mmap" 0
+ enable_extension_with_built_with =${PHP_PKG} apache2 apxs /usr/sbin/apxs2 "optimisation for apache2"
+
+ php-ext-pecl-r1_src_compile
+}
+
+src_install() {
+ php-ext-pecl-r1_src_install
+
+ php-ext-base-r1_addtoinifiles "apc.enabled" '"1"'
+ php-ext-base-r1_addtoinifiles "apc.shm_segments" '"1"'
+ php-ext-base-r1_addtoinifiles "apc.shm_size" '"30"'
+ php-ext-base-r1_addtoinifiles "apc.optimization" '"0"'
+ php-ext-base-r1_addtoinifiles "apc.num_files_hint" '"1024"'
+ php-ext-base-r1_addtoinifiles "apc.ttl" '"7200"'
+ php-ext-base-r1_addtoinifiles "apc.user_ttl" '"7200"'
+ php-ext-base-r1_addtoinifiles "apc.gc_ttl" '"3600"'
+ php-ext-base-r1_addtoinifiles "apc.cache_by_default" '"1"'
+ php-ext-base-r1_addtoinifiles ";apc.mmap_file_mask" '"/tmp/apcphp5.XXXXXX"'
+ php-ext-base-r1_addtoinifiles "apc.file_update_protection" '"2"'
+ php-ext-base-r1_addtoinifiles "apc.enable_cli" '"0"'
+ php-ext-base-r1_addtoinifiles "apc.max_file_size" '"1M"'
+ php-ext-base-r1_addtoinifiles "apc.stat" '"1"'
+ php-ext-base-r1_addtoinifiles "apc.write_lock" '"1"'
+
+ dodir "${PHP_EXT_SHARED_DIR}"
+ insinto "${PHP_EXT_SHARED_DIR}"
+ doins apc.php
+}
+
+pkg_postinst() {
+ elog "The apc.php file shipped with this release of PECL-APC was"
+ elog "installed into ${ROOT}usr/share/php5/apc/."
+}