summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorIan Delaney <idella4@gentoo.org>2014-12-07 10:45:49 +0000
committerIan Delaney <idella4@gentoo.org>2014-12-07 10:45:49 +0000
commit2a69e205919c6e844e45fa889e59790958f0fdde (patch)
tree07bf365a7f20572e155f77f64ce170bf2df44d17 /dev-python/colander
parentversion bump (diff)
downloadgentoo-2-2a69e205919c6e844e45fa889e59790958f0fdde.tar.gz
gentoo-2-2a69e205919c6e844e45fa889e59790958f0fdde.tar.bz2
gentoo-2-2a69e205919c6e844e45fa889e59790958f0fdde.zip
clean old impl, add pypy3, add new dep for tests, tm old
(Portage version: 2.2.14/cvs/Linux x86_64, signed Manifest commit with key 0xB8072B0D)
Diffstat (limited to 'dev-python/colander')
-rw-r--r--dev-python/colander/ChangeLog9
-rw-r--r--dev-python/colander/colander-1.0.ebuild (renamed from dev-python/colander/colander-1.0_beta1.ebuild)9
-rw-r--r--dev-python/colander/colander-1.0_alpha1-r1.ebuild55
-rw-r--r--dev-python/colander/colander-1.0_alpha1.ebuild59
4 files changed, 13 insertions, 119 deletions
diff --git a/dev-python/colander/ChangeLog b/dev-python/colander/ChangeLog
index 19e2526d64ed..2fe462cb75c5 100644
--- a/dev-python/colander/ChangeLog
+++ b/dev-python/colander/ChangeLog
@@ -1,6 +1,13 @@
# ChangeLog for dev-python/colander
# Copyright 1999-2014 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/colander/ChangeLog,v 1.12 2014/08/21 01:30:14 idella4 Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-python/colander/ChangeLog,v 1.13 2014/12/07 10:45:49 idella4 Exp $
+
+*colander-1.0 (07 Dec 2014)
+
+ 07 Dec 2014; Ian Delaney <idella4@gentoo.org> +colander-1.0.ebuild,
+ -colander-1.0_alpha1-r1.ebuild, -colander-1.0_alpha1.ebuild,
+ -colander-1.0_beta1.ebuild:
+ clean old impl, add pypy3, add new dep for tests, tm old
*colander-1.0_beta1 (21 Aug 2014)
diff --git a/dev-python/colander/colander-1.0_beta1.ebuild b/dev-python/colander/colander-1.0.ebuild
index 42b4a9577e9e..db5d9ad2bbf8 100644
--- a/dev-python/colander/colander-1.0_beta1.ebuild
+++ b/dev-python/colander/colander-1.0.ebuild
@@ -1,10 +1,10 @@
# Copyright 1999-2014 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/colander/colander-1.0_beta1.ebuild,v 1.1 2014/08/21 01:30:14 idella4 Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-python/colander/colander-1.0.ebuild,v 1.1 2014/12/07 10:45:49 idella4 Exp $
EAPI=5
-PYTHON_COMPAT=( python{2_7,3_2,3_3,3_4} pypy )
+PYTHON_COMPAT=( python{2_7,3_3,3_4} pypy pypy3 )
inherit distutils-r1
@@ -27,10 +27,11 @@ RDEPEND=">=dev-python/translationstring-1.1[${PYTHON_USEDEP}]"
DEPEND="${RDEPEND}
dev-python/setuptools[${PYTHON_USEDEP}]
doc? ( dev-python/sphinx[${PYTHON_USEDEP}] )
- test? ( dev-python/nose[${PYTHON_USEDEP}] )"
+ test? ( dev-python/nose[${PYTHON_USEDEP}]
+ dev-python/iso8601[${PYTHON_USEDEP}] )"
# Include COPYRIGHT.txt because the license seems to require it.
-DOCS=( CHANGES.txt COPYRIGHT.txt README.txt )
+DOCS=( CHANGES.rst COPYRIGHT.txt README.rst )
python_prepare_all() {
# Remove pylons theme since it's not included in source
diff --git a/dev-python/colander/colander-1.0_alpha1-r1.ebuild b/dev-python/colander/colander-1.0_alpha1-r1.ebuild
deleted file mode 100644
index be045d486686..000000000000
--- a/dev-python/colander/colander-1.0_alpha1-r1.ebuild
+++ /dev/null
@@ -1,55 +0,0 @@
-# Copyright 1999-2014 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/colander/colander-1.0_alpha1-r1.ebuild,v 1.2 2014/03/31 20:50:55 mgorny Exp $
-
-EAPI=5
-
-PYTHON_COMPAT=( python{2_6,2_7,3_2,3_3} pypy pypy2_0 )
-
-inherit distutils-r1
-
-DESCRIPTION="A simple schema-based serialization and deserialization library"
-HOMEPAGE="http://docs.pylonsproject.org/projects/colander/en/latest/ http://pypi.python.org/pypi/colander"
-MY_P=${P/_alpha1/a1}
-SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${MY_P}.tar.gz"
-
-S="${WORKDIR}/${MY_P}"
-
-# MIT license is used by included (modified) iso8601.py code.
-LICENSE="repoze MIT"
-SLOT="0"
-KEYWORDS="~amd64 ~x86"
-IUSE="doc"
-
-# Depend on an ebuild of translationstring with Python 3 support.
-RDEPEND=">=dev-python/translationstring-1.1[${PYTHON_USEDEP}]"
-
-DEPEND="${RDEPEND}
- dev-python/setuptools[${PYTHON_USEDEP}]
- doc? ( dev-python/sphinx[${PYTHON_USEDEP}] )"
-
-# Include COPYRIGHT.txt because the license seems to require it.
-DOCS=( CHANGES.txt COPYRIGHT.txt README.txt )
-
-python_prepare_all() {
- # Remove pylons theme since it's not included in source
- sed -e "/# Add and use Pylons theme/,+37d" -i docs/conf.py || die
-
- distutils-r1_python_prepare_all
-}
-
-python_compile_all() {
- if use doc; then
- # https://github.com/Pylons/colander/issues/38
- emake -C docs html SPHINXOPTS=""
- fi
-}
-
-python_test() {
- nosetests || die "Tests fail with ${EPYTHON}"
-}
-
-python_install_all() {
- use doc && local HTML_DOCS=( docs/_build/html/. )
- distutils-r1_python_install_all
-}
diff --git a/dev-python/colander/colander-1.0_alpha1.ebuild b/dev-python/colander/colander-1.0_alpha1.ebuild
deleted file mode 100644
index 9e6fa105fa0e..000000000000
--- a/dev-python/colander/colander-1.0_alpha1.ebuild
+++ /dev/null
@@ -1,59 +0,0 @@
-# Copyright 1999-2013 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/colander/colander-1.0_alpha1.ebuild,v 1.1 2013/01/22 07:01:30 patrick Exp $
-
-EAPI=4
-
-SUPPORT_PYTHON_ABIS=1
-PYTHON_DEPEND="2:2.6 3:3.2"
-RESTRICT_PYTHON_ABIS="2.4 2.5 3.0 3.1"
-DISTUTILS_SRC_TEST=nosetests
-
-inherit distutils
-
-DESCRIPTION="A simple schema-based serialization and deserialization library"
-HOMEPAGE="http://docs.pylonsproject.org/projects/colander/en/latest/ http://pypi.python.org/pypi/colander"
-MY_P=${P/_alpha1/a1}
-SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${MY_P}.tar.gz"
-
-S="${WORKDIR}/${MY_P}"
-
-# MIT license is used by included (modified) iso8601.py code.
-LICENSE="repoze MIT"
-SLOT="0"
-KEYWORDS="~amd64 ~x86"
-IUSE="doc"
-
-# Depend on an ebuild of translationstring with Python 3 support.
-RDEPEND=">=dev-python/translationstring-1.1"
-
-DEPEND="${RDEPEND}
- dev-python/setuptools
- doc? ( dev-python/sphinx )"
-
-# Include COPYRIGHT.txt because the license seems to require it.
-DOCS="CHANGES.txt COPYRIGHT.txt README.txt"
-
-src_prepare() {
- distutils_src_prepare
-
- # Remove pylons theme since it's not included in source
- sed -e "/# Add and use Pylons theme/,+37d" -i docs/conf.py || die
-}
-
-src_compile() {
- distutils_src_compile
-
- if use doc; then
- # https://github.com/Pylons/colander/issues/38
- PYTHONPATH="." emake -C docs html SPHINXOPTS=""
- fi
-}
-
-src_install() {
- distutils_src_install
-
- if use doc; then
- dohtml -r docs/_build/html/
- fi
-}