summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorIan Delaney <idella4@gentoo.org>2013-07-04 12:50:10 +0000
committerIan Delaney <idella4@gentoo.org>2013-07-04 12:50:10 +0000
commit2f08aed87e5adef848f958e2996f3f2814d5f026 (patch)
tree882bc9e5c9307697fa20bcc943e6bcb4f2e47a20 /dev-python/cssutils
parentVersion bump (fixes bug #430428). Removed old (diff)
downloadgentoo-2-2f08aed87e5adef848f958e2996f3f2814d5f026.tar.gz
gentoo-2-2f08aed87e5adef848f958e2996f3f2814d5f026.tar.bz2
gentoo-2-2f08aed87e5adef848f958e2996f3f2814d5f026.zip
revbump; migrate -> distutils-r1, bump; test phases added accordingly, outstanding test failuress filed, cited, latest tarball 'topped up', re-tared, re-located to devspace
(Portage version: 2.1.11.63/cvs/Linux x86_64, signed Manifest commit with key 0xB8072B0D)
Diffstat (limited to 'dev-python/cssutils')
-rw-r--r--dev-python/cssutils/ChangeLog13
-rw-r--r--dev-python/cssutils/cssutils-0.9.10.ebuild60
-rw-r--r--dev-python/cssutils/cssutils-0.9.10_beta1-r1.ebuild63
3 files changed, 134 insertions, 2 deletions
diff --git a/dev-python/cssutils/ChangeLog b/dev-python/cssutils/ChangeLog
index 2447a9d21c17..82f54cbd1666 100644
--- a/dev-python/cssutils/ChangeLog
+++ b/dev-python/cssutils/ChangeLog
@@ -1,6 +1,15 @@
# ChangeLog for dev-python/cssutils
-# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/cssutils/ChangeLog,v 1.26 2012/09/12 23:10:41 floppym Exp $
+# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/dev-python/cssutils/ChangeLog,v 1.27 2013/07/04 12:50:10 idella4 Exp $
+
+*cssutils-0.9.10 (04 Jul 2013)
+*cssutils-0.9.10_beta1-r1 (04 Jul 2013)
+
+ 04 Jul 2013; Ian Delaney <idella4@gentoo.org> +cssutils-0.9.10.ebuild,
+ +cssutils-0.9.10_beta1-r1.ebuild:
+ revbump; migrate -> distutils-r1, bump; test phases added accordingly,
+ outstanding test failuress filed, cited, latest tarball 'topped up', re-tared,
+ re-located to devspace
12 Sep 2012; Mike Gilbert <floppym@gentoo.org> cssutils-0.9.10_beta1.ebuild:
Remove obsolete sed. Thanks Arfrever.
diff --git a/dev-python/cssutils/cssutils-0.9.10.ebuild b/dev-python/cssutils/cssutils-0.9.10.ebuild
new file mode 100644
index 000000000000..eab84fccdb36
--- /dev/null
+++ b/dev-python/cssutils/cssutils-0.9.10.ebuild
@@ -0,0 +1,60 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-python/cssutils/cssutils-0.9.10.ebuild,v 1.1 2013/07/04 12:50:10 idella4 Exp $
+
+EAPI=5
+PYTHON_COMPAT=( python{2_5,2_6,2_7,3_2,3_3} pypy2_0 )
+
+inherit distutils-r1
+
+DESCRIPTION="A CSS Cascading Style Sheets library"
+HOMEPAGE="http://pypi.python.org/pypi/cssutils/ https://bitbucket.org/cthedot/cssutils"
+SRC_URI="http://dev.gentoo.org/~idella4/tarballs/${P}-20130704.tar.gz"
+
+LICENSE="GPL-3"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~x86"
+IUSE="examples test"
+
+RDEPEND="dev-python/setuptools[${PYTHON_USEDEP}]"
+DEPEND="${RDEPEND}
+ test? ( dev-python/mock[${PYTHON_USEDEP}] )"
+DISTUTILS_IN_SOURCE_BUILD=1
+
+python_prepare_all() {
+ # Disable test failing with dev-python/pyxml installed.
+ if has_version dev-python/pyxml; then
+ sed -e "s/test_linecol/_&/" -i src/tests/test_errorhandler.py
+ fi
+
+ distutils-r1_python_prepare_all
+}
+
+python_test() {
+ # https://bitbucket.org/cthedot/cssutils/issue/35/cssutils-0910-testsuite-fails-from-pypy
+ if [[ "${EPYTHON}" == python2* || "${EPYTHON}" == 'pypy2_0' ]]; then
+ pushd "${BUILD_DIR}"/../ > /dev/null
+ nosetests src/${PN}/tests/test_*.py || die "Tests failed under ${EPYTHON}"
+ else
+ pushd "${BUILD_DIR}"/
+ ln -sf ../sheets .
+ cd lib || die
+ nosetests ${PN}/tests/test_*.py || die "Tests failed under ${EPYTHON}"
+ fi
+}
+
+python_install() {
+ distutils-r1_python_install
+ # Don't install py3 stuff on py2. Breaks py25
+ if [[ "${EPYTHON}" != python3.* ]]; then
+ rm -f "${ED}$(python_get_sitedir)/cssutils/_codec3.py" || die
+ fi
+
+ # Don't install tests
+ rm -fr "${ED}$(python_get_sitedir)/${PN}/tests" || die
+}
+
+python_install_all() {
+ use examples && local EXAMPLES=( examples/. )
+ distutils-r1_python_install_all
+}
diff --git a/dev-python/cssutils/cssutils-0.9.10_beta1-r1.ebuild b/dev-python/cssutils/cssutils-0.9.10_beta1-r1.ebuild
new file mode 100644
index 000000000000..e48acd4c62f2
--- /dev/null
+++ b/dev-python/cssutils/cssutils-0.9.10_beta1-r1.ebuild
@@ -0,0 +1,63 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-python/cssutils/cssutils-0.9.10_beta1-r1.ebuild,v 1.1 2013/07/04 12:50:10 idella4 Exp $
+
+EAPI=5
+PYTHON_COMPAT=( python{2_5,2_6,2_7,3_2,3_3} pypy2_0 )
+
+inherit distutils-r1
+
+MY_P="${P/_beta/b}"
+
+DESCRIPTION="A CSS Cascading Style Sheets library"
+HOMEPAGE="http://pypi.python.org/pypi/cssutils/ https://bitbucket.org/cthedot/cssutils"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${MY_P}.zip"
+
+LICENSE="GPL-3"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~x86"
+IUSE="examples test"
+
+RDEPEND="dev-python/setuptools[${PYTHON_USEDEP}]"
+DEPEND="${RDEPEND}
+ app-arch/unzip
+ test? ( dev-python/mock[${PYTHON_USEDEP}] )"
+
+S="${WORKDIR}/${MY_P}"
+DISTUTILS_IN_SOURCE_BUILD=1
+
+python_prepare_all() {
+ # Disable test failing with dev-python/pyxml installed.
+ if has_version dev-python/pyxml; then
+ sed -e "s/test_linecol/_&/" -i src/tests/test_errorhandler.py
+ fi
+ distutils-r1_python_prepare_all
+}
+
+python_test() {
+ if [[ "${EPYTHON}" == python2* || "${EPYTHON}" == 'pypy2_0' ]]; then
+ pushd "${BUILD_DIR}"/../ > /dev/null
+ nosetests src/tests/test_*.py || die "Tests failed under ${EPYTHON}"
+ else
+ pushd "${BUILD_DIR}"/
+ ln -sf ../sheets .
+ cd lib || die
+ nosetests tests/test_*.py || die "Tests failed under ${EPYTHON}"
+ fi
+}
+
+python_install() {
+ distutils-r1_python_install
+ # Don't install py3 stuff on py2. Breaks py25
+ if [[ "${EPYTHON}" != python3.* ]]; then
+ rm -f "${ED}$(python_get_sitedir)/cssutils/_codec3.py" || die
+ fi
+
+ # Don't install tests
+ rm -fr "${ED}$(python_get_sitedir)/tests" || die
+}
+
+python_install_all() {
+ use examples && local EXAMPLES=( examples/. )
+ distutils-r1_python_install_all
+}