summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlex Brandt <alunduil@gentoo.org>2014-10-11 22:25:03 +0000
committerAlex Brandt <alunduil@gentoo.org>2014-10-11 22:25:03 +0000
commitda855f5f2d8484ab68e622837d75c1efdea73569 (patch)
treedf9155fb609ff44767a79cf769f37f1b829b671c /dev-python/doublex/doublex-1.8.1.ebuild
parentbup (diff)
downloadgentoo-2-da855f5f2d8484ab68e622837d75c1efdea73569.tar.gz
gentoo-2-da855f5f2d8484ab68e622837d75c1efdea73569.tar.bz2
gentoo-2-da855f5f2d8484ab68e622837d75c1efdea73569.zip
add ebuild for doublex—dependence for fig
(Portage version: 2.2.14_rc1/cvs/Linux x86_64, signed Manifest commit with key 11A8217C!)
Diffstat (limited to 'dev-python/doublex/doublex-1.8.1.ebuild')
-rw-r--r--dev-python/doublex/doublex-1.8.1.ebuild44
1 files changed, 44 insertions, 0 deletions
diff --git a/dev-python/doublex/doublex-1.8.1.ebuild b/dev-python/doublex/doublex-1.8.1.ebuild
new file mode 100644
index 000000000000..c73113235360
--- /dev/null
+++ b/dev-python/doublex/doublex-1.8.1.ebuild
@@ -0,0 +1,44 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-python/doublex/doublex-1.8.1.ebuild,v 1.1 2014/10/11 22:25:03 alunduil Exp $
+
+EAPI=5
+PYTHON_COMPAT=( python2_7 python3_3 )
+
+inherit distutils-r1 vcs-snapshot
+
+DESCRIPTION="Python test doubles"
+HOMEPAGE="https://bitbucket.org/DavidVilla/python-doublex"
+SRC_URI="https://bitbucket.org/DavidVilla/python-${PN}/get/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="GPL-3"
+SLOT="0"
+KEYWORDS="~amd64"
+IUSE="doc test"
+
+CDEPEND="dev-python/pyhamcrest[${PYTHON_USEDEP}]"
+DEPEND="
+ ${CDEPEND}
+ doc? ( dev-python/sphinx[${PYTHON_USEDEP}] )
+ test? (
+ dev-python/nose[${PYTHON_USEDEP}]
+ $(python_gen_cond_dep 'dev-python/unittest2[${PYTHON_USEDEP}]' 'python2*')
+ )
+"
+RDEPEND="${CDEPEND}"
+
+python_compile_all() {
+ use doc && emake -C docs
+}
+
+python_test() {
+ esetup.py test || die "Tests failed under ${EPYTHON}"
+}
+
+python_install_all() {
+ use doc && local HTML_DOCS=( docs/_build/html/. )
+
+ distutils-r1_python_install_all
+
+ rm "${D}"/usr/README.rst || die "Couldn't remove spurious README.rst"
+}