summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTim Harder <radhermit@gentoo.org>2014-08-22 21:03:50 +0000
committerTim Harder <radhermit@gentoo.org>2014-08-22 21:03:50 +0000
commit604a6f746237b33398ea9f23653cb97b37b49ee2 (patch)
treef0522db9318db0c7c0047594c40a06cfae8d2343 /dev-python/dugong
parentbumped EAPI to 5; committed directly to stable as no other changes present an... (diff)
downloadgentoo-2-604a6f746237b33398ea9f23653cb97b37b49ee2.tar.gz
gentoo-2-604a6f746237b33398ea9f23653cb97b37b49ee2.tar.bz2
gentoo-2-604a6f746237b33398ea9f23653cb97b37b49ee2.zip
Remove old.
(Portage version: 2.2.12/cvs/Linux x86_64, signed Manifest commit with key 4F064CA3)
Diffstat (limited to 'dev-python/dugong')
-rw-r--r--dev-python/dugong/ChangeLog6
-rw-r--r--dev-python/dugong/dugong-2.2.ebuild30
-rw-r--r--dev-python/dugong/dugong-3.0.ebuild30
-rw-r--r--dev-python/dugong/dugong-3.1.ebuild32
4 files changed, 5 insertions, 93 deletions
diff --git a/dev-python/dugong/ChangeLog b/dev-python/dugong/ChangeLog
index 0077f3233cd1..1c859502696a 100644
--- a/dev-python/dugong/ChangeLog
+++ b/dev-python/dugong/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for dev-python/dugong
# Copyright 1999-2014 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/dugong/ChangeLog,v 1.8 2014/08/20 07:57:24 idella4 Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-python/dugong/ChangeLog,v 1.9 2014/08/22 21:03:50 radhermit Exp $
+
+ 22 Aug 2014; Tim Harder <radhermit@gentoo.org> -dugong-2.2.ebuild,
+ -dugong-3.0.ebuild, -dugong-3.1.ebuild:
+ Remove old.
20 Aug 2014; Ian Delaney <idella4@gentoo.org> +files/3.3-test-timeout.patch,
dugong-3.3.ebuild:
diff --git a/dev-python/dugong/dugong-2.2.ebuild b/dev-python/dugong/dugong-2.2.ebuild
deleted file mode 100644
index 4f8a94d4e9b4..000000000000
--- a/dev-python/dugong/dugong-2.2.ebuild
+++ /dev/null
@@ -1,30 +0,0 @@
-# Copyright 1999-2014 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/dugong/dugong-2.2.ebuild,v 1.1 2014/03/17 09:03:32 radhermit Exp $
-
-EAPI=5
-PYTHON_COMPAT=( python3_3 )
-
-inherit distutils-r1
-
-DESCRIPTION="Python library for communicating with HTTP 1.1 servers"
-HOMEPAGE="https://bitbucket.org/nikratio/python-dugong/"
-SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.bz2"
-
-LICENSE="LGPL-2"
-SLOT="0"
-KEYWORDS="~amd64 ~x86"
-IUSE="doc examples test"
-
-DEPEND="dev-python/setuptools[${PYTHON_USEDEP}]
- test? ( dev-python/pytest[${PYTHON_USEDEP}] )"
-
-python_test() {
- py.test -v || die "Tests failed under ${EPYTHON}"
-}
-
-python_install_all() {
- use doc && local HTML_DOCS=( doc/html/. )
- use examples && local EXAMPLES=( examples/. )
- distutils-r1_python_install_all
-}
diff --git a/dev-python/dugong/dugong-3.0.ebuild b/dev-python/dugong/dugong-3.0.ebuild
deleted file mode 100644
index b8bcf185c6e0..000000000000
--- a/dev-python/dugong/dugong-3.0.ebuild
+++ /dev/null
@@ -1,30 +0,0 @@
-# Copyright 1999-2014 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/dugong/dugong-3.0.ebuild,v 1.1 2014/04/24 05:06:23 radhermit Exp $
-
-EAPI=5
-PYTHON_COMPAT=( python3_{3,4} )
-
-inherit distutils-r1
-
-DESCRIPTION="Python library for communicating with HTTP 1.1 servers"
-HOMEPAGE="https://bitbucket.org/nikratio/python-dugong/"
-SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.bz2"
-
-LICENSE="LGPL-2"
-SLOT="0"
-KEYWORDS="~amd64 ~x86"
-IUSE="doc examples test"
-
-DEPEND="dev-python/setuptools[${PYTHON_USEDEP}]
- test? ( dev-python/pytest[${PYTHON_USEDEP}] )"
-
-python_test() {
- py.test -v || die "Tests failed under ${EPYTHON}"
-}
-
-python_install_all() {
- use doc && local HTML_DOCS=( doc/html/. )
- use examples && local EXAMPLES=( examples/. )
- distutils-r1_python_install_all
-}
diff --git a/dev-python/dugong/dugong-3.1.ebuild b/dev-python/dugong/dugong-3.1.ebuild
deleted file mode 100644
index 1af302fecd4e..000000000000
--- a/dev-python/dugong/dugong-3.1.ebuild
+++ /dev/null
@@ -1,32 +0,0 @@
-# Copyright 1999-2014 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/dugong/dugong-3.1.ebuild,v 1.2 2014/08/06 06:05:59 idella4 Exp $
-
-EAPI=5
-PYTHON_COMPAT=( python3_{3,4} )
-
-inherit distutils-r1
-
-DESCRIPTION="Python library for communicating with HTTP 1.1 servers"
-HOMEPAGE="https://bitbucket.org/nikratio/python-dugong/"
-SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.bz2"
-
-LICENSE="LGPL-2"
-SLOT="0"
-KEYWORDS="~amd64 ~x86"
-IUSE="doc examples test"
-
-DEPEND="dev-python/setuptools[${PYTHON_USEDEP}]
- test? ( dev-python/pytest[${PYTHON_USEDEP}] )"
-
-python_test() {
- # This test hangs
- sed -e 's:test_blocking_send:_&:' -i test/test_dugong.py || die
- py.test -v || die "Tests failed under ${EPYTHON}"
-}
-
-python_install_all() {
- use doc && local HTML_DOCS=( doc/html/. )
- use examples && local EXAMPLES=( examples/. )
- distutils-r1_python_install_all
-}