summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorIan Delaney <idella4@gentoo.org>2014-10-10 07:03:23 +0000
committerIan Delaney <idella4@gentoo.org>2014-10-10 07:03:23 +0000
commit7e19b2e6ec66c90210c147cd22ca754a047ef2f4 (patch)
tree95927582531bde72bec81ff34626e286dd6656a1 /dev-python/flask
parentsci-libs/minfx: Version BUmp (diff)
downloadgentoo-2-7e19b2e6ec66c90210c147cd22ca754a047ef2f4.tar.gz
gentoo-2-7e19b2e6ec66c90210c147cd22ca754a047ef2f4.tar.bz2
gentoo-2-7e19b2e6ec66c90210c147cd22ca754a047ef2f4.zip
update ebuilds re test phase; -9999, update test phase with new test runner, tidy install of examples
(Portage version: 2.2.10/cvs/Linux x86_64, signed Manifest commit with key 0xB8072B0D)
Diffstat (limited to 'dev-python/flask')
-rw-r--r--dev-python/flask/ChangeLog7
-rw-r--r--dev-python/flask/flask-0.10.1-r1.ebuild19
-rw-r--r--dev-python/flask/flask-9999.ebuild20
3 files changed, 16 insertions, 30 deletions
diff --git a/dev-python/flask/ChangeLog b/dev-python/flask/ChangeLog
index 82cb9371a87a..4331e8653b8a 100644
--- a/dev-python/flask/ChangeLog
+++ b/dev-python/flask/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for dev-python/flask
# Copyright 1999-2014 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/flask/ChangeLog,v 1.35 2014/09/29 03:30:24 idella4 Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-python/flask/ChangeLog,v 1.36 2014/10/10 07:03:23 idella4 Exp $
+
+ 10 Oct 2014; Ian Delaney <idella4@gentoo.org> flask-0.10.1-r1.ebuild,
+ flask-9999.ebuild:
+ update ebuilds re test phase; -9999, update test phase with new test runner,
+ tidy install of examples
29 Sep 2014; Ian Delaney <idella4@gentoo.org>
+files/flask-0.10.1-sort_json.patch,
diff --git a/dev-python/flask/flask-0.10.1-r1.ebuild b/dev-python/flask/flask-0.10.1-r1.ebuild
index 1268f6555ad2..a39cd904391f 100644
--- a/dev-python/flask/flask-0.10.1-r1.ebuild
+++ b/dev-python/flask/flask-0.10.1-r1.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2014 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/flask/flask-0.10.1-r1.ebuild,v 1.10 2014/09/29 03:30:24 idella4 Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-python/flask/flask-0.10.1-r1.ebuild,v 1.11 2014/10/10 07:03:23 idella4 Exp $
EAPI="5"
PYTHON_COMPAT=( python{2_7,3_3,3_4} pypy )
@@ -16,7 +16,7 @@ HOMEPAGE="https://github.com/mitsuhiko/flask/"
LICENSE="BSD"
SLOT="0"
KEYWORDS="amd64 ~ppc ~ppc64 x86 ~amd64-linux ~x86-linux"
-IUSE="examples test"
+IUSE="examples"
RDEPEND="dev-python/blinker[${PYTHON_USEDEP}]
>=dev-python/itsdangerous-0.21[${PYTHON_USEDEP}]
@@ -33,22 +33,7 @@ PATCHES=( "${FILESDIR}"/${P}-is_package.patch
"${FILESDIR}"/${P}-sort_json.patch
"${FILESDIR}"/${P}-test_appcontext.patch )
-python_prepare_all() {
- # https://github.com/mitsuhiko/flask/issues/837
- sed -e s':test_uninstalled_package_paths:_&:' \
- -i flask/testsuite/config.py || die
-
- distutils-r1_python_prepare_all
-}
-
python_test() {
- # https://github.com/mitsuhiko/flask/issues/837, 1047
- if [[ "${EPYTHON}" == pypy ]]; then
- sed -e s':test_build_error_handler:_&:' \
- -i flask/testsuite/basic.py || die
- sed -e s':test_session_transactions_no_null_sessions:_&:' \
- -i flask/testsuite/testing.py || die
- fi
"${PYTHON}" run-tests.py || die "Testing failed with ${EPYTHON}"
}
diff --git a/dev-python/flask/flask-9999.ebuild b/dev-python/flask/flask-9999.ebuild
index 162611d2993a..808c29e1d95b 100644
--- a/dev-python/flask/flask-9999.ebuild
+++ b/dev-python/flask/flask-9999.ebuild
@@ -1,16 +1,14 @@
# Copyright 1999-2014 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/flask/flask-9999.ebuild,v 1.8 2014/08/11 22:26:08 blueness Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-python/flask/flask-9999.ebuild,v 1.9 2014/10/10 07:03:23 idella4 Exp $
EAPI="5"
PYTHON_COMPAT=( python{2_7,3_3,3_4} )
-inherit distutils-r1
-#if LIVE
-inherit git-2
+inherit distutils-r1 git-2
+
EGIT_REPO_URI="git://github.com/mitsuhiko/flask.git
https://github.com/mitsuhiko/flask.git"
-#endif
DESCRIPTION="A microframework based on Werkzeug, Jinja2 and good intentions"
MY_PN="Flask"
@@ -28,7 +26,8 @@ RDEPEND="dev-python/blinker[${PYTHON_USEDEP}]
>=dev-python/jinja-2.4[${PYTHON_USEDEP}]
dev-python/setuptools[${PYTHON_USEDEP}]
>=dev-python/werkzeug-0.7[${PYTHON_USEDEP}]"
-DEPEND="${RDEPEND}"
+DEPEND="${RDEPEND}
+ test? ( dev-python/pytest[${PYTHON_USEDEP}] )"
S="${WORKDIR}/${MY_P}"
#if LIVE
@@ -37,13 +36,10 @@ KEYWORDS=
#endif
python_test() {
- "${PYTHON}" run-tests.py || die "Testing failed with ${EPYTHON}"
+ py.test tests || die "Testing failed with ${EPYTHON}"
}
python_install_all() {
- if use examples; then
- insinto /usr/share/doc/${PF}
- doins -r examples
- docompress -x /usr/share/doc/${PF}/examples
- fi
+ use examples && local EXAMPLES=( examples/. )
+ distutils-r1_python_install_all
}