summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorArfrever Frehtes Taifersar Arahesis <arfrever@gentoo.org>2010-06-18 18:55:19 +0000
committerArfrever Frehtes Taifersar Arahesis <arfrever@gentoo.org>2010-06-18 18:55:19 +0000
commit850df286c62c57b76487df0bbcf1404aff238131 (patch)
treed01e29130ca8d5865f8035f0c2a4eea784159ccc /dev-python/flask
parentstable amd64, security bug 280613 (diff)
downloadgentoo-2-850df286c62c57b76487df0bbcf1404aff238131.tar.gz
gentoo-2-850df286c62c57b76487df0bbcf1404aff238131.tar.bz2
gentoo-2-850df286c62c57b76487df0bbcf1404aff238131.zip
Version bump.
(Portage version: HEAD/cvs/Linux x86_64)
Diffstat (limited to 'dev-python/flask')
-rw-r--r--dev-python/flask/ChangeLog8
-rw-r--r--dev-python/flask/flask-0.4.ebuild63
2 files changed, 70 insertions, 1 deletions
diff --git a/dev-python/flask/ChangeLog b/dev-python/flask/ChangeLog
index 964d123693e5..a1ccdd93c349 100644
--- a/dev-python/flask/ChangeLog
+++ b/dev-python/flask/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for dev-python/flask
# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/flask/ChangeLog,v 1.1 2010/05/30 11:00:08 djc Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-python/flask/ChangeLog,v 1.2 2010/06/18 18:55:19 arfrever Exp $
+
+*flask-0.4 (18 Jun 2010)
+
+ 18 Jun 2010; Arfrever Frehtes Taifersar Arahesis <arfrever@gentoo.org>
+ -flask-0.3.1.ebuild, +flask-0.4.ebuild:
+ Version bump.
*flask-0.3.1 (30 May 2010)
diff --git a/dev-python/flask/flask-0.4.ebuild b/dev-python/flask/flask-0.4.ebuild
new file mode 100644
index 000000000000..1c6727729523
--- /dev/null
+++ b/dev-python/flask/flask-0.4.ebuild
@@ -0,0 +1,63 @@
+# Copyright 1999-2010 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-python/flask/flask-0.4.ebuild,v 1.1 2010/06/18 18:55:19 arfrever Exp $
+
+EAPI="3"
+PYTHON_DEPEND="2"
+SUPPORT_PYTHON_ABIS="1"
+RESTRICT_PYTHON_ABIS="3.*"
+
+inherit distutils
+
+MY_PN="Flask"
+MY_P="${MY_PN}-${PV}"
+
+DESCRIPTION="A microframework based on Werkzeug, Jinja2 and good intentions"
+HOMEPAGE="http://pypi.python.org/pypi/Flask"
+SRC_URI="http://pypi.python.org/packages/source/${MY_PN:0:1}/${MY_PN}/${MY_P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="doc examples test"
+
+RDEPEND=">=dev-python/jinja-2.4
+ dev-python/setuptools
+ >=dev-python/werkzeug-0.6.1"
+DEPEND="${RDEPEND}
+ doc? ( >=dev-python/sphinx-0.6 )"
+
+S="${WORKDIR}/${MY_P}"
+
+PYTHON_MODNAME="flask.py"
+
+src_compile() {
+ distutils_src_compile
+
+ if use doc; then
+ einfo "Generation of documentation"
+ cd docs
+ PYTHONPATH=".." emake html || die "Generation of documentation failed"
+ fi
+}
+
+src_test() {
+ testing() {
+ PYTHONPATH=. "$(PYTHON)" tests/flask_tests.py
+ }
+ python_execute_function testing
+}
+
+src_install() {
+ distutils_src_install
+# python_clean_installation_image
+
+ if use doc; then
+ dohtml -r docs/_build/html/* || die "Installation of documentation failed"
+ fi
+
+ if use examples; then
+ insinto "/usr/share/doc/${PF}"
+ doins -r examples || die "Installation of examples failed"
+ fi
+}