summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPatrick Lauer <patrick@gentoo.org>2009-08-17 14:53:32 +0000
committerPatrick Lauer <patrick@gentoo.org>2009-08-17 14:53:32 +0000
commit08d5f15d7ae26d65bfeff5b09621fe7086d1c0b5 (patch)
tree518dacda9b6f833ce1fb8ede678723953de9d834 /dev-python/ipython
parentPull in Python 2.4 or older wrt #257545. (diff)
downloadgentoo-2-08d5f15d7ae26d65bfeff5b09621fe7086d1c0b5.tar.gz
gentoo-2-08d5f15d7ae26d65bfeff5b09621fe7086d1c0b5.tar.bz2
gentoo-2-08d5f15d7ae26d65bfeff5b09621fe7086d1c0b5.zip
Bump to 0.10, fixes #281032
(Portage version: 2.2_rc38/cvs/Linux x86_64)
Diffstat (limited to 'dev-python/ipython')
-rw-r--r--dev-python/ipython/ChangeLog7
-rw-r--r--dev-python/ipython/ipython-0.10.ebuild99
2 files changed, 105 insertions, 1 deletions
diff --git a/dev-python/ipython/ChangeLog b/dev-python/ipython/ChangeLog
index 258c7d9418c2..2ae71f7ef6a6 100644
--- a/dev-python/ipython/ChangeLog
+++ b/dev-python/ipython/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for dev-python/ipython
# Copyright 1999-2009 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/ipython/ChangeLog,v 1.63 2009/08/01 12:18:05 bicatali Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-python/ipython/ChangeLog,v 1.64 2009/08/17 14:53:32 patrick Exp $
+
+*ipython-0.10 (17 Aug 2009)
+
+ 17 Aug 2009; Patrick Lauer <patrick@gentoo.org> +ipython-0.10.ebuild:
+ Bump to 0.10, fixes #281032
01 Aug 2009; Sébastien Fabbro <bicatali@gentoo.org> ipython-0.9.1.ebuild:
Changed wxwindows to wxwidgets use flag
diff --git a/dev-python/ipython/ipython-0.10.ebuild b/dev-python/ipython/ipython-0.10.ebuild
new file mode 100644
index 000000000000..40a35d42746f
--- /dev/null
+++ b/dev-python/ipython/ipython-0.10.ebuild
@@ -0,0 +1,99 @@
+# Copyright 1999-2009 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-python/ipython/ipython-0.10.ebuild,v 1.1 2009/08/17 14:53:32 patrick Exp $
+
+NEED_PYTHON=2.4
+
+inherit distutils elisp-common
+
+DESCRIPTION="An advanced interactive shell for Python."
+HOMEPAGE="http://ipython.scipy.org/"
+SRC_URI="http://ipython.scipy.org/dist/${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~ia64 ~ppc ~ppc64 ~s390 ~x86"
+IUSE="doc emacs examples gnuplot readline smp test wxwidgets"
+
+CDEPEND="dev-python/pexpect
+ wxwidgets? ( dev-python/wxpython )
+ readline? ( sys-libs/readline )
+ emacs? ( app-emacs/python-mode virtual/emacs )
+ smp? ( net-zope/zopeinterface
+ dev-python/foolscap
+ dev-python/pyopenssl )"
+RDEPEND="${CDEPEND}
+ gnuplot? ( dev-python/gnuplot-py )"
+DEPEND="${CDEPEND}
+ test? ( dev-python/nose )"
+
+PYTHON_MODNAME="IPython"
+SITEFILE="62ipython-gentoo.el"
+
+src_unpack() {
+ unpack ${A}
+ cd "${S}"
+ epatch "${FILESDIR}"/${PN}-0.9.1-globalpath.patch
+
+ sed -i \
+ -e '/examfiles)/d' \
+ -e '/manfiles)/d' \
+ -e '/manstatic)/d' \
+ -e 's/^docfiles.*/docfiles=""/' \
+ setup.py || die "sed failed"
+}
+
+src_compile() {
+ distutils_src_compile
+ if use emacs ; then
+ elisp-compile docs/emacs/ipython.el || die "elisp-compile failed"
+ fi
+}
+
+src_test() {
+ "${python}" setup.py \
+ install --home="${WORKDIR}/test" > /dev/null \
+ || die "fake install for testing failed"
+ cd "${WORKDIR}"/test
+ # first initialize .ipython stuff
+ PATH="${WORKDIR}/test/bin:${PATH}" \
+ PYTHONPATH="${WORKDIR}/test/lib/python" ipython > /dev/null <<-EOF
+ EOF
+ # test ( -v for more verbosity)
+ PATH="${WORKDIR}/test/bin:${PATH}" \
+ PYTHONPATH="${WORKDIR}/test/lib/python" iptest || die "test failed"
+}
+
+src_install() {
+ DOCS="docs/source/changes.txt"
+ distutils_src_install
+
+ cd docs
+ insinto "/usr/share/doc/${PF}"
+
+ if use doc; then
+ doins -r dist/* || die "doc install failed"
+ doins "${S}"/IPython/Extensions/igrid_help* || die
+ fi
+
+ if use examples ; then
+ doins -r examples || die "examples install failed"
+ fi
+
+ if use emacs ; then
+ pushd emacs
+ elisp-install ${PN} ${PN}.el* || die "elisp-install failed"
+ elisp-site-file-install "${FILESDIR}/${SITEFILE}"
+ popd
+ fi
+}
+
+pkg_postinst() {
+ distutils_pkg_postinst
+ use emacs && elisp-site-regen
+}
+
+pkg_postrm() {
+ distutils_pkg_postrm
+ use emacs && elisp-site-regen
+}