summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorIan Delaney <idella4@gentoo.org>2014-12-18 12:54:02 +0000
committerIan Delaney <idella4@gentoo.org>2014-12-18 12:54:02 +0000
commit4bb7fa7c02cb471d430c5e8093dd8996467d9195 (patch)
tree5bf80b7ba52f556bf57f437ce18ba4ed063ad382 /dev-python/matplotlib
parentadd support for glusterfs, bug #532632 (diff)
downloadgentoo-2-4bb7fa7c02cb471d430c5e8093dd8996467d9195.tar.gz
gentoo-2-4bb7fa7c02cb471d430c5e8093dd8996467d9195.tar.bz2
gentoo-2-4bb7fa7c02cb471d430c5e8093dd8996467d9195.zip
remove some old
(Portage version: 2.2.14/cvs/Linux x86_64, signed Manifest commit with key 0xB8072B0D)
Diffstat (limited to 'dev-python/matplotlib')
-rw-r--r--dev-python/matplotlib/ChangeLog6
-rw-r--r--dev-python/matplotlib/matplotlib-1.2.0-r2.ebuild203
-rw-r--r--dev-python/matplotlib/matplotlib-1.2.1.ebuild201
-rw-r--r--dev-python/matplotlib/matplotlib-1.3.1.ebuild239
4 files changed, 5 insertions, 644 deletions
diff --git a/dev-python/matplotlib/ChangeLog b/dev-python/matplotlib/ChangeLog
index 4481fd7a5f4f..717af8d64de3 100644
--- a/dev-python/matplotlib/ChangeLog
+++ b/dev-python/matplotlib/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for dev-python/matplotlib
# Copyright 1999-2014 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/matplotlib/ChangeLog,v 1.175 2014/12/05 05:08:01 heroxbd Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-python/matplotlib/ChangeLog,v 1.176 2014/12/18 12:54:02 idella4 Exp $
+
+ 18 Dec 2014; Ian Delaney <idella4@gentoo.org> -matplotlib-1.2.0-r2.ebuild,
+ -matplotlib-1.2.1.ebuild, -matplotlib-1.3.1.ebuild:
+ remove some old
05 Dec 2014; Benda Xu <heroxbd@gentoo.org> matplotlib-1.4.2.ebuild:
Tune dependencies of matplotlib-1.4.2: according to INSTALL in the tarball, it
diff --git a/dev-python/matplotlib/matplotlib-1.2.0-r2.ebuild b/dev-python/matplotlib/matplotlib-1.2.0-r2.ebuild
deleted file mode 100644
index b4a406c768b9..000000000000
--- a/dev-python/matplotlib/matplotlib-1.2.0-r2.ebuild
+++ /dev/null
@@ -1,203 +0,0 @@
-# Copyright 1999-2014 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/matplotlib/matplotlib-1.2.0-r2.ebuild,v 1.16 2014/11/23 16:36:23 floppym Exp $
-
-EAPI=5
-
-PYTHON_COMPAT=( python{2_7,3_2,3_3} )
-PYTHON_REQ_USE='tk?'
-
-inherit distutils-r1 eutils flag-o-matic
-
-DESCRIPTION="Pure python plotting library with matlab like syntax"
-HOMEPAGE="http://matplotlib.org/ http://pypi.python.org/pypi/matplotlib"
-SRC_URI="mirror://github/${PN}/${PN}/${P}.tar.gz"
-
-IUSE="cairo doc excel examples fltk gtk gtk3 latex qt4 test tk wxwidgets"
-SLOT="0"
-KEYWORDS="~amd64 ~arm ~ppc ~ppc64 ~x86 ~x86-freebsd ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos"
-
-# Main license: matplotlib
-# Some modules: BSD
-# matplotlib/backends/qt4_editor: MIT
-# Fonts: BitstreamVera, OFL-1.1
-LICENSE="BitstreamVera BSD matplotlib MIT OFL-1.1"
-
-# #456704 -- a lot of py2-only deps
-PY2_USEDEP=$(python_gen_usedep 'python2*')
-COMMON_DEPEND="dev-python/numpy[${PYTHON_USEDEP}]
- dev-python/python-dateutil[${PYTHON_USEDEP}]
- dev-python/pytz[${PYTHON_USEDEP}]
- dev-python/six[${PYTHON_USEDEP}]
- media-fonts/stix-fonts
- media-libs/freetype:2
- media-libs/libpng
- gtk? ( dev-python/pygtk[${PY2_USEDEP}] )
- wxwidgets? ( dev-python/wxpython:2.8[${PY2_USEDEP}] )"
-
-# internal copy of pycxx highly patched
-# dev-python/pycxx
-
-DEPEND="${COMMON_DEPEND}
- virtual/pkgconfig
- doc? (
- app-text/dvipng
- virtual/python-imaging[${PYTHON_USEDEP}]
- dev-python/ipython
- dev-python/xlwt[${PY2_USEDEP}]
- dev-python/sphinx[${PYTHON_USEDEP}]
- dev-texlive/texlive-latexextra
- dev-texlive/texlive-fontsrecommended
- dev-texlive/texlive-latexrecommended
- media-gfx/graphviz[cairo]
- )
- test? ( dev-python/nose[${PYTHON_USEDEP}] )"
-
-RDEPEND="${COMMON_DEPEND}
- dev-python/pyparsing[${PYTHON_USEDEP}]
- cairo? ( dev-python/pycairo[${PYTHON_USEDEP}] )
- excel? ( dev-python/xlwt[${PY2_USEDEP}] )
- fltk? ( dev-python/pyfltk[${PY2_USEDEP}] )
- gtk3? ( dev-python/pygobject:3[${PYTHON_USEDEP}]
- x11-libs/gtk+:3[introspection] )
- latex? (
- virtual/latex-base
- app-text/ghostscript-gpl
- app-text/dvipng
- app-text/poppler[utils]
- dev-texlive/texlive-fontsrecommended
- )
- qt4? ( || ( dev-python/PyQt4[X,${PYTHON_USEDEP}] dev-python/pyside[X,${PYTHON_USEDEP}] ) )"
-
-PY2_FLAGS="|| ( $(python_gen_useflags python2*) )"
-REQUIRED_USE="doc? ( ${PY2_FLAGS} )
- excel? ( ${PY2_FLAGS} )
- fltk? ( ${PY2_FLAGS} )
- gtk? ( ${PY2_FLAGS} )
- wxwidgets? ( ${PY2_FLAGS} )"
-
-RESTRICT="mirror"
-
-# A few C++ source files are written to srcdir.
-# Other than that, the ebuild shall be fit for out-of-source build.
-DISTUTILS_IN_SOURCE_BUILD=1
-
-use_setup() {
- local uword="${2:-${1}}"
- if use ${1}; then
- echo "${uword} = True"
- echo "${uword}agg = True"
- else
- echo "${uword} = False"
- echo "${uword}agg = False"
- fi
-}
-
-python_prepare_all() {
- # remove internal copies of pyparsing
- rm lib/matplotlib/pyparsing{_py2,_py3}.py || die
-
- sed -i -e 's/matplotlib.pyparsing_py[23]/pyparsing/g' \
- lib/matplotlib/{mathtext,fontconfig_pattern}.py \
- || die "sed pyparsing failed"
-
- local PATCHES=(
- # avoid checks needing a X display
- "${FILESDIR}"/${P}-setup.patch
-
- # Fix test, issue no. 1532
- "${FILESDIR}"/${P}-ft-refcount.patch
- )
-
- distutils-r1_python_prepare_all
-}
-
-python_configure_all() {
- append-flags -fno-strict-aliasing
-}
-
-python_configure() {
- mkdir -p "${BUILD_DIR}" || die
-
- # create setup.cfg (see setup.cfg.template for any changes).
-
- # common switches.
- cat > "${BUILD_DIR}"/setup.cfg <<-EOF || die
- [provide_packages]
- pytz = False
- dateutil = False
- [gui_support]
- $(use_setup cairo)
- $(use_setup qt4)
- $(use_setup tk)
- EOF
-
- if [[ ${EPYTHON} == python3* ]]; then
- cat >> "${BUILD_DIR}"/setup.cfg <<-EOF || die
- six = True
- fltk = False
- fltkagg = False
- gtk = False
- gtkagg = False
- wx = False
- wxagg = False
- EOF
- else
- cat >> "${BUILD_DIR}"/setup.cfg <<-EOF || die
- six = False
- $(use_setup fltk)
- $(use_setup gtk)
- $(use_setup wxwidgets wx)
- EOF
- fi
-}
-
-wrap_setup() {
- local MPLSETUPCFG=${BUILD_DIR}/setup.cfg
- export MPLSETUPCFG
-
- # Note: remove build... if switching to out-of-source build
- "${@}" build --build-lib="${BUILD_DIR}"/build/lib
-}
-
-python_compile() {
- wrap_setup distutils-r1_python_compile
-}
-
-python_compile_all() {
- if use doc; then
- cd doc || die
-
- # necessary for in-source build
- local -x PYTHONPATH="${BUILD_DIR}"/build/lib:${PYTHONPATH}
-
- unset DISPLAY # bug #278524
- VARTEXFONTS="${T}"/fonts \
- "${PYTHON}" ./make.py --small html || die
- fi
-}
-
-python_test() {
- wrap_setup distutils_install_for_testing
-
- cd "${TMPDIR}" || die
- "${PYTHON}" -c "
-import sys, matplotlib as m
-sys.exit(0 if m.test(verbosity=2) else 1)
-" || die "Tests fail with ${EPYTHON}"
-}
-
-python_install() {
- wrap_setup distutils-r1_python_install
-}
-
-python_install_all() {
- use doc && local HTML_DOCS=( doc/build/html/. )
-
- distutils-r1_python_install_all
-
- if use examples; then
- dodoc -r examples
- docompress -x /usr/share/doc/${PF}/examples
- fi
-}
diff --git a/dev-python/matplotlib/matplotlib-1.2.1.ebuild b/dev-python/matplotlib/matplotlib-1.2.1.ebuild
deleted file mode 100644
index 7c565fbc9fe0..000000000000
--- a/dev-python/matplotlib/matplotlib-1.2.1.ebuild
+++ /dev/null
@@ -1,201 +0,0 @@
-# Copyright 1999-2014 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/matplotlib/matplotlib-1.2.1.ebuild,v 1.8 2014/11/23 16:36:23 floppym Exp $
-
-EAPI=5
-
-PYTHON_COMPAT=( python{2_7,3_2,3_3} )
-PYTHON_REQ_USE='tk?'
-
-inherit distutils-r1 eutils flag-o-matic
-
-DESCRIPTION="Pure python plotting library with matlab like syntax"
-HOMEPAGE="http://matplotlib.org/"
-SRC_URI="mirror://sourceforge/${PN}/${P}.tar.gz"
-
-IUSE="cairo doc excel examples fltk gtk gtk3 latex qt4 test tk wxwidgets"
-SLOT="0"
-KEYWORDS="~amd64 ~arm ~ppc ~ppc64 ~x86 ~x86-freebsd ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos"
-
-# Main license: matplotlib
-# Some modules: BSD
-# matplotlib/backends/qt4_editor: MIT
-# Fonts: BitstreamVera, OFL-1.1
-LICENSE="BitstreamVera BSD matplotlib MIT OFL-1.1"
-
-# #456704 -- a lot of py2-only deps
-PY2_USEDEP=$(python_gen_usedep 'python2*')
-COMMON_DEPEND="
- dev-python/numpy[${PYTHON_USEDEP}]
- dev-python/python-dateutil[${PYTHON_USEDEP}]
- dev-python/pytz[${PYTHON_USEDEP}]
- dev-python/six[${PYTHON_USEDEP}]
- media-fonts/stix-fonts
- media-libs/freetype:2
- media-libs/libpng
- gtk? ( dev-python/pygtk[${PY2_USEDEP}] )
- wxwidgets? ( dev-python/wxpython:2.8[${PY2_USEDEP}] )"
-
-# internal copy of pycxx highly patched
-# dev-python/pycxx
-
-DEPEND="${COMMON_DEPEND}
- virtual/pkgconfig
- doc? (
- app-text/dvipng
- virtual/python-imaging[${PYTHON_USEDEP}]
- dev-python/ipython
- dev-python/xlwt[${PY2_USEDEP}]
- dev-python/sphinx[${PYTHON_USEDEP}]
- dev-texlive/texlive-latexextra
- dev-texlive/texlive-fontsrecommended
- dev-texlive/texlive-latexrecommended
- media-gfx/graphviz[cairo]
- )
- test? ( dev-python/nose[${PYTHON_USEDEP}] )"
-
-RDEPEND="${COMMON_DEPEND}
- dev-python/pyparsing[${PYTHON_USEDEP}]
- cairo? ( dev-python/pycairo[${PYTHON_USEDEP}] )
- excel? ( dev-python/xlwt[${PY2_USEDEP}] )
- fltk? ( dev-python/pyfltk[${PY2_USEDEP}] )
- gtk3? ( dev-python/pygobject:3[${PYTHON_USEDEP}]
- x11-libs/gtk+:3[introspection] )
- latex? (
- virtual/latex-base
- app-text/ghostscript-gpl
- app-text/dvipng
- app-text/poppler[utils]
- dev-texlive/texlive-fontsrecommended
- )
- qt4? ( || ( dev-python/PyQt4[X,${PYTHON_USEDEP}] dev-python/pyside[X,${PYTHON_USEDEP}] ) )"
-
-PY2_FLAGS="|| ( $(python_gen_useflags python2*) )"
-REQUIRED_USE="doc? ( ${PY2_FLAGS} )
- excel? ( ${PY2_FLAGS} )
- fltk? ( ${PY2_FLAGS} )
- gtk? ( ${PY2_FLAGS} )
- wxwidgets? ( ${PY2_FLAGS} )"
-
-RESTRICT="mirror"
-
-# A few C++ source files are written to srcdir.
-# Other than that, the ebuild shall be fit for out-of-source build.
-DISTUTILS_IN_SOURCE_BUILD=1
-
-use_setup() {
- local uword="${2:-${1}}"
- if use ${1}; then
- echo "${uword} = True"
- echo "${uword}agg = True"
- else
- echo "${uword} = False"
- echo "${uword}agg = False"
- fi
-}
-
-python_prepare_all() {
- # remove internal copies of pyparsing
- rm lib/matplotlib/pyparsing{_py2,_py3}.py || die
-
- sed -i -e 's/matplotlib.pyparsing_py[23]/pyparsing/g' \
- lib/matplotlib/{mathtext,fontconfig_pattern}.py \
- || die "sed pyparsing failed"
-
- local PATCHES=(
- # avoid checks needing a X display
- "${FILESDIR}"/${PN}-1.2.0-setup.patch
- )
-
- distutils-r1_python_prepare_all
-}
-
-python_configure_all() {
- append-flags -fno-strict-aliasing
-}
-
-python_configure() {
- mkdir -p "${BUILD_DIR}" || die
-
- # create setup.cfg (see setup.cfg.template for any changes).
-
- # common switches.
- cat > "${BUILD_DIR}"/setup.cfg <<-EOF || die
- [provide_packages]
- pytz = False
- dateutil = False
- [gui_support]
- $(use_setup cairo)
- $(use_setup qt4)
- $(use_setup tk)
- EOF
-
- if [[ ${EPYTHON} == python3* ]]; then
- cat >> "${BUILD_DIR}"/setup.cfg <<-EOF || die
- six = True
- fltk = False
- fltkagg = False
- gtk = False
- gtkagg = False
- wx = False
- wxagg = False
- EOF
- else
- cat >> "${BUILD_DIR}"/setup.cfg <<-EOF || die
- six = False
- $(use_setup fltk)
- $(use_setup gtk)
- $(use_setup wxwidgets wx)
- EOF
- fi
-}
-
-wrap_setup() {
- local MPLSETUPCFG=${BUILD_DIR}/setup.cfg
- export MPLSETUPCFG
-
- # Note: remove build... if switching to out-of-source build
- "${@}" build --build-lib="${BUILD_DIR}"/build/lib
-}
-
-python_compile() {
- wrap_setup distutils-r1_python_compile
-}
-
-python_compile_all() {
- if use doc; then
- cd doc || die
-
- # necessary for in-source build
- local -x PYTHONPATH="${BUILD_DIR}"/build/lib:${PYTHONPATH}
-
- unset DISPLAY # bug #278524
- VARTEXFONTS="${T}"/fonts \
- "${PYTHON}" ./make.py --small html || die
- fi
-}
-
-python_test() {
- wrap_setup distutils_install_for_testing
-
- cd "${TMPDIR}" || die
- "${PYTHON}" -c "
-import sys, matplotlib as m
-sys.exit(0 if m.test(verbosity=2) else 1)
-" || die "Tests fail with ${EPYTHON}"
-}
-
-python_install() {
- wrap_setup distutils-r1_python_install
-}
-
-python_install_all() {
- use doc && local HTML_DOCS=( doc/build/html/. )
-
- distutils-r1_python_install_all
-
- if use examples; then
- dodoc -r examples
- docompress -x /usr/share/doc/${PF}/examples
- fi
-}
diff --git a/dev-python/matplotlib/matplotlib-1.3.1.ebuild b/dev-python/matplotlib/matplotlib-1.3.1.ebuild
deleted file mode 100644
index 1ec6db2a3fac..000000000000
--- a/dev-python/matplotlib/matplotlib-1.3.1.ebuild
+++ /dev/null
@@ -1,239 +0,0 @@
-# Copyright 1999-2014 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/matplotlib/matplotlib-1.3.1.ebuild,v 1.7 2014/11/23 16:36:23 floppym Exp $
-
-EAPI=5
-
-PYTHON_COMPAT=( python{2_7,3_2,3_3,3_4} )
-
-PYTHON_REQ_USE='tk?'
-
-VIRTUALX_REQUIRED="always"
-
-inherit distutils-r1 eutils flag-o-matic virtualx
-
-DESCRIPTION="Pure python plotting library with matlab like syntax"
-HOMEPAGE="http://matplotlib.org/"
-SRC_URI="mirror://sourceforge/${PN}/${P}.tar.gz"
-
-SLOT="0"
-# Main license: matplotlib
-# Some modules: BSD
-# matplotlib/backends/qt4_editor: MIT
-# Fonts: BitstreamVera, OFL-1.1
-LICENSE="BitstreamVera BSD matplotlib MIT OFL-1.1"
-KEYWORDS="~amd64 ~arm ~ppc ~ppc64 ~x86 ~x86-freebsd ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos"
-IUSE="cairo doc excel examples fltk gtk gtk3 latex pyside qt4 test tk wxwidgets"
-
-# #456704 -- a lot of py2-only deps
-PY2_USEDEP=$(python_gen_usedep 'python2*')
-COMMON_DEPEND="
- dev-python/numpy[${PYTHON_USEDEP}]
- dev-python/python-dateutil:0[${PYTHON_USEDEP}]
- dev-python/pytz[${PYTHON_USEDEP}]
- dev-python/six[${PYTHON_USEDEP}]
- media-fonts/stix-fonts
- media-libs/freetype:2
- media-libs/libpng:0
- gtk? ( x11-libs/gtk+:2
- dev-libs/glib
- x11-libs/gdk-pixbuf
- dev-python/pygtk[${PY2_USEDEP}] )
- wxwidgets? ( >=dev-python/wxpython-2.8[${PY2_USEDEP}] )"
-
-# internal copy of pycxx highly patched
-# dev-python/pycxx
-
-DEPEND="${COMMON_DEPEND}
- virtual/pkgconfig
- doc? (
- app-text/dvipng
- virtual/python-imaging[${PYTHON_USEDEP}]
- dev-python/ipython[${PYTHON_USEDEP}]
- dev-python/numpydoc[${PY2_USEDEP}]
- dev-python/xlwt[${PY2_USEDEP}]
- dev-python/sphinx[${PYTHON_USEDEP}]
- dev-texlive/texlive-latexextra
- dev-texlive/texlive-fontsrecommended
- dev-texlive/texlive-latexrecommended
- media-gfx/graphviz[cairo]
- )
- test? ( dev-python/nose[${PYTHON_USEDEP}] )"
-
-RDEPEND="${COMMON_DEPEND}
- dev-python/pyparsing[${PYTHON_USEDEP}]
- cairo? ( dev-python/pycairo[${PYTHON_USEDEP}] )
- excel? ( dev-python/xlwt[${PY2_USEDEP}] )
- fltk? ( dev-python/pyfltk[${PY2_USEDEP}] )
- gtk3? (
- dev-python/pygobject:3[${PYTHON_USEDEP}]
- x11-libs/gtk+:3[introspection] )
- latex? (
- virtual/latex-base
- app-text/ghostscript-gpl
- app-text/dvipng
- app-text/poppler[utils]
- dev-texlive/texlive-fontsrecommended
- dev-texlive/texlive-latexextra
- dev-texlive/texlive-xetex
- )
- pyside? ( dev-python/pyside[X,${PYTHON_USEDEP}] )
- qt4? ( dev-python/PyQt4[X,${PYTHON_USEDEP}] )"
-
-PY2_FLAGS="|| ( $(python_gen_useflags python2*) )"
-REQUIRED_USE="
- doc? ( ${PY2_FLAGS} )
- excel? ( ${PY2_FLAGS} )
- fltk? ( ${PY2_FLAGS} )
- gtk? ( ${PY2_FLAGS} )
- wxwidgets? ( ${PY2_FLAGS} )
- test? (
- cairo fltk latex pyside qt4 tk wxwidgets
- || ( gtk gtk3 )
- )"
-
-RESTRICT="mirror"
-
-# A few C++ source files are written to srcdir.
-# Other than that, the ebuild shall be fit for out-of-source build.
-DISTUTILS_IN_SOURCE_BUILD=1
-
-use_setup() {
- local uword="${2:-${1}}"
- if use ${1}; then
- echo "${uword} = True"
- echo "${uword}agg = True"
- else
- echo "${uword} = False"
- echo "${uword}agg = False"
- fi
-}
-
-python_prepare_all() {
-# Generates test failures, but fedora does it
-# local PATCHES=(
-# "${FILESDIR}"/${P}-unbundle-pycxx.patch
-# "${FILESDIR}"/${P}-unbundle-agg.patch
-# )
-# rm -r agg24 CXX || die
-# rm -r agg24 || die
-
- sed \
- -e 's/matplotlib.pyparsing_py[23]/pyparsing/g' \
- -i lib/matplotlib/{mathtext,fontconfig_pattern}.py \
- || die "sed pyparsing failed"
-
- # suggested by upstream
- sed \
- -e '/tol/s:32:35:g' \
- -i lib/matplotlib/tests/test_mathtext.py || die
-
- if use gtk || use gtk3; then
- export XDG_RUNTIME_DIR="${T}/runtime-dir"
- mkdir "${XDG_RUNTIME_DIR}" || die
- chmod 0700 "${XDG_RUNTIME_DIR}" || die
- fi
-
- distutils-r1_python_prepare_all
-}
-
-python_configure_all() {
- append-flags -fno-strict-aliasing
-}
-
-python_configure() {
- mkdir -p "${BUILD_DIR}" || die
-
- # create setup.cfg (see setup.cfg.template for any changes).
-
- # common switches.
- cat > "${BUILD_DIR}"/setup.cfg <<-EOF
- [directories]
- basedirlist = ${EPREFIX}/usr
- [provide_packages]
- pytz = False
- dateutil = False
- [gui_support]
- agg = True
- $(use_setup cairo)
- $(use_setup pyside)
- $(use_setup qt4)
- $(use_setup tk)
- EOF
-
- if use gtk3 && use cairo; then
- echo "gtk3cairo = True" >> "${BUILD_DIR}"/setup.cfg || die
- else
- echo "gtk3cairo = False" >> "${BUILD_DIR}"/setup.cfg || die
- fi
-
- if $(python_is_python3); then
- cat >> "${BUILD_DIR}"/setup.cfg <<-EOF
- six = True
- fltk = False
- fltkagg = False
- gtk = False
- gtkagg = False
- wx = False
- wxagg = False
- EOF
- else
- cat >> "${BUILD_DIR}"/setup.cfg <<-EOF
- six = False
- $(use_setup fltk)
- $(use_setup gtk)
- $(use_setup gtk3)
- $(use_setup wxwidgets wx)
- EOF
- fi
-}
-
-wrap_setup() {
- local MPLSETUPCFG=${BUILD_DIR}/setup.cfg
- export MPLSETUPCFG
-
- # Note: remove build... if switching to out-of-source build
- "${@}" build --build-lib="${BUILD_DIR}"/build/lib
-}
-
-python_compile() {
- VIRTUALX_COMMAND="wrap_setup distutils-r1_python_compile"
- virtualmake
-}
-
-python_compile_all() {
- if use doc; then
- cd doc || die
-
- # necessary for in-source build
- local -x PYTHONPATH="${BUILD_DIR}"/build/lib:${PYTHONPATH}
-
- unset DISPLAY # bug #278524
- VARTEXFONTS="${T}"/fonts \
- "${PYTHON}" ./make.py --small html || die
- fi
-}
-
-python_test() {
- wrap_setup distutils_install_for_testing
-
- cd "${TMPDIR}" || die
- VIRTUALX_COMMAND="${PYTHON}"
- virtualmake -c "import sys, matplotlib as m; sys.exit(0 if m.test(verbosity=2) else 1)" || \
- die "Tests fail with ${EPYTHON}"
-}
-
-python_install() {
- wrap_setup distutils-r1_python_install
-}
-
-python_install_all() {
- use doc && local HTML_DOCS=( doc/build/html/. )
-
- distutils-r1_python_install_all
-
- if use examples; then
- dodoc -r examples
- docompress -x /usr/share/doc/${PF}/examples
- fi
-}