summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2013-02-21 23:32:50 +0000
committerMichał Górny <mgorny@gentoo.org>2013-02-21 23:32:50 +0000
commitb70a2a17a8bba428947e19a1aa94f56425876b9b (patch)
tree7c094016ff70f401edd6427e624cc4b8a1fd1f5c /dev-python/ply
parentSupport EXAMPLES to install examples in a consistent manner. (diff)
downloadgentoo-2-b70a2a17a8bba428947e19a1aa94f56425876b9b.tar.gz
gentoo-2-b70a2a17a8bba428947e19a1aa94f56425876b9b.tar.bz2
gentoo-2-b70a2a17a8bba428947e19a1aa94f56425876b9b.zip
Migrate to distutils-r1.
(Portage version: 2.2.0_alpha163/cvs/Linux x86_64, signed Manifest commit with key 9627F456F9DA7643!)
Diffstat (limited to 'dev-python/ply')
-rw-r--r--dev-python/ply/ChangeLog9
-rw-r--r--dev-python/ply/ply-3.4-r1.ebuild39
2 files changed, 46 insertions, 2 deletions
diff --git a/dev-python/ply/ChangeLog b/dev-python/ply/ChangeLog
index 2e376c067fcb..2ff0dc28de86 100644
--- a/dev-python/ply/ChangeLog
+++ b/dev-python/ply/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for dev-python/ply
-# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/ply/ChangeLog,v 1.21 2012/12/31 16:33:04 ago Exp $
+# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/dev-python/ply/ChangeLog,v 1.22 2013/02/21 23:32:50 mgorny Exp $
+
+*ply-3.4-r1 (21 Feb 2013)
+
+ 21 Feb 2013; Michał Górny <mgorny@gentoo.org> +ply-3.4-r1.ebuild:
+ Migrate to distutils-r1.
31 Dec 2012; Agostino Sarubbo <ago@gentoo.org> ply-3.4.ebuild:
Add ~ppc64, wrt bug #412329
diff --git a/dev-python/ply/ply-3.4-r1.ebuild b/dev-python/ply/ply-3.4-r1.ebuild
new file mode 100644
index 000000000000..8c73ae454fb3
--- /dev/null
+++ b/dev-python/ply/ply-3.4-r1.ebuild
@@ -0,0 +1,39 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-python/ply/ply-3.4-r1.ebuild,v 1.1 2013/02/21 23:32:50 mgorny Exp $
+
+EAPI=5
+
+PYTHON_COMPAT=( python{2_5,2_6,2_7,3_1,3_2,3_3} pypy{1_9,2_0} )
+
+inherit distutils-r1
+
+DESCRIPTION="Python Lex-Yacc library"
+HOMEPAGE="http://www.dabeaz.com/ply/ http://pypi.python.org/pypi/ply"
+SRC_URI="http://www.dabeaz.com/ply/${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~ia64 ~ppc ~ppc64 ~x86 ~amd64-linux ~x86-linux"
+IUSE="examples"
+
+DEPEND=""
+RDEPEND=""
+
+DOCS=( ANNOUNCE CHANGES README TODO )
+
+python_test() {
+ cp -r -l test "${BUILD_DIR}"/ || die
+ cd "${BUILD_DIR}"/test || die
+
+ local t
+ for t in testlex.py testyacc.py; do
+ "${PYTHON}" "${t}" || die "${t} fails with ${EPYTHON}"
+ done
+}
+
+python_install_all() {
+ local HTML_DOCS=( doc/. )
+ use examples && local EXAMPLES=( example/. )
+ distutils-r1_python_install_all
+}