summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorIan Delaney <idella4@gentoo.org>2014-06-24 15:02:04 +0000
committerIan Delaney <idella4@gentoo.org>2014-06-24 15:02:04 +0000
commitaf23d650461f389e6251784d0c2144ddbafc9974 (patch)
treed5d89dff8029322bf6b7ac46c85ab1021e74f4f4 /dev-python/plyr
parentVersion bump. (diff)
downloadgentoo-2-af23d650461f389e6251784d0c2144ddbafc9974.tar.gz
gentoo-2-af23d650461f389e6251784d0c2144ddbafc9974.tar.bz2
gentoo-2-af23d650461f389e6251784d0c2144ddbafc9974.zip
bump; update HOMEPAGE, change SRC_URI to src repo and tarball, add IUSE doc, doc build, test phase, ebuild prepared & updated by proxy maintainer
(Portage version: 2.2.10/cvs/Linux x86_64, signed Manifest commit with key 0xB8072B0D)
Diffstat (limited to 'dev-python/plyr')
-rw-r--r--dev-python/plyr/ChangeLog8
-rw-r--r--dev-python/plyr/plyr-1.0.6.ebuild57
2 files changed, 64 insertions, 1 deletions
diff --git a/dev-python/plyr/ChangeLog b/dev-python/plyr/ChangeLog
index 375d03d781f7..f1d1b488885e 100644
--- a/dev-python/plyr/ChangeLog
+++ b/dev-python/plyr/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for dev-python/plyr
# Copyright 1999-2014 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/plyr/ChangeLog,v 1.1 2014/06/22 12:28:01 idella4 Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-python/plyr/ChangeLog,v 1.2 2014/06/24 15:02:04 idella4 Exp $
+
+*plyr-1.0.6 (24 Jun 2014)
+
+ 24 Jun 2014; Ian Delaney <idella4@gentoo.org> +plyr-1.0.6.ebuild:
+ bump; update HOMEPAGE, change SRC_URI to src repo and tarball, add IUSE doc,
+ doc build, test phase, ebuild prepared & updated by proxy maintainer
*plyr-1.0.2 (22 Jun 2014)
diff --git a/dev-python/plyr/plyr-1.0.6.ebuild b/dev-python/plyr/plyr-1.0.6.ebuild
new file mode 100644
index 000000000000..769de48cbedc
--- /dev/null
+++ b/dev-python/plyr/plyr-1.0.6.ebuild
@@ -0,0 +1,57 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-python/plyr/plyr-1.0.6.ebuild,v 1.1 2014/06/24 15:02:04 idella4 Exp $
+
+EAPI="5"
+PYTHON_COMPAT=( python{2_7,3_3,3_4} )
+
+inherit distutils-r1 flag-o-matic
+
+MY_PN="python-glyr"
+MY_P="${MY_PN}-${PV}"
+
+DESCRIPTION="A python wrapper for Glyr"
+HOMEPAGE="http://sahib.github.com/python-glyr/intro.html
+ https://github.com/sahib/python-glyr"
+SRC_URI="https://github.com/sahib/${MY_PN}/archive/${PV}.tar.gz -> ${MY_P}.tar.gz"
+
+LICENSE="GPL-3+"
+KEYWORDS="~amd64"
+SLOT="0"
+IUSE="doc"
+
+RDEPEND="media-libs/glyr"
+DEPEND="${RDEPEND}
+ dev-python/cython[${PYTHON_USEDEP}]
+ dev-python/setuptools[${PYTHON_USEDEP}]
+ doc? ( dev-python/sphinx[${PYTHON_USEDEP}] )"
+
+S="${WORKDIR}/${MY_P}"
+
+python_prepare_all() {
+ # Disable test requiring internet connection
+ sed -e 's:test_download:_&:' -i tests/test_misc.py || die
+}
+
+python_compile() {
+ if ! python_is_python3; then
+ local CFLAGS=${CFLAGS}
+ append-cflags -fno-strict-aliasing
+ fi
+ distutils-r1_python_compile
+}
+
+python_compile_all() {
+ if use doc; then
+ emake -C docs html || die "Generating documentation failed"
+ fi
+}
+
+python_test() {
+ "${PYTHON}" -m unittest discover tests || die "Tests fail with ${EPYTHON}"
+}
+
+python_install_all() {
+ use doc && local HTML_DOCS=( docs/build/html/. )
+ distutils-r1_python_install_all
+}