summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorArfrever Frehtes Taifersar Arahesis <arfrever@gentoo.org>2010-02-07 03:07:41 +0000
committerArfrever Frehtes Taifersar Arahesis <arfrever@gentoo.org>2010-02-07 03:07:41 +0000
commit5eea6e33d649c5b8b9137e839601d534152520a9 (patch)
tree6ffb714ca565b42fa58f0bd04dc8cf4a745036e0 /dev-python/pyqwt
parentVersion bump. Fix dependencies (bug #303317). (diff)
downloadgentoo-2-5eea6e33d649c5b8b9137e839601d534152520a9.tar.gz
gentoo-2-5eea6e33d649c5b8b9137e839601d534152520a9.tar.bz2
gentoo-2-5eea6e33d649c5b8b9137e839601d534152520a9.zip
Set SUPPORT_PYTHON_ABIS. Require >=dev-python/PyQt4-4.6.1 to avoid file collision (bug #303673). Delete unused "debug" USE flag.
(Portage version: 15325-svn/cvs/Linux x86_64)
Diffstat (limited to 'dev-python/pyqwt')
-rw-r--r--dev-python/pyqwt/ChangeLog9
-rw-r--r--dev-python/pyqwt/pyqwt-5.2.0.ebuild47
2 files changed, 33 insertions, 23 deletions
diff --git a/dev-python/pyqwt/ChangeLog b/dev-python/pyqwt/ChangeLog
index 3964e3d84891..b80fbcd85821 100644
--- a/dev-python/pyqwt/ChangeLog
+++ b/dev-python/pyqwt/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for dev-python/pyqwt
-# Copyright 1999-2009 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/pyqwt/ChangeLog,v 1.15 2009/12/28 05:07:28 yngwin Exp $
+# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/dev-python/pyqwt/ChangeLog,v 1.16 2010/02/07 03:07:41 arfrever Exp $
+
+ 07 Feb 2010; Arfrever Frehtes Taifersar Arahesis <arfrever@gentoo.org>
+ pyqwt-5.2.0.ebuild:
+ Set SUPPORT_PYTHON_ABIS. Require >=dev-python/PyQt4-4.6.1 to avoid file
+ collision (bug #303673). Delete unused "debug" USE flag.
*pyqwt-5.2.0 (27 Dec 2009)
diff --git a/dev-python/pyqwt/pyqwt-5.2.0.ebuild b/dev-python/pyqwt/pyqwt-5.2.0.ebuild
index 403e926e93ba..38f2c567eedc 100644
--- a/dev-python/pyqwt/pyqwt-5.2.0.ebuild
+++ b/dev-python/pyqwt/pyqwt-5.2.0.ebuild
@@ -1,10 +1,13 @@
# Copyright 1999-2010 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/pyqwt/pyqwt-5.2.0.ebuild,v 1.3 2010/01/31 07:39:17 ssuominen Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-python/pyqwt/pyqwt-5.2.0.ebuild,v 1.4 2010/02/07 03:07:41 arfrever Exp $
-EAPI=2
+EAPI="2"
+PYTHON_DEPEND="2"
+SUPPORT_PYTHON_ABIS="1"
+PYTHON_DEFINE_DEFAULT_FUNCTIONS="1"
-inherit python flag-o-matic
+inherit flag-o-matic python
MY_P="PyQwt-${PV}"
DESCRIPTION="Python bindings for the Qwt library"
@@ -14,38 +17,40 @@ HOMEPAGE="http://pyqwt.sourceforge.net/"
SLOT="5"
LICENSE="GPL-2"
KEYWORDS="~amd64 ~ia64 ~x86"
-IUSE="debug doc examples svg"
+IUSE="doc examples svg"
RDEPEND=">=x11-libs/qwt-5.1[svg?]
- dev-python/PyQt4
+ >=dev-python/PyQt4-4.6.1
dev-python/numpy"
DEPEND="${DEPEND}
dev-python/sip"
-
-RESTRICT_PYTHON_ABIS="2.4 2.7 3.*"
+RESTRICT_PYTHON_ABIS="3.*"
S="${WORKDIR}/${MY_P}/configure"
+pkg_setup() {
+ append-flags -fPIC
+}
+
src_configure() {
+ configuration() {
+ # '-j' option can be buggy.
+ "$(PYTHON)" configure.py \
+ --disable-numarray \
+ --disable-numeric \
+ -I/usr/include/qwt5 \
+ -lqwt || return 1
- append-flags -fPIC
+ # Avoid stripping of the libraries.
+ sed -i -e "/strip/d" {iqt5qt4,qwt5qt4}/Makefile || die "sed failed"
+ }
+ python_execute_function -s configuration
- # the -j option can be buggy
- python_version
- "${python}" configure.py \
- --disable-numarray \
- --disable-numeric \
- -I/usr/include/qwt5 \
- -lqwt \
- || die "python configure.py failed"
-
- # avoiding strip the libraries
- sed -i -e '/strip/d' {iqt5qt4,qwt5qt4}/Makefile || die "sed failed"
}
src_install() {
- python_need_rebuild
- emake DESTDIR="${D}" install || die "emake install failed"
+ python_src_install
+
cd ..
dodoc ANNOUNCEMENT-${PV} README
if use doc; then