summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAmadeusz Piotr Żołnowski <aidecoe@gentoo.org>2014-03-03 11:01:57 +0000
committerAmadeusz Piotr Żołnowski <aidecoe@gentoo.org>2014-03-03 11:01:57 +0000
commit733901f50afbe00c717f4d80ea275a06b2a56644 (patch)
tree38c3f6b2b8ad52a4452f28b0f49af429b4503ef6 /dev-python/pyro
parentfix IUSE examples usage (diff)
downloadgentoo-2-733901f50afbe00c717f4d80ea275a06b2a56644.tar.gz
gentoo-2-733901f50afbe00c717f4d80ea275a06b2a56644.tar.bz2
gentoo-2-733901f50afbe00c717f4d80ea275a06b2a56644.zip
Version bump. Added python3_4 support.
NEWS ~~~~ - Python 3.4 compatibility added (fixed pickle/marshal issues) - a backwards incompatible change has been implemented regarding the threadpool implementation and configuration, see next two items. - threadpool is now again a fixed size determined by the new THREADPOOL_SIZE config item (defaults to 16) - config items removed: THREADPOOL_MINTHREADS, THREADPOOL_MAXTHREADS, THREADPOOL_IDLETIMEOUT - daemon no longer sends an exception response when a communication error occurred (such as a timeout). This fixes the MSG_PING/disconnect example. (Portage version: 2.2.8-r1/cvs/Linux x86_64, signed Manifest commit with key F0134531E1DBFAB5)
Diffstat (limited to 'dev-python/pyro')
-rw-r--r--dev-python/pyro/ChangeLog19
-rw-r--r--dev-python/pyro/pyro-4.24.ebuild78
2 files changed, 96 insertions, 1 deletions
diff --git a/dev-python/pyro/ChangeLog b/dev-python/pyro/ChangeLog
index a7d38e29c115..c11dfd228111 100644
--- a/dev-python/pyro/ChangeLog
+++ b/dev-python/pyro/ChangeLog
@@ -1,6 +1,23 @@
# ChangeLog for dev-python/pyro
# Copyright 1999-2014 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/pyro/ChangeLog,v 1.101 2014/03/02 23:09:49 pacho Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-python/pyro/ChangeLog,v 1.102 2014/03/03 11:01:57 aidecoe Exp $
+
+*pyro-4.24 (03 Mar 2014)
+
+ 03 Mar 2014; Amadeusz Żołnowski <aidecoe@gentoo.org> +pyro-4.24.ebuild:
+ Version bump. Added python3_4 support.
+
+ NEWS
+ ~~~~
+ - Python 3.4 compatibility added (fixed pickle/marshal issues)
+ - a backwards incompatible change has been implemented regarding the
+ threadpool implementation and configuration, see next two items.
+ - threadpool is now again a fixed size determined by the new THREADPOOL_SIZE
+ config item (defaults to 16)
+ - config items removed: THREADPOOL_MINTHREADS, THREADPOOL_MAXTHREADS,
+ THREADPOOL_IDLETIMEOUT
+ - daemon no longer sends an exception response when a communication error
+ occurred (such as a timeout). This fixes the MSG_PING/disconnect example.
02 Mar 2014; Pacho Ramos <pacho@gentoo.org> pyro-4.23.ebuild:
amd64 stable, bug #502792
diff --git a/dev-python/pyro/pyro-4.24.ebuild b/dev-python/pyro/pyro-4.24.ebuild
new file mode 100644
index 000000000000..dce41ac01423
--- /dev/null
+++ b/dev-python/pyro/pyro-4.24.ebuild
@@ -0,0 +1,78 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-python/pyro/pyro-4.24.ebuild,v 1.1 2014/03/03 11:01:57 aidecoe Exp $
+
+EAPI=5
+
+PYTHON_COMPAT=( python{2_6,2_7,3_2,3_3,3_4} pypy2_0 )
+
+inherit distutils-r1
+
+MY_PN="Pyro4"
+MY_P="${MY_PN}-${PV}"
+
+DESCRIPTION="Advanced and powerful Distributed Object Technology system written entirely in Python"
+HOMEPAGE="http://www.xs4all.nl/~irmen/pyro/ http://pypi.python.org/pypi/Pyro4"
+SRC_URI="mirror://pypi/${MY_PN:0:1}/${MY_PN}/${MY_P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="4"
+KEYWORDS="~amd64 ~ppc ~x86 ~amd64-linux ~x86-linux"
+IUSE="doc examples test"
+
+RDEPEND="!dev-python/pyro:0
+ dev-python/serpent[${PYTHON_USEDEP}]"
+DEPEND="${RDEPEND}
+ dev-python/setuptools[${PYTHON_USEDEP}]
+ test? (
+ dev-python/coverage[${PYTHON_USEDEP}]
+ dev-python/nose[${PYTHON_USEDEP}]
+ virtual/python-unittest2[${PYTHON_USEDEP}]
+ )"
+
+S="${WORKDIR}/${MY_P}"
+DISTUTILS_IN_SOURCE_BUILD=1
+
+python_prepare_all() {
+ sed \
+ -e '/sys.path.insert/a sys.path.insert(1,"PyroTests")' \
+ -i tests/run_suite.py || die
+
+ # Disable tests requiring network connection.
+ sed \
+ -e "s/testBCstart/_&/" \
+ -e "s/testDaemonPyroObj/_&/" \
+ -e "s/testLookupAndRegister/_&/" \
+ -e "s/testMulti/_&/" \
+ -e "s/testRefuseDottedNames/_&/" \
+ -e "s/testResolve/_&/" \
+ -e "s/testBCLookup/_&/" \
+ -i tests/PyroTests/test_naming.py || die
+ sed \
+ -e "s/testOwnloopBasics/_&/" \
+ -e "s/testStartNSfunc/_&/" \
+ -i tests/PyroTests/test_naming2.py || die
+
+ sed \
+ -e "s/testServerConnections/_&/" \
+ -e "s/testServerParallelism/_&/" \
+ -i tests/PyroTests/test_server.py || die
+
+ sed \
+ -e "s/testBroadcast/_&/" \
+ -e "s/testGetIP/_&/" \
+ -e "s/testGetIpVersion[46]/_&/" \
+ -i tests/PyroTests/test_socket.py || die
+ distutils-r1_python_prepare_all
+}
+
+python_test() {
+ cd "${S}"/tests || die
+ ${PYTHON} run_suite.py || die
+}
+
+python_install_all() {
+ use doc && HTML_DOCS=( docs/. )
+ use examples && local EXAMPLES=( examples/. )
+ distutils-r1_python_install_all
+}