summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorIan Delaney <idella4@gentoo.org>2015-01-14 05:37:16 +0000
committerIan Delaney <idella4@gentoo.org>2015-01-14 05:37:16 +0000
commitbfeaefc57bb3404b04281a93ae8c625da116f51e (patch)
tree51f2308bd36338320e89d7c923773e44164c5114 /dev-python/pysvn
parentRevision bump: migrate to python-single-r1 eclass, wrt bug #531620, thanks to... (diff)
downloadgentoo-2-bfeaefc57bb3404b04281a93ae8c625da116f51e.tar.gz
gentoo-2-bfeaefc57bb3404b04281a93ae8c625da116f51e.tar.bz2
gentoo-2-bfeaefc57bb3404b04281a93ae8c625da116f51e.zip
rm disused patches & old versions
(Portage version: 2.2.14/cvs/Linux x86_64, signed Manifest commit with key 0xB8072B0D)
Diffstat (limited to 'dev-python/pysvn')
-rw-r--r--dev-python/pysvn/ChangeLog10
-rw-r--r--dev-python/pysvn/files/pysvn-1.7.6-respect_flags.patch104
-rw-r--r--dev-python/pysvn/files/pysvn-1.7.7-respect_flags.patch95
-rw-r--r--dev-python/pysvn/pysvn-1.7.6.ebuild100
-rw-r--r--dev-python/pysvn/pysvn-1.7.7.ebuild72
-rw-r--r--dev-python/pysvn/pysvn-1.7.8.ebuild66
6 files changed, 8 insertions, 439 deletions
diff --git a/dev-python/pysvn/ChangeLog b/dev-python/pysvn/ChangeLog
index e4bc49130078..51b36326b46e 100644
--- a/dev-python/pysvn/ChangeLog
+++ b/dev-python/pysvn/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for dev-python/pysvn
-# Copyright 1999-2014 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/pysvn/ChangeLog,v 1.44 2014/12/07 12:03:13 ago Exp $
+# Copyright 1999-2015 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/dev-python/pysvn/ChangeLog,v 1.45 2015/01/14 05:37:16 idella4 Exp $
+
+ 14 Jan 2015; Ian Delaney <idella4@gentoo.org>
+ -files/pysvn-1.7.6-respect_flags.patch,
+ -files/pysvn-1.7.7-respect_flags.patch, -pysvn-1.7.6.ebuild,
+ -pysvn-1.7.7.ebuild, -pysvn-1.7.8.ebuild:
+ rm disused patches & old versions
07 Dec 2014; Agostino Sarubbo <ago@gentoo.org> pysvn-1.7.9.ebuild:
Stable for ppc, wrt bug #530576
diff --git a/dev-python/pysvn/files/pysvn-1.7.6-respect_flags.patch b/dev-python/pysvn/files/pysvn-1.7.6-respect_flags.patch
deleted file mode 100644
index 6f7f4e3cd5c3..000000000000
--- a/dev-python/pysvn/files/pysvn-1.7.6-respect_flags.patch
+++ /dev/null
@@ -1,104 +0,0 @@
---- Source/setup_configure.py
-+++ Source/setup_configure.py
-@@ -821,8 +821,8 @@
- def __init__( self, setup ):
- Compiler.__init__( self, setup )
-
-- self._addVar( 'CCC', 'g++' )
-- self._addVar( 'CC', 'gcc' )
-+ self._addVar( 'CCC', '$(CXX)' )
-+ self._addVar( 'CC', '$(CC)' )
-
- def getPythonExtensionFileExt( self ):
- return '.so'
-@@ -864,7 +864,7 @@
-
- rules.append( '%s : %s' % (target_filename, ' '.join( all_objects )) )
- rules.append( '\t@echo Link %s' % (target_filename,) )
-- rules.append( '\t@%%(LDSHARED)s -o %s %%(CCCFLAGS)s %s' % (target_filename, ' '.join( all_objects )) )
-+ rules.append( '\t@%%(LDSHARED)s -o %s %%(CCCFLAGS)s %s %%(LDLIBS)s' % (target_filename, ' '.join( all_objects )) )
-
- self.makePrint( self.expand( '\n'.join( rules ) ) )
-
-@@ -939,8 +939,8 @@
- else:
- arch_options = ''
-
-- self._addVar( 'CCC', 'g++ %s' % (arch_options,) )
-- self._addVar( 'CC', 'gcc %s' % (arch_options,) )
-+ self._addVar( 'CCC', '$(CXX) %s' % (arch_options,) )
-+ self._addVar( 'CC', '$(CC) %s' % (arch_options,) )
-
- self._find_paths_pycxx_dir = [
- '../Import/pycxx-%d.%d.%d' % pycxx_version,
-@@ -1004,12 +1004,12 @@
-
- def setupUtilities( self ):
- self._addVar( 'CCCFLAGS',
-- '-g '
-+ '$(CXXFLAGS) '
- '-no-long-double '
- '-Wall -fPIC -fexceptions -frtti '
- '-I. -I%(APR_INC)s -I%(SVN_INC)s '
- '-D%(DEBUG)s' )
-- self._addVar( 'LDEXE', '%(CCC)s -g' )
-+ self._addVar( 'LDEXE', '$(CXX) $(LDFLAGS)' )
-
- def setupPySvn( self ):
- self._pysvnModuleSetup()
-@@ -1022,7 +1022,7 @@
- self._addVar( 'PYTHON_INC', distutils.sysconfig.get_python_inc() )
-
- py_cflags_list = [
-- '-g',
-+ '$(CXXFLAGS)',
- '-no-long-double',
- '-Wall -fPIC -fexceptions -frtti',
- '-I. -I%(APR_INC)s -I%(SVN_INC)s',
-@@ -1049,13 +1049,12 @@
-
- self._addVar( 'CCCFLAGS', ' '.join( py_cflags_list ) )
- self._addVar( 'LDLIBS', ' '.join( py_ld_libs ) )
-- self._addVar( 'LDSHARED', '%(CCC)s -bundle -g '
-+ self._addVar( 'LDSHARED', '$(CXX) $(LDFLAGS) -bundle '
- '-framework System '
- '%(PYTHON_FRAMEWORK)s '
- '-framework CoreFoundation '
- '-framework Kerberos '
-- '-framework Security '
-- '%(LDLIBS)s' )
-+ '-framework Security' )
-
- class UnixCompilerGCC(CompilerGCC):
- def __init__( self, setup ):
-@@ -1115,11 +1114,11 @@
-
- def setupUtilities( self ):
- self._addVar( 'CCCFLAGS',
-- '-g '
-+ '$(CXXFLAGS) '
- '-Wall -fPIC -fexceptions -frtti '
- '-I. -I%(APR_INC)s -I%(SVN_INC)s '
- '-D%(DEBUG)s' )
-- self._addVar( 'LDEXE', '%(CCC)s -g' )
-+ self._addVar( 'LDEXE', '$(CXX) $(LDFLAGS)' )
-
- def setupPySvn( self ):
- self._pysvnModuleSetup()
-@@ -1129,6 +1128,7 @@
- self._addVar( 'PYTHON_INC', distutils.sysconfig.get_python_inc() )
-
- py_cflags_list = [
-+ '$(CXXFLAGS)',
- '-Wall -fPIC -fexceptions -frtti',
- '-I. -I%(APR_INC)s -I%(SVN_INC)s',
- '-DPYCXX_PYTHON_2TO3 -I%(PYCXX)s -I%(PYCXX_SRC)s -I%(PYTHON_INC)s',
-@@ -1145,7 +1145,7 @@
-
- self._addVar( 'CCCFLAGS', ' '.join( py_cflags_list ) )
- self._addVar( 'LDLIBS', ' '.join( self._getLdLibs() ) )
-- self._addVar( 'LDSHARED', '%(CCC)s -shared -g %(LDLIBS)s' )
-+ self._addVar( 'LDSHARED', '$(CXX) $(LDFLAGS) -shared' )
-
- #--------------------------------------------------------------------------------
- class LinuxCompilerGCC(UnixCompilerGCC):
diff --git a/dev-python/pysvn/files/pysvn-1.7.7-respect_flags.patch b/dev-python/pysvn/files/pysvn-1.7.7-respect_flags.patch
deleted file mode 100644
index e36171baeda3..000000000000
--- a/dev-python/pysvn/files/pysvn-1.7.7-respect_flags.patch
+++ /dev/null
@@ -1,95 +0,0 @@
---- Source/setup_configure.py
-+++ Source/setup_configure.py
-@@ -830,8 +830,8 @@
- def __init__( self, setup ):
- Compiler.__init__( self, setup )
-
-- self._addVar( 'CCC', 'g++' )
-- self._addVar( 'CC', 'gcc' )
-+ self._addVar( 'CCC', '$(CXX)' )
-+ self._addVar( 'CC', '$(CC)' )
-
- def getPythonExtensionFileExt( self ):
- return '.so'
-@@ -948,8 +948,8 @@
- else:
- arch_options = ''
-
-- self._addVar( 'CCC', 'g++ %s' % (arch_options,) )
-- self._addVar( 'CC', 'gcc %s' % (arch_options,) )
-+ self._addVar( 'CCC', '$(CXX) %s' % (arch_options,) )
-+ self._addVar( 'CC', '$(CC) %s' % (arch_options,) )
-
- self._find_paths_pycxx_dir = [
- '../Import/pycxx-%d.%d.%d' % pycxx_version,
-@@ -1014,12 +1014,12 @@
-
- def setupUtilities( self ):
- self._addVar( 'CCCFLAGS',
-- '-g '
-+ '$(CXXFLAGS) '
- '-no-long-double '
- '-Wall -fPIC -fexceptions -frtti '
- '-I. -I%(APR_INC)s -I%(SVN_INC)s '
- '-D%(DEBUG)s' )
-- self._addVar( 'LDEXE', '%(CCC)s -g' )
-+ self._addVar( 'LDEXE', '$(CXX) $(LDFLAGS)' )
-
- def setupPySvn( self ):
- self._pysvnModuleSetup()
-@@ -1031,7 +1031,7 @@
- self._addVar( 'PYTHON_INC', distutils.sysconfig.get_python_inc() )
-
- py_cflags_list = [
-- '-g',
-+ '$(CXXFLAGS)',
- '-no-long-double',
- '-Wall -fPIC -fexceptions -frtti',
- '-I. -I%(APR_INC)s -I%(SVN_INC)s',
-@@ -1058,13 +1058,12 @@
-
- self._addVar( 'CCCFLAGS', ' '.join( py_cflags_list ) )
- self._addVar( 'LDLIBS', ' '.join( py_ld_libs ) )
-- self._addVar( 'LDSHARED', '%(CCC)s -bundle -g '
-+ self._addVar( 'LDSHARED', '$(CXX) $(LDFLAGS) -bundle '
- '-framework System '
- '%(PYTHON_FRAMEWORK)s '
- '-framework CoreFoundation '
- '-framework Kerberos '
-- '-framework Security '
-- '%(LDLIBS)s' )
-+ '-framework Security' )
-
- class UnixCompilerGCC(CompilerGCC):
- def __init__( self, setup ):
-@@ -1124,11 +1123,11 @@
-
- def setupUtilities( self ):
- self._addVar( 'CCCFLAGS',
-- '-g '
-+ '$(CXXFLAGS) '
- '-Wall -fPIC -fexceptions -frtti '
- '-I. -I%(APR_INC)s -I%(SVN_INC)s '
- '-D%(DEBUG)s' )
-- self._addVar( 'LDEXE', '%(CCC)s -g' )
-+ self._addVar( 'LDEXE', '$(CXX) $(LDFLAGS)' )
-
- def setupPySvn( self ):
- self._pysvnModuleSetup()
-@@ -1138,6 +1137,7 @@
- self._addVar( 'PYTHON_INC', distutils.sysconfig.get_python_inc() )
-
- py_cflags_list = [
-+ '$(CXXFLAGS)',
- '-Wall -fPIC -fexceptions -frtti',
- '-I. -I%(APR_INC)s -I%(SVN_INC)s',
- '-DPYCXX_PYTHON_2TO3 -I%(PYCXX)s -I%(PYCXX_SRC)s -I%(PYTHON_INC)s',
-@@ -1154,7 +1154,7 @@
-
- self._addVar( 'CCCFLAGS', ' '.join( py_cflags_list ) )
- self._addVar( 'LDLIBS', ' '.join( self._getLdLibs() ) )
-- self._addVar( 'LDSHARED', '%(CCC)s -shared -g' )
-+ self._addVar( 'LDSHARED', '$(CXX) $(LDFLAGS) -shared' )
-
- #--------------------------------------------------------------------------------
- class LinuxCompilerGCC(UnixCompilerGCC):
diff --git a/dev-python/pysvn/pysvn-1.7.6.ebuild b/dev-python/pysvn/pysvn-1.7.6.ebuild
deleted file mode 100644
index da55ac512bb9..000000000000
--- a/dev-python/pysvn/pysvn-1.7.6.ebuild
+++ /dev/null
@@ -1,100 +0,0 @@
-# Copyright 1999-2013 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/pysvn/pysvn-1.7.6.ebuild,v 1.9 2013/01/13 11:40:59 ago Exp $
-
-EAPI=4
-PYTHON_DEPEND="*"
-SUPPORT_PYTHON_ABIS="1"
-RESTRICT_PYTHON_ABIS="*-jython 2.7-pypy-*"
-
-inherit eutils python toolchain-funcs
-
-DESCRIPTION="Object-oriented python bindings for subversion"
-HOMEPAGE="http://pysvn.tigris.org/"
-SRC_URI="http://pysvn.barrys-emacs.org/source_kits/${P}.tar.gz"
-
-LICENSE="Apache-1.1"
-SLOT="0"
-KEYWORDS="amd64 ~arm ~ppc x86 ~x86-freebsd ~amd64-linux ~x86-linux ~ppc-macos ~x86-solaris"
-IUSE="doc examples"
-
-DEPEND="
- >=dev-python/pycxx-6.2.0
- <dev-vcs/subversion-1.8" # (bug #395533)
-RDEPEND="${DEPEND}"
-
-src_prepare() {
- # Don't use internal copy of dev-python/pycxx.
- rm -fr Import
-
- epatch "${FILESDIR}/${P}-respect_flags.patch"
-
- # http://pysvn.tigris.org/source/browse/pysvn?view=rev&revision=1469
- sed -e "s/PYSVN_HAS_SVN_CLIENT_CTX_T__CONFLICT_FUNC_16/PYSVN_HAS_SVN_CLIENT_CTX_T__CONFLICT_FUNC_1_6/" -i Source/pysvn_svnenv.hpp
-
- python_copy_sources
-
- preparation() {
- cd Source
- if [[ "$(python_get_version -l)" == "2.5" ]]; then
- "$(PYTHON)" setup.py backport || die "Backport failed"
- fi
- }
- python_execute_function -s preparation
-}
-
-src_configure() {
- configuration() {
- cd Source
- "$(PYTHON)" setup.py configure \
- --pycxx-src-dir="${EPREFIX}/usr/share/python$(python_get_version)/CXX" \
- --apr-inc-dir="${EPREFIX}/usr/include/apr-1" \
- --apu-inc-dir="${EPREFIX}/usr/include/apr-1" \
- --svn-root-dir="${EPREFIX}/usr"
- }
- python_execute_function -s configuration
-}
-
-src_compile() {
- building() {
- cd Source
- emake CC="$(tc-getCC)" CXX="$(tc-getCXX)"
- }
- python_execute_function -s building
-}
-
-src_test() {
- testing() {
- cd Tests
- LC_ALL="en_US.UTF-8" emake
- }
- python_execute_function -s testing
-}
-
-src_install() {
- installation() {
- cd Source/pysvn
- exeinto "$(python_get_sitedir)/pysvn"
- doexe _pysvn*$(get_modname)
- insinto "$(python_get_sitedir)/pysvn"
- doins __init__.py
- }
- python_execute_function -s installation
-
- if use doc; then
- dohtml -r Docs/
- fi
-
- if use examples; then
- docinto examples
- dodoc Examples/Client/*
- fi
-}
-
-pkg_postinst() {
- python_mod_optimize pysvn
-}
-
-pkg_postrm() {
- python_mod_cleanup pysvn
-}
diff --git a/dev-python/pysvn/pysvn-1.7.7.ebuild b/dev-python/pysvn/pysvn-1.7.7.ebuild
deleted file mode 100644
index 3fb2c4acc083..000000000000
--- a/dev-python/pysvn/pysvn-1.7.7.ebuild
+++ /dev/null
@@ -1,72 +0,0 @@
-# Copyright 1999-2013 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/pysvn/pysvn-1.7.7.ebuild,v 1.3 2013/09/05 18:46:31 mgorny Exp $
-
-EAPI=5
-PYTHON_COMPAT=( python{2_6,2_7,3_2} )
-
-inherit eutils distutils-r1 toolchain-funcs
-
-DESCRIPTION="Object-oriented python bindings for subversion"
-HOMEPAGE="http://pysvn.tigris.org/"
-SRC_URI="http://pysvn.barrys-emacs.org/source_kits/${P}.tar.gz"
-
-LICENSE="Apache-1.1"
-SLOT="0"
-KEYWORDS="~amd64 ~arm ~ppc ~x86 ~x86-freebsd ~amd64-linux ~x86-linux ~ppc-macos ~x86-solaris"
-IUSE="doc examples"
-
-DEPEND="
- >=dev-python/pycxx-6.2.0
- <dev-vcs/subversion-1.8" # (bug #395533)
-RDEPEND="${DEPEND}"
-# Currently fail, no facility to add new issue upstream
-RESTRICT="test"
-
-python_prepare() {
- # Don't use internal copy of dev-python/pycxx.
- rm -fr Import
-
- epatch "${FILESDIR}"/${PN}-1.7.7-respect_flags.patch
-
- # http://pysvn.tigris.org/source/browse/pysvn?view=rev&revision=1469
- sed -e "s/PYSVN_HAS_SVN_CLIENT_CTX_T__CONFLICT_FUNC_16/PYSVN_HAS_SVN_CLIENT_CTX_T__CONFLICT_FUNC_1_6/" -i Source/pysvn_svnenv.hpp
-
- pushd Source > /dev/null
- if [[ "${EPYTHON:6:3}" == "2.5" ]]; then
- "${PYTHON}" setup.py backport || die "Backport failed"
- fi
-}
-
-python_configure() {
- cd Source
- # all config options from 1.7.6 are all already set
- "${PYTHON}" setup.py configure
-}
-
-python_compile() {
- cd Source
- emake CC="$(tc-getCC)" CXX="$(tc-getCXX)"
-}
-
-python_test() {
- cd Tests
- LC_ALL="en_US.UTF-8" emake
-}
-
-python_install() {
- cd Source/pysvn
- exeinto "$(python_get_sitedir)"/pysvn
- doexe _pysvn*$(get_modname)
- insinto "$(python_get_sitedir)"/pysvn
- doins __init__.py
-}
-
-python_install_all() {
- use doc && dohtml -r Docs/
-
- if use examples; then
- docinto examples
- dodoc Examples/Client/*
- fi
-}
diff --git a/dev-python/pysvn/pysvn-1.7.8.ebuild b/dev-python/pysvn/pysvn-1.7.8.ebuild
deleted file mode 100644
index 32967f5c00d4..000000000000
--- a/dev-python/pysvn/pysvn-1.7.8.ebuild
+++ /dev/null
@@ -1,66 +0,0 @@
-# Copyright 1999-2014 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/pysvn/pysvn-1.7.8.ebuild,v 1.6 2014/10/18 14:30:20 ago Exp $
-
-EAPI=5
-PYTHON_COMPAT=( python{2_6,2_7,3_2,3_3} )
-
-inherit eutils distutils-r1 toolchain-funcs
-
-DESCRIPTION="Object-oriented python bindings for subversion"
-HOMEPAGE="http://pysvn.tigris.org/"
-SRC_URI="http://pysvn.barrys-emacs.org/source_kits/${P}.tar.gz"
-
-LICENSE="Apache-1.1"
-SLOT="0"
-KEYWORDS="amd64 ~arm ppc x86 ~x86-freebsd ~amd64-linux ~x86-linux ~ppc-macos ~x86-solaris"
-IUSE="doc examples"
-
-DEPEND="
- >=dev-python/pycxx-6.2.0[${PYTHON_USEDEP}]
- <dev-vcs/subversion-1.9"
-RDEPEND="${DEPEND}"
-# Currently fail, no facility to add new issue upstream
-RESTRICT="test"
-
-python_prepare() {
- # Don't use internal copy of dev-python/pycxx.
- rm -r Import || die
-
- epatch "${FILESDIR}"/${PN}-1.7.7-respect_flags.patch
-
- # http://pysvn.tigris.org/source/browse/pysvn?view=rev&revision=1469
- sed -e "s/PYSVN_HAS_SVN_CLIENT_CTX_T__CONFLICT_FUNC_16/PYSVN_HAS_SVN_CLIENT_CTX_T__CONFLICT_FUNC_1_6/" -i Source/pysvn_svnenv.hpp
-
- if [[ ${EPYTHON} == python2.5 ]]; then
- cd Source || die
- "${PYTHON}" setup.py backport || die "Backport failed"
- fi
-}
-
-python_configure() {
- cd Source || die
- # all config options from 1.7.6 are all already set
- "${PYTHON}" setup.py configure
-}
-
-python_compile() {
- cd Source || die
- emake CC="$(tc-getCC)" CXX="$(tc-getCXX)"
-}
-
-python_test() {
- cd Tests || die
- LC_ALL="en_US.UTF-8" emake
-}
-
-python_install() {
- cd Source || die
- python_domodule pysvn
-}
-
-python_install_all() {
- use doc && local HTML_DOCS=( Docs/ )
- use examples && local EXAMPLES=( Examples/Client/. )
- distutils-r1_python_install_all
-}