summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorArfrever Frehtes Taifersar Arahesis <arfrever@gentoo.org>2010-07-08 18:03:24 +0000
committerArfrever Frehtes Taifersar Arahesis <arfrever@gentoo.org>2010-07-08 18:03:24 +0000
commitdb6232c4ca5a95fe51a4f6f8903477f9810d818d (patch)
tree9df0485823c5ed3367fd823118b38a4d91463cc2 /dev-python/python-fastcgi
parentRespect LDFLAGS wrt bug #325947 (diff)
downloadgentoo-2-db6232c4ca5a95fe51a4f6f8903477f9810d818d.tar.gz
gentoo-2-db6232c4ca5a95fe51a4f6f8903477f9810d818d.tar.bz2
gentoo-2-db6232c4ca5a95fe51a4f6f8903477f9810d818d.zip
Clean patch.
Diffstat (limited to 'dev-python/python-fastcgi')
-rw-r--r--dev-python/python-fastcgi/files/python-fastcgi-1.1-setup.patch39
1 files changed, 7 insertions, 32 deletions
diff --git a/dev-python/python-fastcgi/files/python-fastcgi-1.1-setup.patch b/dev-python/python-fastcgi/files/python-fastcgi-1.1-setup.patch
index d565dda17c93..6ce721a5e004 100644
--- a/dev-python/python-fastcgi/files/python-fastcgi-1.1-setup.patch
+++ b/dev-python/python-fastcgi/files/python-fastcgi-1.1-setup.patch
@@ -1,40 +1,15 @@
---- setup.py 2005-12-15 07:41:42.000000000 +0100
-+++ setup.py 2008-05-25 18:10:01.461135391 +0200
-@@ -1,18 +1,12 @@
--#from distutils.core import setup, Extension
--from ez_setup import use_setuptools
--use_setuptools()
--from setuptools import setup, Extension
-+#!/usr/bin/env python
+--- setup.py
++++ setup.py
+@@ -4,11 +4,7 @@
+ from setuptools import setup, Extension
-+from distutils import core
-+from distutils.extension import Extension
-c_ext = Extension("fcgi", ["fastcgi/pyfcgi.c"], libraries=["fcgi"],
- include_dirs=["/usr/local/include"],
- library_dirs=["/usr/local/lib"],
- #extra_link_args=["-s"],
- )
--
--setup(name="python-fastcgi",
-+core.setup(
-+ name="python-fastcgi",
++c_ext = Extension("fcgi", ["fastcgi/pyfcgi.c"], libraries=["fcgi"])
+
+ setup(name="python-fastcgi",
version="1.1",
-- description="Python wrapper for the Open Market FastCGI library",
-+ description="Python wrapper for the Open Market FastCGI library.",
- long_description="python-fastcgi is a lightweight wrapper around the Open Market FastCGI C Library/SDK. It includes threaded and forking WSGI 1.0 server implementations.",
- author="Cody Pisto",
- author_email="cody@hpcs.com",
-@@ -26,9 +20,7 @@
- "Programming Language :: C",
- "Topic :: Internet :: WWW/HTTP :: Dynamic Content :: CGI Tools/Libraries",
- "Topic :: Software Development :: Libraries :: Python Modules"],
-- packages=["fastcgi"],
-- #data_files=[("share/doc/python-fastcgi/example", ["example/test.fcgi"])],
-+ packages=['fastcgi'],
- ext_package='fastcgi',
-- ext_modules=[c_ext],
-- zip_safe=False,
-- )
-+ ext_modules=[Extension(name='fcgi', sources=['fastcgi/pyfcgi.c'], libraries=['fcgi'])],
-+)